dhcpd.conf domain-name not transmitted to /etc/resolv.conf

Bug #604581 reported by Matthew Paul Thomas on 2010-07-12
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Connection Manager
Medium
Kalle Valo
connman (Ubuntu)
Medium
Mathieu Trudel-Lapierre

Bug Description

Binary package hint: connman

connman 0.45+dfsg-0ubuntu1, Ubuntu 10.04

According to one of our sysadmins, dhcpd.conf contains:
------------
option domain-name "millbank";
------------

This is apparently supposed to result in these lines in /etc/resolv.conf:
------------
domain millbank
search millbank
------------

But it does not: no "domain" or "search" lines end up in resolv.conf at all.

Related branches

Kalle Valo (kvalo) wrote :

That's right, connman does not currently set either domain or search lines even though it receives them from the dhcp client.

Changed in connman (Ubuntu):
status: New → Confirmed
Changed in connman:
status: New → Confirmed
Kalle Valo (kvalo) wrote :

Henri Bragge posted patches upstream to fix this:

http://lists.connman.net/pipermail/connman/2010-December/002792.html

I haven't tested the patches myself, but hopefully they will be applied soon. If not, I'll include the patches as distro patches.

Changed in connman:
status: Confirmed → In Progress
assignee: nobody → Kalle Valo (kvalo)
Kalle Valo (kvalo) on 2010-12-07
Changed in connman:
importance: Undecided → Medium
Kalle Valo (kvalo) wrote :

Connman daily build version 0.64-0ubuntu1~ind1+r2955+201012080307 or later now has a fix for this. I quickly tested this and it seems to work.

I'll mark this bug fix released as soon as the fix is uploaded to natty (which might take some time).

Kalle Valo (kvalo) wrote :

The fix will be in connman 0.65.

Changed in connman:
status: In Progress → Fix Committed
Kalle Valo (kvalo) on 2011-02-08
Changed in connman (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium

Preparing to include this in a new connman upload.

Changed in connman (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package connman - 0.69-0ubuntu1

---------------
connman (0.69-0ubuntu1) natty; urgency=low

  * New upstream release.
    - dhcpd.conf domain-name not transmitted to /etc/resolv.conf (LP: #604581)
    - provide NM compatiblity code for applications which request network
      status (LP: #586033)
  * debian/control: explicitly Conflict with network-manager. (LP: #659460)
  * debian/rules: enable udev and the builtin dhclient during build.
  * debian/patches/04-wifi-add-a-disconnected-timer.patch: refreshed.
  * debian/patches/09-disable-wifi-legacy.patch: dropped.
  * debian/control: drop dhcp3-client Build-Depends, it's no longer required.
  * debian/patches/10-fix-dhcp-renewal-disconnect.patch: avoid disconnections
    caused by calling dhcp_bound() when DHCP renewal results in no IP change.
    (LP: #713146)
  * debian/control: Recommend indicator-network for UI. (LP: #704867)
  * debian/manpages/connmand.8: update to add BUGS section and fix AUTHORS
    (LP: #587779)
  * debian/control: Remove binary Depends on dhcp3-client for connman.
 -- Mathieu Trudel-Lapierre <email address hidden> Tue, 15 Feb 2011 23:43:45 -0600

Changed in connman (Ubuntu):
status: In Progress → Fix Released
Kalle Valo (kvalo) on 2011-03-14
Changed in connman:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers