Ubuntu

connman should be updated to version 1.9

Reported by Gustavo Sverzut Barbieri on 2012-11-18
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
connman (Debian)
Fix Released
Unknown
connman (Ubuntu)
Wishlist
Unassigned

Bug Description

ConnMan (http://connman.net/) was brought to Ubuntu as a possible alternative to NetworkManager some years ago. Although the test did not evolve (at least to replace NM), the package stayed at that version.

However ConnMan evolved quite a bit and is now at version 1.9. Since 1.0 the D-Bus API is stable, so it was adopted by some other projects such as Enlightenment DR 17 (E17), which is about to be released.

Moreover, the pre-1.0 branch had a security issue that was fixed.

The packaging should be pretty simple and trivial, one can see the requirements and options at their README (http://git.kernel.org/?p=network/connman/connman.git;a=blob;f=README;h=4ae17a9c1a66e94642c6d343b7a01a24681e130b;hb=HEAD) and configure.ac (http://git.kernel.org/?p=network/connman/connman.git;a=blob;f=configure.ac;h=286b71cf2cc6dde2393766674d7d5e285551d6d5;hb=HEAD)

To do 3G it uses oFono which is at 1.11 release (1.9 is packaged for Ubuntu), one may consider updating it as well.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in connman (Ubuntu):
status: New → Confirmed
tags: added: upgrade-software-version
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

summary: - connman should be updated to version 1.9
+ [needs-packaging] connman should be updated to version 1.9
Changed in connman (Ubuntu):
importance: Undecided → Wishlist
Logan Rosen (logan) on 2012-11-19
summary: - [needs-packaging] connman should be updated to version 1.9
+ connman should be updated to version 1.9
tags: removed: needs-packaging
Changed in connman (Debian):
status: Unknown → New

I recently sponsored connman 1.21-1 in Debian and it is - as of yesterday - now in unstable.

Ubuntu just needs to resync.

Cheers,

Adrian

Changed in connman (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.