[karmic] crashes with segmentation fault

Bug #401568 reported by Asif Youssuff on 2009-07-20
38
This bug affects 4 people
Affects Status Importance Assigned to Milestone
conduit (Ubuntu)
Undecided
Unassigned
pygoocanvas (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: conduit

Clicking on "show me" causes a crash.

asif@asif-desktop:~$ conduit
/usr/lib/conduit/modules/FacebookModule/FacebookModule.py:6: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import md5
Segmentation fault

Dragging over many of the choices on the left side to the right area also causes crashes.

ProblemType: Bug
Architecture: amd64
Date: Mon Jul 20 00:25:57 2009
DistroRelease: Ubuntu 9.10
Package: conduit 0.3.16-0ubuntu1
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-3.19-generic
SourcePackage: conduit
Uname: Linux 2.6.31-3-generic x86_64

Related branches

Asif Youssuff (yoasif) wrote :
Philippe Delodder (lodder) wrote :

Got the same issue on i386 Architecture

Alexandre Rosenfeld (airmind) wrote :

It's probably a bug in pygoocanvas, which unfortunately keeps coming back. Probably an update to that package would fix this problem. Hopefully before Karmic is released as it causes Conduit to be completely unusable.

Julien Lavergne (gilir) wrote :

I'll try to update pygoocanvas package to see if it's fix the bug.

Changed in conduit (Ubuntu):
status: New → Confirmed
Julien Lavergne (gilir) wrote :

Testing package for python-pygoocanvas is available in my PPA (https://edge.launchpad.net/~gilir/+archive/unstable). It fixes the problem for me. Can someone also confirm it please ?

Changed in pygoocanvas (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
Philippe Delodder (lodder) wrote :

Problem fixed for me after installing it.

Julien Lavergne (gilir) wrote :

Thanks Lodder, I'll try to push the fix ASAP.

Changed in conduit (Ubuntu):
status: Confirmed → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pygoocanvas - 0.14.1-0ubuntu1

---------------
pygoocanvas (0.14.1-0ubuntu1) karmic; urgency=low

  * New upstream release (LP: #409057)
   - Fix a crash on conduit (LP: #401568)
  * debian/control
   - Set build-depends of python-cairo-dev to >= 1.8.0
   - Set build-depends of libgoocanvas-dev to >= 0.14
  * debian/watch: Add.

 -- Julien Lavergne <email address hidden> Tue, 04 Aug 2009 23:16:25 +0200

Changed in pygoocanvas (Ubuntu):
status: In Progress → Fix Released
Alexandre Rosenfeld (airmind) wrote :

Thanks for the quick action Julien!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers