computer-janitor-gtk crashed with DBusException in call_blocking(): org.freedesktop.DBus.Python.computerjanitord.errors.PermissionDeniedError: com.ubuntu.computerjanitor.updatesystem

Bug #721244 reported by Adrian Borucki on 2011-02-18
452
This bug affects 48 people
Affects Status Importance Assigned to Milestone
computer-janitor (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: computer-janitor

I opened Computer Janitor and tried to deselect one option. When program asked me about password in order to remove programs I closed this dialogue and then appeared window informing about crash, even though program was still running.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: computer-janitor-gtk 2.1.0-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
Uname: Linux 2.6.38-1-generic x86_64
Architecture: amd64
Date: Fri Feb 18 13:26:32 2011
ExecutablePath: /usr/share/computerjanitor/computer-janitor-gtk
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110112)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/computerjanitor/computer-janitor-gtk
ProcEnviron:
 LANGUAGE=en_GB:en_US:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_GB.utf8
 SHELL=/bin/zsh
PythonArgs: ['/usr/share/computerjanitor/computer-janitor-gtk']
SourcePackage: computer-janitor
Title: computer-janitor-gtk crashed with DBusException in call_blocking(): org.freedesktop.DBus.Python.computerjanitord.errors.PermissionDeniedError: com.ubuntu.computerjanitor.updatesystem
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Adrian Borucki (gentoolx) wrote :
tags: removed: need-duplicate-check
visibility: private → public
tags: added: maverick
tags: added: bugpattern-needed

Judging from the duplicates, this bug appears to occur much more often on amd64 than i386, which is interesting. However, duplicate bug 738055 is with i386 (so I'm adding the i386 tag). All the other duplicates so far, as well as this original report, are with amd64.

tags: added: i386
Changed in computer-janitor (Ubuntu):
status: New → Confirmed
Kushal (hadakushal) on 2011-04-17
visibility: public → private

@Kushal
Why have you just changed this bug's visibility from public to private?

only meant to mark my duplicate

On Sat, Apr 16, 2011 at 10:26 PM, Eliah Kagan
<email address hidden>wrote:

> @Kushal
> Why have you just changed this bug's visibility from public to private?
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/721244
>
> Title:
> computer-janitor-gtk crashed with DBusException in call_blocking():
> org.freedesktop.DBus.Python.computerjanitord.errors.PermissionDeniedError:
> com.ubuntu.computerjanitor.updatesystem
>
> Status in “computer-janitor” package in Ubuntu:
> Confirmed
>
> Bug description:
> Binary package hint: computer-janitor
>
> I opened Computer Janitor and tried to deselect one option. When
> program asked me about password in order to remove programs I closed
> this dialogue and then appeared window informing about crash, even
> though program was still running.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.04
> Package: computer-janitor-gtk 2.1.0-0ubuntu3
> ProcVersionSignature: Ubuntu 2.6.38-1.28-generic 2.6.38-rc2
> Uname: Linux 2.6.38-1-generic x86_64
> Architecture: amd64
> Date: Fri Feb 18 13:26:32 2011
> ExecutablePath: /usr/share/computerjanitor/computer-janitor-gtk
> InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110112)
> InterpreterPath: /usr/bin/python2.7
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python
> /usr/share/computerjanitor/computer-janitor-gtk
> ProcEnviron:
> LANGUAGE=en_GB:en_US:en
> LANG=en_US.UTF-8
> LC_MESSAGES=en_GB.utf8
> SHELL=/bin/zsh
> PythonArgs: ['/usr/share/computerjanitor/computer-janitor-gtk']
> SourcePackage: computer-janitor
> Title: computer-janitor-gtk crashed with DBusException in call_blocking():
> org.freedesktop.DBus.Python.computerjanitord.errors.PermissionDeniedError:
> com.ubuntu.computerjanitor.updatesystem
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To unsubscribe from this bug, go to:
>
> https://bugs.launchpad.net/ubuntu/+source/computer-janitor/+bug/721244/+subscribe
>

--
Have a great day!

--

Kushal Hada
ETBU Box 6-631
1209 North Grove Street
Marshall, TX 75670
USA

Tel.: +1 903 472 5985 (Text messages welcome)
http://www.google.com/profiles/hadakushal

visibility: private → public
tags: added: oneiric
Brian Murray (brian-murray) wrote :

Information about the duplicates of this bug report:

LP: #721244 has a total of 39 duplicates
DistroRelease
  [29] Ubuntu 11.04: 722825, 722827, 728972, 738055, 743543, 747947, 748081, 749002, 750721, 751762, 752488, 752514, 753600, 753609, 753759, 756258, 756655, 756820, 759740, 761716, 762013, 762220, 762332, 765666, 766506, 766566, 767057, 779337, 810703
  [9] Ubuntu 11.10: 844958, 850332, 854441, 862046, 865660, 869855, 880149, 883682, 889617
  [1] Ubuntu 10.10: 727650

tags: removed: bugpattern-needed
tags: added: bugpattern-written
Changed in computer-janitor (Ubuntu):
importance: Undecided → Medium
Andreas Jährig (washuu-de) wrote :

It also affects Ubuntu 12.04.

tags: added: precise

this bug report is still open? what further action will be taken on it.

To post a comment you must log in.