Ubuntu

dbus.proxies:Introspect error when cleaning up prevents clean up action

Reported by Jamie Strandboge on 2010-11-17
74
This bug affects 14 people
Affects Status Importance Assigned to Milestone
computer-janitor (Ubuntu)
Critical
Barry Warsaw
gnome-control-center (Ubuntu)
Undecided
Unassigned
policykit (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: computer-janitor

If I start computer-janitor-gtk from a terminal on up to date natty and click the 'Clean up' button, I am given the following dialog:

"System clean up failure. System clean up could not complete. Be sure no other package manager such as Synaptic or Update Manager is running."

Here is the terminal output:
$ computer-janitor-gtk
/usr/share/computerjanitor/computerjanitorapp/gtk/ui.py:94: GtkWarning: Could not load image 'computerjanitor-24x24.png': Failed to open file '/usr/share/computer-janitor/computerjanitor-24x24.png': No such file or directory
  builder.add_from_file(glade_file)
ERROR:dbus.proxies:Introspect error on :1.136:/: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: Rejected send message, 1 matched rules; type="method_call", sender=":1.139" (uid=1000 pid=11347 comm="/usr/bin/python) interface="org.freedesktop.DBus.Introspectable" member="Introspect" error name="(unset)" requested_reply=0 destination=":1.136" (uid=0 pid=10718 comm="/usr/bin/python))
org.freedesktop.PolicyKit1.Error.Failed: Error getting subject: Error parsing unix-process subject: Value for key `start-time' found but is of type i and type t was expected

This looks to be related to bug #676485.

Jamie Strandboge (jdstrand) wrote :

Marking as Critical since it renders the package completely unusable.

Changed in computer-janitor (Ubuntu):
importance: Undecided → Critical
Bharath Ramesh (krosswindz) wrote :

Could bug #665740 also be related to this.

Matteo Settenvini (tchernobog) wrote :

Happens also in gnome-keyboard-properties in Natty when you try to apply globally your changes (try running that from the console, and look for the output):

root@orchid:~# gnome-keyboard-properties
dpy: 0x1babc50
evt/error/major/minor: 97/156/1/0

(gnome-keyboard-properties:4093): Gtk-CRITICAL **: IA__gtk_window_resize: assertion `width > 0' failed

(gnome-keyboard-properties:4093): Gtk-WARNING **: Can't set a parent on a toplevel widget

dpy: 0x1babc50
evt/error/major/minor: 97/156/1/0
dpy: 0x1babc50
evt/error/major/minor: 97/156/1/0

(gnome-keyboard-properties:4093): Gtk-WARNING **: Can't set a parent on a toplevel widget

Caught remote method exception org.freedesktop.PolicyKit1.Error.Failed: Error getting subject: Error parsing unix-process subject: Value for key `start-time' found but is of type i and type t was expected

SWmail (swmail) on 2011-01-11
Changed in computer-janitor (Ubuntu):
status: New → Confirmed
Timo Witte (spacefish) wrote :

Same here, can´t change my keyboard layout!

Changed in computer-janitor (Ubuntu):
assignee: nobody → Timo Witte (5-launchpad-spacefish-biz)
assignee: Timo Witte (5-launchpad-spacefish-biz) → nobody
Barry Warsaw (barry) wrote :

Bug 665740 is a different problem.

It's not possible to change keyboard layout or network proxy system-wide because of this.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Changed in policykit (Ubuntu):
status: New → Confirmed
Barry Warsaw (barry) wrote :

Still investigating, but I suspect this is a bug in polkit since:

1) the same code for CJ works in maverick
2) this bug is affecting multiple different packages

I'm guessing that the type for start-time got erroneously changed from uint64 to string. This page still describes start-time's time to be the former:

http://hal.freedesktop.org/docs/polkit/eggdbus-interface-org.freedesktop.PolicyKit1.Authority.html

Barry Warsaw (barry) wrote :

The problem is that automatic type conversion of 0 gives you a UInt32(0) under Natty, where a UInt64(0) is expected. You have to be explicit about the type conversion for start-time. I have a patch for computer-janitor that I'll propose momentarily.

Changed in computer-janitor (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Barry Warsaw (barry)
milestone: none → natty-alpha-2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package computer-janitor - 2.0.4-0ubuntu3

---------------
computer-janitor (2.0.4-0ubuntu3) natty; urgency=low

  * debian/control: Add explicit dependency on dbus since depending on
    python-dbus does not yield an implicit dependency on dbus. (LP: #665740)
  * computerjanitord/authenticator.py: Explicitly convert start-time to a
    UInt64(0). Under Natty, implicit conversion uses a UInt32 which does
    not match the CheckAuthorization signature. (LP: #676488)
 -- Barry Warsaw <email address hidden> Thu, 13 Jan 2011 12:56:20 -0500

Changed in computer-janitor (Ubuntu):
status: In Progress → Fix Released

I can not reproduce this bug anymore (even on proxy settings or keyboard configuration).

Can someone confirm that this bug is fixed?

On Feb 02, 2011, at 11:13 AM, Marco Biscaro wrote:

>I can not reproduce this bug anymore (even on proxy settings or keyboard
>configuration).
>
>Can someone confirm that this bug is fixed?

It's definitely fixed for C-J. I don't know if the other packages were
patched the same way, or whether some change in python-dbus was made to fix it
for all clients.

Almost sure that is fixed. Setting it as so.

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Fix Released
Changed in policykit (Ubuntu):
status: Confirmed → Fix Released

Still not resolved in Maverick.

what can I do?

thank you

Zoubidoo (zoubidoo) wrote :

Fixed? Not for me:

$ computer-janitor find
ERROR:dbus.proxies:Introspect error on :1.368:/: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: Rejected send message, 1 matched rules; type="method_call", sender=":1.371" (uid=1000 pid=28230 comm="/usr/bin/python /usr/sbin/computer-janitor find ") interface="org.freedesktop.DBus.Introspectable" member="Introspect" error name="(unset)" requested_reply=0 destination=":1.368" (uid=0 pid=27306 comm="/usr/bin/python /usr/share/computerjanitor/janitor"))

computer-janitor 2.1.0-0ubuntu4
Ubuntu 11.04

Can we please re-open?

Barry Warsaw (barry) wrote :

On Jan 11, 2012, at 09:12 PM, Zoubidoo wrote:

>Fixed? Not for me:
>
>$ computer-janitor find
>ERROR:dbus.proxies:Introspect error on :1.368:/: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: Rejected send message, 1 matched rules; type="method_call", sender=":1.371" (uid=1000 pid=28230 comm="/usr/bin/python /usr/sbin/computer-janitor find ") interface="org.freedesktop.DBus.Introspectable" member="Introspect" error name="(unset)" requested_reply=0 destination=":1.368" (uid=0 pid=27306 comm="/usr/bin/python /usr/share/computerjanitor/janitor"))
>
>computer-janitor 2.1.0-0ubuntu4
>Ubuntu 11.04
>
>Can we please re-open?

I think that's bug 715707.

https://bugs.launchpad.net/ubuntu/+source/computer-janitor/+bug/715707

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers