Computer Janitor gives misleading error message "close other package managers" when none are running

Bug #657198 reported by Lachy Clark on 2010-10-09
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
computer-janitor (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: computer-janitor

I start Computer Janitor,
Click Do Selected Tasks
Clear list, Enter sudo password, done
then get error:
"System clean up could not complete, be sure no other package manager such as Synaptic or Update Manager is running."
But there are no other package managers running, processes or programs running for that instance...
Is this a virus, i doubt it seeing as ubuntu is virtually immune, or a bug?
 I have just upgraded to Ubuntu 10.10
Thanks all help is appreciated,
Im a massive noob, oh and F&*# windows, just quietly :)

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at https://answers.launchpad.net/ubuntu if you are uncertain if they are bugs. For help on reporting bugs, see https://help.ubuntu.com/community/ReportingBugs#When%20not%20to%20file%20a%20bug.

Changed in computer-janitor (Ubuntu):
status: New → Invalid

I can reproduce the OP's report, computer-janitor's error message is misleading.

Sorry again for closing the bug first. I can confirm the behaviour you described. To make sure it is the same issue, could you please check the following:
* Start computer janitor from a terminal, i.e. open Applications > Accessories > Terminal and type
computer-janitor-gtk
* Do the same steps you did before and copy&paste the output on the terminal here.

Thanks!

Changed in computer-janitor (Ubuntu):
status: Invalid → Incomplete

No worries, here you go:
lokdog@lokdog:~$ computer-janitor-gtk
/usr/share/computerjanitor/computerjanitorapp/gtk/ui.py:94: GtkWarning:
Could not load image 'computerjanitor-24x24.png': Failed to open file
'/usr/share/computer-janitor/computerjanitor-24x24.png': No such file or
directory
  builder.add_from_file(glade_file)
lokdog@lokdog:~$

however after this the program opened, but did the same thing as before.
over to you

On Sat, 2010-10-09 at 09:08 +0000, Marcel Stimberg wrote:
> Sorry again for closing the bug first. I can confirm the behaviour you described. To make sure it is the same issue, could you please check the following:
> * Start computer janitor from a terminal, i.e. open Applications > Accessories > Terminal and type
> computer-janitor-gtk
> * Do the same steps you did before and copy&paste the output on the terminal here.
>
> Thanks!
>
> ** Changed in: computer-janitor (Ubuntu)
> Status: Invalid => Incomplete
>

Hm, that's odd. It should show an error message in the terminal when it opens the "System clean up could not complete..." dialog.
The error messages you posted will appear before you do anything in the computer janitor -- are you sure you did the full process (Click on "Do selected tasks", enter password, wait for the message to appear and close the message)?

Sorry mate I thought you wanted the script from the terminal, that's all
saw in the terminal. after doing what you said, the terminal said this :

"lokdog@lokdog:~$ computer-janitor-gtk
/usr/share/computerjanitor/computerjanitorapp/gtk/ui.py:94: GtkWarning:
Could not load image 'computerjanitor-24x24.png': Failed to open file
'/usr/share/computer-janitor/computerjanitor-24x24.png': No such file or
directory
  builder.add_from_file(glade_file)
org.freedesktop.DBus.Python.SystemError: Traceback (most recent call
last):
  File "/usr/lib/pymodules/python2.6/dbus/service.py", line 702, in
_message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/share/computerjanitor/computerjanitord/service.py", line
273, in clean
    self.collector.clean(names, self.dry_run)
  File "/usr/share/computerjanitor/computerjanitord/collector.py", line
126, in clean
    cruft.cleanup()
  File
"/usr/lib/python2.6/dist-packages/computerjanitor/package_cruft.py",
line 57, in cleanup
    self._pkg.markDelete()
  File "/usr/lib/python2.6/dist-packages/apt/deprecation.py", line 78,
in deprecated_function
    return func(*args, **kwds)
  File "/usr/lib/python2.6/dist-packages/apt/deprecation.py", line 98,
in deprecated_function
    return func(*args, **kwds)
  File "/usr/lib/python2.6/dist-packages/apt/package.py", line 1190, in
mark_delete
    fix.resolve()
SystemError: E:Error, pkgProblemResolver::Resolve generated breaks, this
may be caused by held packages.

As I said before, there are NO package managers running, or any other
reason why it should stop working... cheers:)
 Sat, 2010-10-09 at 15:20 +0000, Marcel Stimberg wrote:
> Hm, that's odd. It should show an error message in the terminal when it opens the "System clean up could not complete..." dialog.
> The error messages you posted will appear before you do anything in the computer janitor -- are you sure you did the full process (Click on "Do selected tasks", enter password, wait for the message to appear and close the message)?
>

Thanks, that confirms my observation. The problem is that computer janitor gives the error message you encountered whenever *something* goes wrong during the deletion process. In my case it try to delete files that did not exist, in your case there seems to be a conflict between packages (that occasionally happens if you work with a pre-release version).

To fix your problem you should open the synaptic package manager (System > Administration) and chose Edit > Fix broken packages. After this is fixed, computer janitor should work as well.

summary: - Computer Janitor wont delete files, saying close other package managers,
- but there are none running...? help?
+ Computer Janitor gives misleading error message "close other package
+ managers" when none are running
Changed in computer-janitor (Ubuntu):
status: Incomplete → Confirmed

Hello Marcel,
thankyou for your advice, I did as you advised, but found that i have no
broken packages to fix, so i clicked on it, but nothing happened, and
then tried to use janitor again to no avail... any more options? thanks
again

On Sun, 2010-10-10 at 09:53 +0000, Marcel Stimberg wrote:
> Thanks, that confirms my observation. The problem is that computer
> janitor gives the error message you encountered whenever *something*
> goes wrong during the deletion process. In my case it try to delete
> files that did not exist, in your case there seems to be a conflict
> between packages (that occasionally happens if you work with a pre-
> release version).
>
> To fix your problem you should open the synaptic package manager (System
> > Administration) and chose Edit > Fix broken packages. After this is
> fixed, computer janitor should work as well.
>
> ** Summary changed:
>
> - Computer Janitor wont delete files, saying close other package managers, but there are none running...? help?
> + Computer Janitor gives misleading error message "close other package managers" when none are running
>
> ** Changed in: computer-janitor (Ubuntu)
> Status: Incomplete => Confirmed
>

I'm not sure whether the problem has anything to do with computer-janitor (which, by the way, I can't really recommend...) or with an incomplete update and some problems with your packages.
In a terminal, could you try:
sudo apt-get clean
sudo apt-get update
sudo apt-get upgrade

And if you do get any warnings about conflicts, unmet dependencies etc.:
sudo apt-get -f install

shankao (shankao) wrote :

I'm getting this error as well and the broken packages fix does not seem to make any effect. Anyway, I get this message in the command line after clicking on "Do the selected tasks":

org.freedesktop.PolicyKit1.Error.Failed: Error getting subject: Error parsing unix-process subject: Value for key `start-time' found but is of type i and type t was expected

Mark Lancas (red-soviet91) wrote :

Hello, i have the same problem as well, when i want to remove the unwanted application by the Janitor, it gave the misleading message. I solved this by running in terminal:

sudo apt-get autoremove

hope this helps

shankao (shankao) wrote :

I have not this problem anymore with the last natty package

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers