Update FIXME strings

Bug #552777 reported by Barry Warsaw on 2010-03-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
computer-janitor (Ubuntu)
Medium
Barry Warsaw

Bug Description

Binary package hint: computer-janitor

In order to pass FFe for Lucid since we're in between beta 1 and 2, I've reverted a few modified strings to their Karmic (i.e. already translated) versions. I've marked them as FIXME in the source and included this bug #. For Lucid + 1 these FIXMEs should be restored to their improved strings.

Related branches

Barry Warsaw (barry) on 2010-03-31
Changed in computer-janitor (Ubuntu):
milestone: none → later
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Barry Warsaw (barry)
Barry Warsaw (barry) on 2010-04-15
Changed in computer-janitor (Ubuntu):
status: Confirmed → In Progress
Barry Warsaw (barry) on 2010-04-15
Changed in computer-janitor (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package computer-janitor - 2.0.1-0ubuntu1

---------------
computer-janitor (2.0.1-0ubuntu1) maverick; urgency=low

  * Bumping for Ubuntu.

computer-janitor (2.0.1~ppa1) lucid; urgency=low

  * Display dialog in gtk version when another package manager is running,
    preventing package plugin post-cleanup from completing. (LP: #545306)

computer-janitor (2.0~ppa0) lucid; urgency=low

  * Since CJ 2.0 won't make it into Lucid, do Maverick updates now.
    (LP: #552777)
    - Give computer-janitor-gtk --help and --version command line args.
    - Revert translatable strings to post-Lucid improvements
    - Make string substitutions more consistent
    - Update po

computer-janitor (2.0-0ubuntu5) lucid; urgency=low

  * Move some FIXME comments around for less gettext confusion.

computer-janitor (2.0-0ubuntu4) lucid; urgency=low

  * FFe review resolution (LP: #541990)
    - Reverted some strings back to Karmic versions to satisfy FFe for C-J
      2.0 in Lucid. Strings marked with FIXME for updating in Lucid+1.
    - Catch DBusExceptions in both cli and gtk front-ends and print a
      better error message.

computer-janitor (2.0-0ubuntu3) lucid; urgency=low

  * Some cleanup indicated by visual inspection.
    - Move more exception classes to the error.py module.
    - Update docstring.
    - Do not translate logged error messages (can make log analysis
      scripts more difficult).
    - Update copyright years in About dialog.

computer-janitor (2.0-0ubuntu2) lucid; urgency=low

  * Disable the Do... button when there is no cruft to clean up.

computer-janitor (2.0-0ubuntu1) lucid; urgency=low

  * Refactor all package change operations into a dbus service.
    - Switch to using python-argparse
    - Extend functionality of cli version
    - Change format for state.dat ini file
 -- Barry Warsaw <email address hidden> Fri, 21 May 2010 16:55:46 -0400

Changed in computer-janitor (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers