computer janitor not responsive while running

Bug #451833 reported by Leandro on 2009-10-15
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
computer-janitor (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: computer-janitor

When applying changes using computer janitor, it becomes irresponsive and I see the
attached image. It worked, didn't crash, but that behavior is not a very good user
experience.

Leandro (leandromartinez98) wrote :
to be removed (liw) wrote :

This is true. I don't know why it happens, and didn't find the cause in time for karmic, I'm afraid.

Changed in computer-janitor (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Jaromir Obr (jaromir-obr) wrote :

For me, it occurred when removing "xulrunner-1.9-gnome-support". Computer-janitor maybe was waiting for finishing of that action, but nothing happened (see attached stdout, last logged info is "Post-cleanup"). Strange is that when I interrupted it using Ctrl+C, killed the computer-janitor and started again, I found out that the package xulrunner was really uninstalled.
I tried to start computer-janitor several times, but it always failed in the same way (but on various packages).

IMHO some progress of running actions should be displayed in computer-janitor.
Currently computer-janitor is fast unusable for me.

Used SW:
Ubuntu 9.10, amd64

Michael Vogt (mvo) on 2009-11-10
Changed in computer-janitor (Ubuntu):
status: Confirmed → Fix Committed
Michael Vogt (mvo) wrote :

This should be fixed in bzr now, its not that intrusive, we might consider backporting it for karmic-proposed. Its more than just a UI bug because the karmic version seems to sometimes deadlock as well.

Michael Vogt (mvo) on 2009-11-10
Changed in computer-janitor (Ubuntu):
status: Fix Committed → Confirmed
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package computer-janitor - 1.14-0ubuntu1

---------------
computer-janitor (1.14-0ubuntu1) lucid; urgency=low

  * New upstream release:
    - merge fixes from Julian Andres Klode (many thanks)
    - threading improvements
    - optimization
    - improve the UI responsiveness
  * The above threading/UI changes should fix LP: #451833
    (needs a updated update-manager-core as well)
  * debian/control:
    - remove the python-glade2 dependency (we use gtkbuilder)
    - set XS-Python-Version to "current" to workaround strange
      effect that python-support generates 2.5 headers for the
      binaries otherwise
 -- Michael Vogt <email address hidden> Wed, 25 Nov 2009 10:00:18 +0100

Changed in computer-janitor (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers