Computer-janitor do not display locale language, only English

Bug #437827 reported by Tao Wei on 2009-09-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Translations
Undecided
Adi Roiban
computer-janitor (Ubuntu)
High
Unassigned
Karmic
High
Unassigned

Bug Description

Binary package hint: computer-janitor

The simplified chinese translation is 100% done, but the software display only English (just two words show in chinese).

The translation computerjanitor.mo is installed properly.

ProblemType: Bug
Architecture: i386
Date: Sun Sep 27 22:32:14 2009
DistroRelease: Ubuntu 9.10
Package: computer-janitor 1.13.3-0ubuntu1
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=zh_CN.UTF-8
 LANG=zh_CN.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.35-generic
SourcePackage: computer-janitor
Uname: Linux 2.6.31-10-generic i686

Tao Wei (weitao1979) wrote :
Tao Wei (weitao1979) wrote :

the translation is done

to be removed (liw) wrote :

Is the translation included in a version of the relevant language pack installed on your system?

Changed in computer-janitor (Ubuntu):
status: New → Incomplete
Tao Wei (weitao1979) wrote :

Lars Wirzenius, the translation is installed.

And I tried directly download the mo file from the LP (Karmic) and copy it into my Karmic, the same, only the name "Computer Janitor" is translated into chinese.

to be removed (liw) wrote :

Do you have an up-to-date computerjanitorapp.mo? The translations are divided into two .mo files (one for the backend, one for the frontend).

Tao Wei (weitao1979) wrote :

yes i have.

And i tried install a new karmic in virtualbox, and update it, the computer janitor shows only English.

I can confirm this, fully updated Karmic with the app translated into Polish, and the interface is in English completely, apart from the small dialog window asking if I really want to remove unused packages. Something is wrong with computer-janitor still. Maybe the translation domain is not set explicitly in all of the gtkbuilder ui files?

This is how it looks http://imgur.com/dARvm.png

Changed in computer-janitor (Ubuntu):
status: Incomplete → Confirmed
tags: added: i18n
David Planella (dpm) wrote :

Lars,

I can confirm this as well. You are mentioning there are two .mo files, which would correspond to two translation templates.

In the 'computer-janitor' source package I can only see the 'computerjanitor' template with the 'computerjanitor' domain at https://translations.launchpad.net/ubuntu/jaunty/+source/computer-janitor/ Is there another template I'm missing somewhere else?

Sebastien Bacher (seb128) wrote :

Confirmed on current karmic the translations are not working

Changed in computer-janitor (Ubuntu):
importance: Undecided → High
Changed in computer-janitor (Ubuntu Karmic):
assignee: nobody → Lars Wirzenius (liw)
to be removed (liw) on 2009-10-05
Changed in computer-janitor (Ubuntu Karmic):
status: Confirmed → Fix Committed
Changed in ubuntu-translations:
status: New → Fix Committed
Adi Roiban (adiroiban) on 2009-10-05
Changed in ubuntu-translations:
assignee: nobody → Adi Roiban (adiroiban)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package computer-janitor - 1.13.3-0ubuntu2

---------------
computer-janitor (1.13.3-0ubuntu2) karmic; urgency=low

  * Undid changes in previous release wrt UI and threading changes,
    since they didn't seem to fix the problem.
  * Set the gettext translation domain for GtkBuilder.
    (Closes: LP: #437827)
  * The "bored now" message dialog is used properly.

 -- Lars Wirzenius <email address hidden> Wed, 16 Sep 2009 17:19:28 +0300

Changed in computer-janitor (Ubuntu Karmic):
status: Fix Committed → Fix Released
Adi Roiban (adiroiban) on 2009-10-14
Changed in ubuntu-translations:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers