computer janitor "cleanup" button sensitive when there's nothing to clean up

Bug #418319 reported by Mathieu on 2009-08-24
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
computer-janitor (Ubuntu)
Low
Unassigned

Bug Description

starting the computer janitor using the system menu always starts the janitor in an empty way. i.e. I see 3 column, but there are always empty. I just can choose the button clean, which is then asking me if I do understand that the program will clean something. But what...? I have no information, as everything is white.

Additional information
karmic koala alpha 4
Linux pelerin 2.6.31-6-generic #26-Ubuntu SMP Fri Aug 21 17:48:16 UTC 2009 i686 GNU/Linux
computer-janitor-gtk_1.13.2-0ubuntu1_all.deb

Mathieu (mathieu-weber-ubuntu) wrote :
arky (arky) on 2009-08-26
affects: ubuntu → computer-janitor (Ubuntu)
pvdeynse (vandeynse) wrote :

have similar problem.
I would like to cleanup the many linux kernels still on my sytem, but janitor gives empty screen, even worse clicking on "Do selected tasks" and selecting "Remove packages" hangs janitor application. I need to kill the application.

here is my system:

Linux pvdeynse-desktop 2.6.31-8-generic #28-Ubuntu SMP Thu Aug 27 14:43:30 UTC 2009 i686 GNU/Linux

ii computer-janitor 1.13.2-0ubuntu1 clean up a system so it's more like a freshly installed one
ii computer-janitor-gtk 1.13.2-0ubuntu1 clean up a system so it's more like a freshly installed one

Changed in computer-janitor (Ubuntu):
status: New → Confirmed
to be removed (liw) wrote :

If the janitor shows nothing to clean, then it doesn't find anything wrong in your system. That's probably a good thing.

The button should be greyed out in that case, though. I'll retitle the bug to indicate that as the problem.

pvendeyse, please file a separate bug about your problem, as I suspect something else is going on there. If you can, run it from the command line, and attach the output to the terminal as well.

summary: - computer janitor window is always empty
+ computer janitor "cleanup" button sensitive when there's nothing to
+ clean up
Changed in computer-janitor (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Mathieu (mathieu-weber-ubuntu) wrote :

I do have older packages installed (e.g. older kernel version) which aren't displayed in the actual janitor. They did appear in a previous version. So I am not really sure if it is only an issue regarding greying out a button.

to be removed (liw) wrote :

Mathieu, the janitor's heuristics for guessing what can be removed have changed. It is now much more careful about suggesting things to remove. This is not a bug.

Mathieu (mathieu-weber-ubuntu) wrote :

Lars, thank you for this hint about these new rules, I didn't know these changes.

to be removed (liw) on 2009-09-07
Changed in computer-janitor (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package computer-janitor - 1.13.3-0ubuntu1

---------------
computer-janitor (1.13.3-0ubuntu1) karmic; urgency=low

  * New upstream release. Fixes the following bugs in Ubuntu:
    - incomplete translation template (Closes: LP: #425018)
    - "cleanup" button sensitive when there's nothing to clean up
      (Closes: LP: #418319)
    - wrong launchpad page link in about box (Closes: LP: #417309)
  * Also, upstream re-introduced the "unsupported package" plugin, and
    the Ubuntu packaging added a default whitelist file listing the
    most common manually installed third-party packages.

 -- Lars Wirzenius <email address hidden> Wed, 09 Sep 2009 17:37:19 +0300

Changed in computer-janitor (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers