"composer create-project drupal/drupal hellodrupal 8.0.0" throws error

Bug #1530204 reported by Dan Kegel on 2015-12-30
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
composer (Ubuntu)
Undecided
Unassigned

Bug Description

Created a fresh ubuntu 15.10 container, tried using composer to install drupal8:
--- snip ---
$ sudo apt-get install composer
$ composer create-project drupal/drupal hellodrupal 8.0.0
  - Installing drupal/drupal (8.0.0)
    Cloning ca30166e37ed78e1f9920dc42a82396d98d2a3f4

Created project in hellodrupal
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Nothing to install or update
Generating autoload files
Script Drupal\Core\Composer\Composer::preAutoloadDump handling the pre-autoload-dump event terminated with an exception

  [UnexpectedValueException]
  Invalid version string ">"
--- snip ---

Was considering reporting this to the composer folks, but I see that version of composer
doesn't even know its own version:
$ composer --version
Composer version @package_branch_alias_version@ (@package_version@) @release_date@

Uninstalling this composer and using the dreaded "curl | php" method to install it worked around both problems,
so it looks like ubuntu's composer needs to be refreshed from upstream.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: composer 1.0.0~alpha10+20150602-1
ProcVersionSignature: Ubuntu 4.2.0-22.27-generic 4.2.6
Uname: Linux 4.2.0-22-generic x86_64
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
Date: Wed Dec 30 20:01:20 2015
JournalErrors:
 No journal files were found.
 -- No entries --
PackageArchitecture: all
SourcePackage: composer
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Dan Kegel (dank) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in composer (Ubuntu):
status: New → Confirmed
Revision history for this message
pwaring (launchpad-pwaring) wrote :

Is this bug still valid? 15.10 has been unsupported for over two years now and 18.04 has a more recent version of Composer (although still behind upstream, which I'm hoping to fix with a Snap or PPA).

Revision history for this message
Dan Kegel (dank) wrote :

Tested as follows on ubuntu 18.04:

$ apt-get install lxd lxd-client
$ lxd init
$ lxc launch ubuntu:18.04 ubu1804-demo
$ lxc exec ubu1804-demo bash
# apt update
# apt install composer
# composer --version
Composer 1.6.3 2018-01-31 16:28:17
# composer create-project drupal/drupal hellodrupal 8.5.6

That completed with some warnings and no crash.

This bug can be closed as 'fixed in ubuntu 18.04'.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers