ccsm profile handling bug

Bug #876709 reported by Petko Ditchev on 2011-10-17
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
compizconfig-settings-manager (Ubuntu)
Undecided
Unassigned

Bug Description

 In Oneiric (11.10) compiz (yes the 0.9.6 with 0.9.5 ccsm (last version)) has a bug with both gnome-shell and unityshell . It might be only a ccsm bug but I'm not too sure so I haven't listed it as one .

Here's the overall situation : ccsm with gconf backend cannot correctly handle profiles . For example if you add or import a profile - it shows up in the .gconf/.../profiles directory but it doesn't activate correctly and makes all sorts of bugs on restart etc.

Next thing is that when a profile is added it doesn't appear in the profiles list correctly (under any circumstances (for ex. change to flat backend , gnome shell,unity...) ) . Some profile (or 2) appear/s with a name of non-valid characters , and I'm pretty sure that's not the added/imported one . This invalid thing doesn't get erased and changes its random name from time to time .

That's what I can think of for now (I tinkered the configuration files a lot but concluded only that they behave strange ) .

edit : Just did a complete removal of compiz and unity (got into some fiasko with getting back in ubuntu and had to install gdm) and got back into the configuration compiz ,unity (this time over gdm) and without touching anything ccsm showed the same on profiles : Default and " *(#$ " (but with some freakier characters) .

IKT (ikt) on 2011-10-17
affects: ubuntu → simple-ccsm (Ubuntu)
affects: simple-ccsm (Ubuntu) → compizconfig-settings-manager (Ubuntu)
IKT (ikt) wrote :

Setting against ccsm, if they can verify the issue so much the better, if not we can go from there.

Petko Ditchev (pditchev) wrote :

Can someone with 11.10 try to replicate (just go in ccsm and click on the profiles list) , I want to know if it's common for the distro or it might help to reinstall ubuntu .

description: updated
Lem (lem-jjr) wrote :

This affects me too, and many others I know who have used Ubuntu 11.10 and tried to go to the Preferences/profiles area in CCSM.. totally borks compiz's config, causes unity not to load, etc.. seen it consistent across about 5 installations, one of which was an upgrade from 11.04, the other four fresh installs.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compizconfig-settings-manager (Ubuntu):
status: New → Confirmed
Petko Ditchev (pditchev) wrote :

Can someone from the ccsm team direct me to where to search for the bug ?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers