compiz config settings manager cant change resize window shortcut

Bug #146736 reported by Kuklujis on 2007-09-29
68
This bug affects 7 people
Affects Status Importance Assigned to Milestone
compizconfig-settings-manager (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: compizconfig-settings-manager

I cant change resize window mouse shortcut to <Control>Button1.

Furthermore, when i try to change it, it changes move window shortcut instead somehow.
It even changed move window to just Button1, so i effectively lost the most important mouse button,
since instead of normal clicks, it just moved around windows..
So this is pretty serious i think.

Dmitri Nikulin (dnikulin) wrote :

More clarity on my case, seen on every machine I have installed Ubuntu Gutsy Beta on.

* Attempt to set "Initiate Window Resize" to <Alt>Button3 instead of <Alt>Button2
   The request is completely ignored, nothing changes and no warning of replacing Initiate Window Menu is given.

* Attempt to clear or change "Initiate Window Menu"
    A warning may be given if it overrides another binding, however, the binding is always replaced with just Button3
    and, from then on, the window manager acts as if Alt is always held down.

* Hold Alt, click and replace the binding to <Alt>Button3, the only combination of characters which fixes compiz.

* Give up

Christian Jönsson (chrisjoens) wrote :

I've also experienced this bug.

1) I tried to set Initiate Resize Window key to <Alt>Button3, it was completely ignored, no warnings no nothing.

2) I tried to remove the 'Window Menu', that was the one currently using <Alt>Button3, it was set to just 'Button3' and all mouse buttons stopped working in a normal window unless Alt was also pressed.

3) Using Alt+Click I managed to set 'Window Menu' key to <Super>Button3, it was accepted. However Super+Button3 still triggered the default behavior (not Window Menu) no warning about collision with previous <Super>Button3 binding.

4) Back to 'Initiate Resize Window', it seems to have also been set to <Super>Button3. But it still triggers default behavior.

5) Trying to set 'Initiate Resize Window' key to anything sends me back to the result of 2), and then I'm stuck in a loop. Never succeeding to set Initiate Window Resize to a working button combination.

I'm running a fresh install of Gutsy...

Jonathan Amir (jonathan-amir) wrote :

I experience exactly the same. Can't change the resize binding to <Alt>Button3. In this case and many other, ccsm completely ignores my request, and also somehow changes the binding to button1, thus forcing me to use the keyboard to be able to restore the settings.

I think the issue with button1 should be raised as critical (it's probably in another bug anyway). Regarding the resize issue and <Alt>Button3, here is a little background as to why this change is desired:

1) <Alt>Button3 is the default binding for window resizing in KDE. So KDE users that are enabling compiz, or KDE users that are switching to gnome+compiz (because compiz was not integrated with kubuntu 7.10) would like to have consistent behavior.

2) Even more important, on thinkpad laptops it is possible to combine Button2 and the trackball to emulate the scroll wheel. E.g., a short click on Button2 is actually Button2, but a long press on Button2 activates the mousewheel, and movement of the trackball then sends Button4, Button5 (vertical) and Button6, Button7 (horizontal).
These settings prevent the user from being able to long press Button2, thus prevent <Alt>Button2 from working.

Jonathan Amir (jonathan-amir) wrote :

workaround found:

open ccsm, go to Preferences, and if gconf is selected as a back-end, then make sure that the checkbox "Enable integration into the desktop environment" is unchecked.
Now you change change the bindings.

According to this page:
http://wiki.compiz-fusion.org/CCSM#head-340a755b8f870831a20b51544a116f6dc4795735

When the above mentioned integration is enabled, compiz reads some values from gnome environment, and they are read-only (marked in blue).

FSHero (minesh-fshero-mistry) wrote :

@Jonathan Amir:

Thanks for this; I was trying to rebind Move Window's <Alt>Button1 to <Super>Button1. Previously, even if I tried to remove this binding, it would revert back to <Alt>Button1. Now everything is fine. (I needed this because <Alt>Button1 was interfering with the GIMP!) I also noticed that in the KDE Pager, I get four boxes instead of 8 or 16 that I had when I ran "compiz --replace". (In KDE w/o compiz, I set the number of desktops to 2. In KDE with compiz, I set a cube up with four desktops.)

Btw., I am running Kubuntu Gutsy amd64. I didn't have this problem with Beryl on Kubuntu Feisty i386. But I'm glad to have this fixed.

Shall I report any other compiz-related problems here now that I turned the "Enable integration into the desktop environment" off?

Jonathan Amir (jonathan-amir) wrote :

The problem still exist in Hardy Alpha 4. The UI is improved, and it informs the user of conlicting bindings, but it still doesn't behave properly, because of the desktop environment integration mentioned above. I played with it for a while and it screwed up my bindings, even changing the binding for button1, thus preventing me from being able to click anything and forcing me to use the keyboard. Lame.

A Kao (ak-ubuntu) wrote :

This is still happening in Alpha 5. The UI is still poor, because it should at the very least let the user know about the problem and tell them to disable integration.

Daniel T Chen (crimsun) on 2008-10-26
Changed in compizconfig-settings-manager:
status: New → Confirmed
david.hilton.p (david.hilton.p) wrote :

Still exists in 0.8.2

david.hilton.p (david.hilton.p) wrote :

A related issue is this: gconf-editor apps->metacity->general: resize_with_right_button setting is ignored in the integration.

Romuald (romu70) wrote :

I also do confirm the bug in Jaunty.

Guido I (guidoweb) wrote :

@david.hilton.p I've made a patch for the gconf integration backend, so that it honours the resize_with_right_button gconf key. This solves some aspects of this bug. Feel free to check it out and give feedback - if it works, you'll be helping in the process of getting it included upstream :)

https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/207065
https://bugs.launchpad.net/compiz/+bug/495135

Phillip Susi (psusi) wrote :

This package has been removed from Ubuntu. Closing all related bugs.

Changed in compizconfig-settings-manager (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers