Broken list of profiles is given by compizconfig-backend-gconf

Bug #874799 reported by Sam Spilsbury on 2011-10-15
128
This bug affects 28 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Sam Spilsbury
Compiz Configuration Library - GConf Backend
Undecided
Sam Spilsbury
Compiz Configuration Library - Python Bindings
In Progress
Undecided
Sam Spilsbury
compizconfig-backend-gconf (Ubuntu)
Undecided
Sam Spilsbury
Oneiric
Undecided
Unassigned
compizconfig-python (Ubuntu)
Undecided
Sam Spilsbury
Oneiric
Undecided
Unassigned

Bug Description

When going into CCSM and selecting a profile, a broken list of profiles
is generated in in the profile view, Eg

1. Default
2. " "
3. "%%#"
4. "@AFdd"

test case:
1. install the new version in -proposed
2. start in the unity session, with unity loaded
3. open ccsm
4. click on preferences
5. see that the "unity" profile is still there and selected

Related branches

lp:~compiz-team/compiz-compizconfig-python/compiz-compizconfig-python.fix_874799
Tim Penhey (community): Approve on 2011-11-11
Changed in compiz-compizconfig-gconf:
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 0.9.6
status: New → In Progress
Changed in compizconfig-backend-gconf (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
status: New → In Progress
Changed in compiz-compizconfig-gconf:
status: In Progress → Invalid
Changed in compizconfig-backend-gconf (Ubuntu):
status: In Progress → Invalid
Changed in compiz-compizconfig-python:
status: New → In Progress
Changed in compizconfig-python (Ubuntu):
status: New → In Progress
Changed in compiz-compizconfig-python:
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compizconfig-python (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz-compizconfig-python:
milestone: none → 0.9.6
Didier Roche (didrocks) on 2011-11-09
description: updated
Martin Pitt (pitti) wrote :

Please upload to precise as well, otherwise this can't progress to -updates.

Changed in compizconfig-python (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed

Hello Sam, or anyone else affected,

Accepted compizconfig-python into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compizconfig-python - 0.9.5.94-0ubuntu4

---------------
compizconfig-python (0.9.5.94-0ubuntu4) precise; urgency=low

  * Upload to precise

compizconfig-python (0.9.5.94-0ubuntu3) oneiric-proposed; urgency=low

  * debian/patches/fix-874799.patch:
    - fix unity being unloaded when clicking on "preferences" in ccsm
      (LP: #874799)
 -- Didier Roche <email address hidden> Thu, 10 Nov 2011 09:09:41 +0100

Changed in compizconfig-python (Ubuntu):
status: In Progress → Fix Released
Wildjiji (wildjiji) wrote :

Thank you for fix.
I can confirm that the CCSM profile lists is displayed correctly.
And, I can select profiles and see "unity" in the profile lists .

Jay S (topdownjimmy) wrote :

Confirming that the package in oneiric-proposed resolved this issue for me.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compizconfig-backend-gconf (Ubuntu Oneiric):
status: New → Confirmed
Doug McMahon (mc3man) wrote :

Excellent - there were loads of users who where clicking on Preferences just out of curiosity & getting immediately switched to the default profile with resultant issues

Doug McMahon (mc3man) wrote :

It would be nice to see this pushed out to oneiric [universe] , many users continue to click on "Preferences" solely out of curiosity & or habit which can have unfortunate results.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compizconfig-python - 0.9.5.94-0ubuntu3

---------------
compizconfig-python (0.9.5.94-0ubuntu3) oneiric-proposed; urgency=low

  * debian/patches/fix-874799.patch:
    - fix unity being unloaded when clicking on "preferences" in ccsm
      (LP: #874799)
 -- Didier Roche <email address hidden> Wed, 09 Nov 2011 18:32:40 +0100

Changed in compizconfig-python (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Petko Ditchev (pditchev) wrote :

The time came and went to put this into universe . Please someone go ahead and do it because people are still breaking their desktops because of that . When I updated I expected that the package is updated and broke again , fixed again, in order to continue using everithing allright (good thing I knew about the fix and did it in 2 mins..) .

Changed in compiz-compizconfig-gconf:
milestone: 0.9.7.0 → none
Changed in compiz:
assignee: nobody → Sam Spilsbury (smspillaz)
status: New → In Progress
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in compizconfig-backend-gconf (Ubuntu Oneiric):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers