mplayer wont keep aspect ratio when resizing the windows while playing video

Bug #989342 reported by _dan_ on 2012-04-27
70
This bug affects 15 people
Affects Status Importance Assigned to Milestone
MPlayer
New
Undecided
Unassigned
compiz (Ubuntu)
High
Unassigned

Bug Description

After upgrading to 12.04 its no longer possible to resize mplayer window properly while running compiz.
running metacity everything is fine

expected behaviour:
window only resizes to correct aspect ratio

current behaviour:
window resizes to however its drawn distorting the movie

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: compiz 1:0.9.7.6-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 295.40 Thu Apr 5 21:37:00 PDT 2012
 GCC version: gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5)
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu6
Architecture: amd64
CompizPlugins: [core,composite,opengl,decor,dbus,imgjpeg,resize,imgsvg,obs,scale,text,grid,move,put,imgpng,compiztoolbox,place,workarounds,mousepoll,scaleaddon,gnomecompat,wall,thumbnail,expo,mag,ezoom,staticswitcher]
CompositorRunning: compiz
Date: Fri Apr 27 02:57:19 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 295.40, 3.2.0-23-generic, x86_64: installed
 nvidia-current, 295.40, 3.2.0-24-generic, x86_64: installed
 nvidia-current-updates, 295.40, 3.2.0-23-generic, x86_64: installed
 nvidia-current-updates, 295.40, 3.2.0-24-generic, x86_64: installed
GraphicsCard:
 NVIDIA Corporation GF104 [GeForce GTX 460] [10de:0e22] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Giga-byte Technology Device [1458:34fc]
JockeyStatus:
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Disabled, Not in use)
 xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Enabled, In use)
MachineType: MICRO-STAR INTERNATIONAL CO.,LTD P35 Platinum(MS-7345)
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic root=UUID=d6925b91-52dc-4b5e-b625-1469bb6bfced ro
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/30/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V1.12
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P35 Platinum(MS-7345)
dmi.board.vendor: MICRO-STAR INTERNATIONAL CO.,LTD
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MICRO-STAR INTERNATIONAL CO.,LTD
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV1.12:bd12/30/2009:svnMICRO-STARINTERNATIONALCO.,LTD:pnP35Platinum(MS-7345):pvr1.0:rvnMICRO-STARINTERNATIONALCO.,LTD:rnP35Platinum(MS-7345):rvr1.0:cvnMICRO-STARINTERNATIONALCO.,LTD:ct3:cvr1.0:
dmi.product.name: P35 Platinum(MS-7345)
dmi.product.version: 1.0
dmi.sys.vendor: MICRO-STAR INTERNATIONAL CO.,LTD
version.compiz: compiz 1:0.9.7.6-0ubuntu2
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

_dan_ (dan-void) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Facundo Batista (facundo) wrote :

In Precise it worked ok for me, now I'm getting this weird "not keep aspect ratio" behaviour after upgrading to Quantal.

Anton Anikin (anton-anikin) wrote :

I have the same problem in 13.04 alphas

mpw (matthiaspeterw) wrote :

Still not fixed in 12.04.2. Are there any workarounds?

Is it a fault of compiz, mplayer or the codec?

Justin Hardcastle (rammatamago) wrote :

This bug still exists in Ubuntu 14.04 LTS (Unity 7.2.2, mplayer 1.1-4.8), and Ubuntu 14.10 as far as I can tell.

Has there been any workarounds found for this yet?

tags: added: trusty
Changed in compiz (Ubuntu):
importance: Undecided → High
Facundo Batista (facundo) wrote :

This was fixed at some point in time.

To post a comment you must log in.