Activating alpha blur in CCSM makes notifications unreadable

Bug #983057 reported by Jakub Maleszewski on 2012-04-16
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
Compiz Core
Undecided
Unassigned
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Under 12.04 ticking "alpha blur" checkbox in CCSM's Blur settings make notifications' background completely transparent, thus unreadable. Attached screenshots should clearly show how does it look like.

What is more, and IMO it is compiz-related as well, turning plugins on and off a few times make Compiz crash, and the only way to make system usable again is to switch to console (Ctrl+Alt+F1) and restart LightDM from there (Alt+F2 does not work, so I can't open terminal and use compiz --replace).

In addition, Gaussian blur or mipmap blur do not work for me at all (just 4xBilinear).

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: compiz 1:0.9.7.6-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu3
Architecture: amd64
CompizPlugins: [core,composite,opengl,decor,imgpng,unitymtgrabhandles,compiztoolbox,mousepoll,obs,gnomecompat,snap,place,move,resize,vpswitch,regex,grid,animation,workarounds,commands,expo,wall,session,ezoom,fade,scale,unityshell]
CompositorRunning: compiz
Date: Mon Apr 16 15:08:46 2012
DistUpgraded: 2012-04-01 11:08:40,897 DEBUG enabling apt cron job
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 bbswitch, 0.4.1, 3.2.0-22-generic, x86_64: installed
 bbswitch, 0.4.1, 3.2.0-23-generic, x86_64: installed
 nvidia-current, 295.40, 3.2.0-23-generic, x86_64: installed
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:15f2]
 NVIDIA Corporation GF108 [GeForce GT 540M] [10de:0df4] (rev ff) (prog-if ff)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MachineType: ASUSTeK Computer Inc. K53SV
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic root=UUID=1a9ca011-4c13-4447-a834-25b2a67348e3 ro quiet splash pcie_aspm=force i915.i915_enable_rc6=1 i915.lvds_downclock=1 vt.handoff=7
SourcePackage: compiz
UpgradeStatus: Upgraded to precise on 2012-04-01 (15 days ago)
dmi.bios.date: 09/26/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: K53SV.315
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: K53SV
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 9
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrK53SV.315:bd09/26/2011:svnASUSTeKComputerInc.:pnK53SV:pvr1.0:rvnASUSTeKComputerInc.:rnK53SV:rvr1.0:cvnASUSTeKComputerInc.:ct9:cvr1.0:
dmi.product.name: K53SV
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.
version.compiz: compiz 1:0.9.7.6-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu35
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Jakub Maleszewski (numerant) wrote :
Jakub Maleszewski (numerant) wrote :
Jakub Maleszewski (numerant) wrote :
Jakub Maleszewski (numerant) wrote :

What is more, and IMO it is compiz-related as well, turning plugins on and off a few times make Compiz crash, and the only way to make system usable again is to switch to console (Ctrl+Alt+F1) and restart LightDM from there (Alt+F2 does not work, so I can't open terminal and use compiz --replace).

description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed

I can't reproduce this bug. It all works well for me.

Do you have an optimus laptop? It looks like you have both intel integrated and nvidia.

Changed in compiz (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Incomplete
Jakub Maleszewski (numerant) wrote :

Yes, I do have an Optimus notebook. I use Intel videocard, while NVIDIA is just turned off for the most of the time (I use Bumblebee for switching). I don't really thinks it's related.

I'm gonna check out soon if the bug still affects me with the newest version of Compiz.

Jakub Maleszewski (numerant) wrote :

Update: nothing changed, bug is still present. Maybe it's i915-driver-specific and that's why you cannot reproduce it?

Daniel van Vugt (vanvugt) wrote :

I can't reproduce it on 12.04 with intel graphics. But blur has other (much worse) bugs for me.

Hm, I have a laptop with i915 and can't reproduce, either.

Changed in compiz (Ubuntu):
status: Incomplete → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers