cube plugin "blinks" while changing viewport

Bug #980679 reported by kapetr on 2012-04-13
40
This bug affects 9 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

I have changed from wall to cube + rotate plugin.

When I change viewport then just before (at; after) end of animations blinks (for a fraction of a second) the previous viewport.

It is not tragic but really not nice. If not fixed I will change back to wall probably.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: compiz-plugins 1:0.9.7.6-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic 3.2.14
Uname: Linux 3.2.0-23-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu2
Architecture: amd64
CompizPlugins: [core,composite,opengl,decor,gnomecompat,regex,compiztoolbox,mousepoll,grid,snap,resize,place,vpswitch,animation,move,imgpng,session,fade,workarounds,cube,expo,scale,rotate,ezoom,unitymtgrabhandles,unityshell]
CompositorRunning: compiz
Date: Fri Apr 13 12:21:11 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
EcryptfsInUse: Yes
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0102] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Micro-Star International Co., Ltd. Device [1462:7740]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120401)
MachineType: MSI MS-7740
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=cs_CZ.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-23-generic root=UUID=9b97995f-6b36-4b57-a13e-cf5fd943d0a9 ro
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/04/2011
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: V1.0
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: H61MA-E35 (MS-7740)
dmi.board.vendor: MSI
dmi.board.version: 1.0
dmi.chassis.asset.tag: To Be Filled By O.E.M.
dmi.chassis.type: 3
dmi.chassis.vendor: MSI
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrV1.0:bd08/04/2011:svnMSI:pnMS-7740:pvr1.0:rvnMSI:rnH61MA-E35(MS-7740):rvr1.0:cvnMSI:ct3:cvr1.0:
dmi.product.name: MS-7740
dmi.product.version: 1.0
dmi.sys.vendor: MSI
version.compiz: compiz 1:0.9.7.6-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

kapetr (kapetr) wrote :
kapetr (kapetr) wrote :

The flicker appears only with "cube" not with "wall".

That is why I!m not sure it is a duplicate bug.

Aaron Lebahn (cplusplus328) wrote :

I also only have this bug with the cube. The wall does not flicker and acts smoothly.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Terry Wang (terrywang) wrote :

I had exactly the same issue, when rotating cube or use desktop cube.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers