Expo mode only dims empty viewports, not inactive ones

Bug #972417 reported by Mathieu Comandon on 2012-04-03
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Compiz Core
compiz (Ubuntu)

Bug Description

In Expo mode, the currently selected viewport should stand out from the others (which have a brightness and opacity setting in compiz-config).

Currently, every viewport with a window on it is shown at full brightness and opacity, the only difference is that the current viewport has a border around it. Empty workspaces are dimmed down as expected.

In the UX specification for workspaces:

"The current workspace is highlighted by an orange outline. The other workspaces are shown with dimmed backgrounds."

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: compiz 1:
ProcVersionSignature: Ubuntu 3.2.0-21.34-generic 3.2.13
Uname: Linux 3.2.0-21-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""

ApportVersion: 2.0-0ubuntu3
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
Date: Tue Apr 3 14:55:27 2012
DistUpgraded: 2012-03-02 14:29:42,067 DEBUG enabling apt cron job
DistroCodename: precise
DistroVariant: ubuntu
GraphicsCard: NVIDIA Corporation GT218 [GeForce 210] [10de:0a65] (rev a2) (prog-if 00 [VGA controller])
MachineType: LENOVO 4480B2G
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-21-generic root=UUID=dd6f9bf4-802f-467b-bdc1-362c16bb303d ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: Upgraded to precise on 2012-03-02 (31 days ago)
dmi.bios.date: 05/16/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 9HKT41AUS
dmi.board.vendor: LENOVO
dmi.chassis.type: 3
dmi.chassis.vendor: To Be Filled By O.E.M.
dmi.chassis.version: To Be Filled By O.E.M.
dmi.modalias: dmi:bvnLENOVO:bvr9HKT41AUS:bd05/16/2011:svnLENOVO:pn4480B2G:pvrThinkCentreM91p:rvnLENOVO:rn:rvr:cvnToBeFilledByO.E.M.:ct3:cvrToBeFilledByO.E.M.:
dmi.product.name: 4480B2G
dmi.product.version: ThinkCentre M91p
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental 8.0.2-0ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu8
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Mathieu Comandon (strycore) wrote :

Looking through the UX specs I can find the following:

"The current workspace is highlighted by an orange outline. The other workspaces are shown with dimmed backgrounds."

The mockup in the spec seemed to show that the windows themselves are not dimmed.

description: updated
summary: - Expo mode sets inactive viewport only on empty viewports
+ Expo mode only dims empty viewports, not inactive ones
Changed in compiz (Ubuntu):
status: New → Triaged
Changed in compiz-core:
status: New → Confirmed
Changed in compiz (Ubuntu):
importance: Undecided → Low
To post a comment you must log in.