Window move between workspaces yields wron cursor position

Bug #965577 reported by Klaus Reichl on 2012-03-26
122
This bug affects 24 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Precondition:
ccsm: Enable: Desktop Wall => Edge Flipping => Edge Flip Move

When moving a window from one workspace to the other, the cursor position (or the window's position) on the resulting workspace is calculated wrong.

This makes "Flip Move"
a) Move the window slightly behind the cursor, when moving from far right to workspace on the right (left the other direction)
as soon as the other workspace is hit.
b) Lose the window when moving to the right, then moving back to the left (when reverting the decision) or other way round

"Edge Flip" move was working correctly in Ubuntu 10.10 LTS, so this is definitly a regression in compiz.

Best regards,
Klaus

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: compiz 1:0.9.7.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,gnomecompat,move,mousepoll,imgpng,grid,resize,place,vpswitch,regex,snap,unitymtgrabhandles,session,wall,animation,fade,workarounds,expo,scale,ezoom,unityshell]
Date: Sun Mar 25 16:34:45 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120228)
MachineType: Clevo Co. M570RU
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-20-generic root=UUID=bdb119a6-80ae-4ec4-8181-088eeb048138 ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
XorgConf:
 Section "Device"
  Identifier "Default Device"
  Option "NoLogo" "True"
 EndSection
dmi.bios.date: 06/30/2008
dmi.bios.vendor: Phoenix
dmi.bios.version: SROSA001.86C.
dmi.board.name: SANTA ROSA
dmi.board.vendor: Clevo Co.
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 1
dmi.chassis.vendor: CLEVO
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnPhoenix:bvrSROSA001.86C.:bd06/30/2008:svnClevoCo.:pnM570RU:pvrCLEVOM570RU-1.00.09:rvnClevoCo.:rnSANTAROSA:rvrNotApplicable:cvnCLEVO:ct1:cvrN/A:
dmi.product.name: M570RU
dmi.product.version: CLEVO:M570RU-1.00.09
dmi.sys.vendor: Clevo Co.
version.compiz: compiz 1:0.9.7.2-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.2-0ubuntu2
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Klaus Reichl (klaus-reichl) wrote :
roots (roots) wrote :

I can confirm this with 12.04 and Gnome-Classic...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed

slightly is a under statement and it gets exponentially worse when moving over more than one workspace
just to be sure we are talking about the same bug:
http://youtu.be/etB_9B1EZGg

Bowmore (bowmore) wrote :

It's also reproducable horizontally on a default install with default settings by bumping a window on the top of the screen (same workspace) back and forth.

Bowmore (bowmore) wrote :

Hmm, meant vertically above of course ;)

you could just enable wrap around :)

Bowmore (bowmore) wrote :

Sure, that makes it worse ;)

But what I wanted to say is that it's not just an edge flipping issue. However, If I just disable snapping windows from the default compiz settings for unity I can't reproduce this issue! So the question is what plugin causes this? Tried to remove edge resistance for some plugins but that made no difference.

@"If I just disable snapping windows from the default compiz settings for unity I can't reproduce this issue!"
https://encrypted-tbn3.google.com/images?q=tbn:ANd9GcSINja_BrcKSIM4HoUTlLDYCGS7i0_aqXr2Ij3jueaNg9CnlUlAgQ

try theses extremely basic settings cause it happens here with them
BTW for the sake of eliminating conflicts unity is disabled in these settings so i suggest you have ccsm open and any other apps you think you will need

Bowmore (bowmore) wrote :

Those settings have the "s0_edgeflip_move = true" and that's one thing that reveals this issue. But still the question is what causes this? I've revealed it without edge flipping too.

Doug McMahon (mc3man) wrote :

I believe the cursor disconnect when banging up against the top panel is caused by snapping windows,
The disconnect when edge flipping hopefully will be fixed by the branch for this bug, was as of r3008 but that was while ago
Bug 862430
To that attaching 2 vids, one with wall, the other rotate, the cursor stays put

Doug McMahon (mc3man) wrote :

rotate

snapping windows is disabled see my basic setting file above unless there is one that is part of the wall,window decoration, move, or put

kubecz3k (kubecz3k) on 2012-04-27
no longer affects: compiz-core
walter (walter-mollica) wrote :

The problem affects Xubuntu 12.04 with no Snapping Windows, too.

walter (walter-mollica) wrote :

The bug doesn't show up if you un-tick "Lazy positioning" in ccsm-> Move window

have you tried dragging across multiple (3+) workspaces with out letting the mouse up?

unticking that makes a huge improvement but it does not solve it 100%

Andreas Zeller (luxmedien) wrote :

I can confirm that. Unchecking lazy positioning doesn't fix it entirely but it makes it usable again. But if you hadn't pointed it out, I wouldn't even have noticed :)

For those, who care: switching lazy positioning off reduces the wrong position by just a pixel or two. Almost not noticable. But it's just a workaround, not a fix. So far.

walter (walter-mollica) wrote :

You two are right...the bug remains. In my case, especially when moving between vertical workspaces.
If these are my 4 workspaces:

1O 2O

3O 4O

I find that moving 1O -> 2O or 3O -> 4O and viceversa is passable.
Dragging in 1O->3O 2O->4O directions and viceversa I otherwise have some problems, or maybe given the titlebar height the glitches are just more noticeable.

Anyways it's, as of now, the best trade-off I could find.

if you notice the wobbly windows act like they just came out of a maximized state when switching workspaces this makes me think there is a setting going this since that did not happen on compiz 0.8.6

t3rmin (matt-thetrents) wrote :

For me, unchecking lazy positioning seems to almost fix it for right-to-left drags, but not left-to-right drags... Left-to-right is completely unusable.

tags: added: compiz-0.9
Biji (biji) wrote :

Fixed by unchecking these on Move Window (CCSM):
[ ] Contrain Y
[ ] Snapoff max windows
[ ] Lazy positioning

it's fixed with the latest updates in 12.10

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers