[0.9.7.2] gtk-window-decorator receives BadWindow errors

Bug #962085 reported by Sebastien Bacher on 2012-03-22
30
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Compiz Core
High
Daniel van Vugt
compiz (Ubuntu)
High
Unassigned

Bug Description

That was not happening with 0.9.7.0 r3035 but is happening regularly with 0.9.7.2 from staging, the decorator exits with

"The program 'gtk-window-decorator' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 43121 error_code 3 request_code 20 minor_code 0)"

it happened so far when:
- closing a dialog
- closing an application
- changing workspace
- right click on the decorator bar

i.e seems to happen randomnly

I tried to get a stracktrace by breaking on gdk_x_error but the decorate hits an XError every time something is closed which makes it impossible to debug it this way...

Related branches

Changed in compiz (Ubuntu):
importance: Undecided → High
Changed in compiz-core:
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

I've been informed by didrocks and in a log from smspillaz that this is caused by LIM and should be removed.

Changed in compiz-core:
milestone: none → 0.9.7.4
assignee: nobody → Daniel van Vugt (vanvugt)
status: New → In Progress
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz-core at revision 3077

Changed in compiz-core:
status: In Progress → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Fix released in Compiz Core 0.9.7.4

Changed in compiz-core:
status: Fix Committed → Fix Released
Didier Roche (didrocks) wrote :

(this never reached precise)

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
Deon George (deon-leenooks) wrote :

FWIW, I'm running compiz 0.9.7.4 and the bug continues for me;

<code>
ii compiz 1:0.9.7.4-0ubunt OpenGL window and compositing manager
</code>

<code>
compiz (decor) - Warn: failed to bind pixmap to texture
The program 'gtk-window-decorator' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 5625792 error_code 3 request_code 20 minor_code 0)
</code>

Stephan Trebels (ncubede) wrote :

From the above. I'd have assumed this is 1. not in precise and 2. not after 0.9.7.4

I am running precise and compiz-core is
ii compiz-core 1:0.9.7.6-0ubuntu1 OpenGL window and compositing manager

and this is what I find in xsession errors:
The program 'gtk-window-decorator' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 575507 error_code 3 request_code 20 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

lucky bringing up ccsm and then disabling and re-enabling window decoration restores nicely.

ichutzpah (vinay-iit) wrote :

is the fix released for precise..I am on precise and still facing this bug quite a few times daily

Daniel van Vugt (vanvugt) wrote :

Thanks all. I wasn't convinced that reverting the code as we did would fix this either. I was just asked to do so.

However since this bug is Fix Released, please log a new bug with the details of the continuing problem in 12.04.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers