[regression] Invisible resize border is now only 1px wide

Bug #953839 reported by Andy Whitcroft on 2012-03-13
144
This bug affects 34 people
Affects Status Importance Assigned to Milestone
Compiz Core
High
Sam Spilsbury
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

Before this update you could trigger resize in a fairly wide area outside the window, in its shadow, this no longer works returning us to the 1px area to hit for resize.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,place,snap,imgpng,regex,mousepoll,move,resize,vpswitch,grid,gnomecompat,session,animation,wall,expo,fade,workarounds,ezoom,scale,unityshell]
Date: Tue Mar 13 09:02:57 2012
EcryptfsInUse: Yes
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: unity
UpgradeStatus: Upgraded to precise on 2012-02-01 (40 days ago)

Related branches

Andy Whitcroft (apw) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Sounds like a regression related to the fix for bug 936781 perhaps?

summary: - active resize area around windows no longer works
+ [regression] Invisible resize border is now only 1px wide
tags: added: regression-update
Changed in compiz-core:
status: New → Confirmed
importance: Undecided → High
Changed in compiz-core:
assignee: nobody → Sam Spilsbury (smspillaz)
Tim Penhey (thumper) on 2012-03-20
Changed in compiz-core:
status: Confirmed → In Progress
milestone: none → 0.9.7.4
Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz-core at revision 3063

Changed in compiz-core:
status: In Progress → Fix Committed
affects: unity (Ubuntu) → compiz (Ubuntu)
Omer Akram (om26er) on 2012-03-23
Changed in compiz (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.7.2-0ubuntu1

---------------
compiz (1:0.9.7.2-0ubuntu1) precise-proposed; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream snapshot:
    - Fix global menu not being ergonomical on large screens (LP: #682788)
    - Fix Alt+Right arrow key (LP: #943612)
    - Fix key bindings for actions while doing tap detection (LP: #944631)
    - Window movement is erratic and buggy, backport (LP: #923683)
    - CompScreenImpl::addAction(CompAction*): Assertion `priv->initialized'
      failed (LP: #946118)
    - gtk-window-decorator crash with SIGSEGV in max_window_name_width()
      (LP: #937815)
    - Finish the implementation of the locally integrated menubars
      (LP: #931245)
    - Unity/compiz intercepts keystrokes from grabbed windows (LP: #806255)
    - Pressing alt doesn't show the menu title bar in top panel (LP: #943194)
    - Fix Alt stealing focus from widgets (LP: #943851)
    - Fix Alt + drag (LP: #945373)
    - lp:compiz-core fails parallel builds (make -jN) (LP: #938417)
    - Changing the HUD shortcut disables all Alt-based combinations. And
      changing the Dash shortcut disables all Super-based shortcuts
      (LP: #945816)
    - Fix key bindings (such as Super) not working on empty workspace or on
      slow/loaded systems (LP: #953089)
    - compiz crashed with signal 5 in Glib::exception_handlers_invoke()
      (LP: #808007)
    - Fix segfault caused by r3043 (LP: #958540)
  * Removed cherry-picked patches:
    - debian/patches/fix_806255.patch
    - debian/patches/fix_923683.patch
    - debian/patches/fix_943194.patch
    - debian/patches/fix_944631.patch
    - debian/patches/fix_alt_pressing.patch
    - debian/patches/additional_alt_tapping_fix.patch

  [ Didier Roche ]
  * pick upstream fix, debian/patches/fix_953839.patch:
    [regression] Invisible resize border is now only 1px wide (LP: #953839)
  * debian/patches/revert_lim.patch:
    - revert the integrated menu patch. It won't be released in precise and
      triggers a regression (in bug #962085)
  * debian/patches/fix_953089_2.patch:
    - second trial to fix remaining corner cases
  * debian/patches/exit_1_if_composite_cant_init.patch:
    - try to workaround a crasher which seems to happen when the composite
      plugin failed to initialize. Hopefully exiting 1 will make gnome-session
      respawning compiz and then the init will work. (LP: #833729)
  * debian/patches/always_replace.patch:
    - right now, always replace the current WM as it seems that some people
      got another compositor running at the start of the session. This will
      hopefully workaround the issue that some people experience.
 -- Didier Roche <email address hidden> Fri, 23 Mar 2012 09:13:51 +0100

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

Fix released in Compiz Core 0.9.7.4

Changed in compiz-core:
status: Fix Committed → Fix Released
Matthew Gregg (mcg) wrote :

Using Compiz Core 0.9.7.6-0ubuntu1 this bug appears to be back or at least it is again very difficult to resize windows. The resize border appears to be very small.

Daniel van Vugt (vanvugt) wrote :

Matthew, if you are only having problems with the top resize edge then that is bug 739307.

If you still have problems with the other edges, then please log a new bug with details of the problem and ideally a video.

Shaun Crampton (fasaxc) wrote :

Bug 978737 addresses the same issue, still affecting several folks using Ubuntu inside VMWare (which uses Unity2D).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers