Menus appear empty (only shadow)

Bug #948059 reported by Tony Espy on 2012-03-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
compiz (Ubuntu)
Low
Unassigned

Bug Description

Cascading application menus are sometime rendered such that they're hidden behind parent menus.

This was initially seen with xchat-gnome when initiating a "private chat" from the user menu ( right-click -> private chat ).

I've also seen this same issue recently in chromium-browser when creating a bookmark and selecting the Folder drop-down box.

I haven't seen the corruption that's shown in the earlier screenshots for chromium-browser and software-center for quite some time now. What I'm seeing now can be seen in the screen shots in comments #4 and #12.
---
.tmp.unity.support.test.0:

ApportVersion: 2.0.1-0ubuntu12
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,vpswitch,snap,mousepoll,resize,place,move,wall,grid,regex,imgpng,session,gnomecompat,animation,fade,unitymtgrabhandles,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
DistUpgraded: 2012-03-03 12:29:05,682 DEBUG enabling apt cron job
DistroCodename: precise
DistroRelease: Ubuntu 12.04
DistroVariant: ubuntu
DkmsStatus:
 vboxhost, 4.1.20, 3.2.0-29-generic-pae, i686: installed
 vboxhost, 4.1.20, 3.2.0-30-generic-pae, i686: installed
EcryptfsInUse: Yes
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:21c1]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
MachineType: LENOVO 2901CTO
Package: compiz 1:0.9.7.8-0ubuntu1.4
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-30-generic-pae root=UUID=b154a7ff-6a2a-4dae-804d-0e17319a3cec ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.2.0-30.48-generic-pae 3.2.27
Tags: precise running-unity precise running-unity ubuntu compiz-0.9
Uname: Linux 3.2.0-30-generic-pae i686
UpgradeStatus: Upgraded to precise on 2012-03-03 (187 days ago)
UserGroups: adm admin cdrom dialout libvirtd lpadmin plugdev sambashare
dmi.bios.date: 04/25/2012
dmi.bios.vendor: LENOVO
dmi.bios.version: 6UET69WW (1.49 )
dmi.board.name: 2901CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6UET69WW(1.49):bd04/25/2012:svnLENOVO:pn2901CTO:pvrThinkPadT410s:rvnLENOVO:rn2901CTO:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 2901CTO
dmi.product.version: ThinkPad T410s
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.7.8-0ubuntu1.4
version.libdrm2: libdrm2 2.4.32-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0.3+8.0.2-0ubuntu3.2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0.3+8.0.2-0ubuntu3.2
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu10.7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.7.0-0ubuntu1.2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Tony Espy (awe) wrote :

Please note that chromium is community developed/supported software, and is tightly controlled by Google. A linked bug in their database would be useful as well.

Changed in chromium-browser (Ubuntu):
importance: Undecided → Low
Tony Espy (awe) wrote :

Turns out this is not restricted to chromium browser. I've seen corruption with Software Center right-click menus as well ( see attached png ).

Tony Espy (awe) wrote :

XChat-gnome exhibits a similar, yet slightly different problem. If I click on the users button, and then right-click to start a private chat, the sub-menu sometime is displayed behind the user's widget ( not sure this is really a menu ). I've also attached a screenshot for this.

Tony Espy (awe) wrote :

Note, I'm currently running compiz version:

1:0.9.7.0~bzr2995-0ubuntu5

...and I've noticed that there's a new version in the repository, however it's a partial upgrade scenario, so I'm hesitant to upgrade compiz without further instruction(s).

Tony Espy (awe) wrote :

After a dist-upgrade this morning, the problem appears to have been resolved across all applications mentioned above.

Tony Espy (awe) wrote :

OK, I just hit it again... this time with Eclipse, so the issue is *not* fixed, just reduced in frequency. I unfortunately couldn't grab a screen shot this time around. If I can reproduce again, I will attach to the bug. Note, the symptom was the first described ( i.e. menu window painted, but no menu items rendered ).

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in chromium-browser (Ubuntu):
status: New → Confirmed
wvengen (wvengen) wrote :

Having the same issue using gnome-shell, but only seen with Chromium. I my case the menu does not disappear anymore until Chromium is killed.

wvengen (wvengen) wrote :

see also bug #793836

Tony Espy (awe) wrote :

Still seeing the problem with xchat-gnome on an updated 12.04 system occasionally. This usually happens when trying to initiate a private chat with someone. I will try and grab a screen-shot the next time it happens.

Tony Espy (awe) wrote :

Same problem just occurred with chromium-browser ( see attached screenshot ).

How is xchat-gnome related? Are you saying you have the bug in chromium and
it? This suggests a bug in a larger package (openbox) or an additional bug
in xchat-gnome. What other packages does this happen with? Are there ones
it never happens with? Can you repeatedly recreate this with either package?

Tim Penhey (thumper) on 2012-09-06
affects: chromium-browser (Ubuntu) → compiz (Ubuntu)
Tony Espy (awe) on 2012-09-06
summary: - Right-click text menu ( Cut/Copy/Paste/...) sometimes rendered blank or
- missing items
+ Application menus sometimes rendered hidden

apport information

description: updated
tags: added: apport-collected compiz-0.9 precise running-unity ubuntu
description: updated
Tony Espy (awe) wrote : BootLog.gz

apport information

apport information

apport information

Tony Espy (awe) wrote : DpkgLog.txt

apport information

apport information

apport information

Tony Espy (awe) wrote : Lspci.txt

apport information

Tony Espy (awe) wrote : Lsusb.txt

apport information

apport information

apport information

apport information

apport information

Tony Espy (awe) wrote : UdevDb.txt

apport information

Tony Espy (awe) wrote : UdevLog.txt

apport information

apport information

Tony Espy (awe) wrote : XorgLog.txt

apport information

This was bug 931473, bug apparently not fully fixed. I think I've seen this happen once at least.

summary: - Application menus sometimes rendered hidden
+ Menus appear empty (only shadow)
Tony Espy (awe) wrote :

I'm not sure it's the same bug. Currently I'm always seeing the menu rendered beneath the parent window per the attached screen shots ( comment #2 and #12 ). The bug as originally reported was more consistent with bug #931473.

One last comment... the problem seems to occur intermittently. I suspended my machine last night, and today I can't seem to reproduce with chromium-browser ( bookmark ) nor xchat-gnome ( private-chat ).

Tony Espy (awe) wrote :

Running 13.04 now, I'm still seeing this bug quite frequently using chromium-browser and xchat-gnome as previously reported.

Bug #931473 is marked FixReleased as of compiz 0.9.7.0. 13.10 includes compiz 1:0.9.9~daily13.04.18.1~13.04-0ubuntu1.

Still quite broken, and still quite frustrating.

Please let me know if I can provide anymore debug info.

MC Return (mc-return) wrote :

@awe:
Could you please test this PPA:
ppa:smspillaz/compiz-dev-raring

And report if the issue still occurs ?

Changed in compiz:
milestone: none → 0.9.11.0
Tony Espy (awe) wrote :

Sure, thanks for the quick response!

Tony Espy (awe) wrote :

OK, a bit of mud on my face. It seems I hadn't been pestered by update-manager for quite some time, so when I manually ran it, there was quite a large list of updates available. So for much for the "notify me weekly preference" ( but that's another problem ).

I'm quite happy to say that after the update, the problem *finally* seems to be resolved in chromium-browser and xchat-gnome. Awesome!!!

FYI, after the update my system now is running compiz: 1:0.9.9~daily13.06.19~13.04-0ubuntu1.

MC Return (mc-return) on 2013-07-24
Changed in compiz:
milestone: 0.9.11.0 → none
status: New → Fix Released
Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
Tony Espy (awe) wrote :

Sigh...

This is bug is now showing up on my system again. Same problem with both chrome and xchat-gnome. Right-click, and the newest menu doesn't show up on top and thus isn't very use-able. See comment #4 and comment #12 for screenshots.

I'm running raring, and have verified that it's fully up-to-date.

Changed in compiz (Ubuntu):
status: Fix Released → New
Tony Espy (awe) wrote :

FYI, I changed the status back to New until someone else can confirm...

To post a comment you must log in.