[regression] Changing the HUD shortcut disables all Alt-based combinations. And changing the Dash shortcut disables all Super-based shortcuts.

Bug #945816 reported by Alan Bell on 2012-03-03
184
This bug affects 40 people
Affects Status Importance Assigned to Milestone
Compiz Core
Medium
Daniel van Vugt
compiz (Ubuntu)
Medium
Unassigned

Bug Description

this is probably related to bug #923274
now when I turn off the ALT binding for the HUD I can't take a screenshot of a window with alt+prtscr

Omer Akram (om26er) on 2012-03-11
Changed in unity (Ubuntu):
importance: Undecided → Low
tags: added: hud
Changed in unity:
importance: Undecided → Low
status: New → Triaged
Changed in unity (Ubuntu):
status: New → Triaged
Revision history for this message
Paolo Rotolo (paolorotolo) wrote :

Hi Alan,
What is your version of Unity?
On my Unity 5.4.0 all works good...

Revision history for this message
Mozaic (mozaic) wrote :

I have the same bug.

When i press Alt + Printscreen to take empathy window, i have the following image.
Or i want only the second

Revision history for this message
Mozaic (mozaic) wrote :

I want only that when i press Alt + Printscreen

Revision history for this message
Mozaic (mozaic) wrote :

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.6.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
.tmp.unity.support.test.0:

summary: - if you turn off the HUD you can't screenshot a window
+ Changing the HUD shortcut disables all Alt-based combinations
Changed in unity:
importance: Low → Medium
Revision history for this message
Daniel van Vugt (vanvugt) wrote : Re: Changing the HUD shortcut disables all Alt-based combinations

Wow. Easy bug to reproduce. Hard to explain right now.

Changed in unity:
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in unity:
status: Triaged → In Progress
affects: unity → compiz
tags: added: regression-update
affects: unity (Ubuntu) → compiz (Ubuntu)
affects: compiz → compiz-core
Changed in compiz-core:
milestone: none → 0.9.7.2
summary: - Changing the HUD shortcut disables all Alt-based combinations
+ [regression] Changing the HUD shortcut disables all Alt-based
+ combinations
Revision history for this message
Daniel van Vugt (vanvugt) wrote : Re: [regression] Changing the HUD shortcut disables all Alt-based combinations

Fix committed into lp:compiz-core at revision 3057

Changed in compiz-core:
status: In Progress → Fix Committed
Revision history for this message
Darrick J. Wong (djwong-ibm) wrote :

Hmm... does r3057 also fix the bug where reassigning "Key to show the launcher" breaks all the other <Super> shortcuts?

Omer Akram (om26er) on 2012-03-17
Changed in compiz (Ubuntu):
importance: Low → Medium
status: Triaged → Fix Committed
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

@Darrick, yes the fix for this bug will also fix the same issue with the Super key.

summary: [regression] Changing the HUD shortcut disables all Alt-based
- combinations
+ combinations. And changing the Dash shortcut disables all Super-based
+ shortcuts.
Changed in compiz-core:
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.7.2-0ubuntu1

---------------
compiz (1:0.9.7.2-0ubuntu1) precise-proposed; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream snapshot:
    - Fix global menu not being ergonomical on large screens (LP: #682788)
    - Fix Alt+Right arrow key (LP: #943612)
    - Fix key bindings for actions while doing tap detection (LP: #944631)
    - Window movement is erratic and buggy, backport (LP: #923683)
    - CompScreenImpl::addAction(CompAction*): Assertion `priv->initialized'
      failed (LP: #946118)
    - gtk-window-decorator crash with SIGSEGV in max_window_name_width()
      (LP: #937815)
    - Finish the implementation of the locally integrated menubars
      (LP: #931245)
    - Unity/compiz intercepts keystrokes from grabbed windows (LP: #806255)
    - Pressing alt doesn't show the menu title bar in top panel (LP: #943194)
    - Fix Alt stealing focus from widgets (LP: #943851)
    - Fix Alt + drag (LP: #945373)
    - lp:compiz-core fails parallel builds (make -jN) (LP: #938417)
    - Changing the HUD shortcut disables all Alt-based combinations. And
      changing the Dash shortcut disables all Super-based shortcuts
      (LP: #945816)
    - Fix key bindings (such as Super) not working on empty workspace or on
      slow/loaded systems (LP: #953089)
    - compiz crashed with signal 5 in Glib::exception_handlers_invoke()
      (LP: #808007)
    - Fix segfault caused by r3043 (LP: #958540)
  * Removed cherry-picked patches:
    - debian/patches/fix_806255.patch
    - debian/patches/fix_923683.patch
    - debian/patches/fix_943194.patch
    - debian/patches/fix_944631.patch
    - debian/patches/fix_alt_pressing.patch
    - debian/patches/additional_alt_tapping_fix.patch

  [ Didier Roche ]
  * pick upstream fix, debian/patches/fix_953839.patch:
    [regression] Invisible resize border is now only 1px wide (LP: #953839)
  * debian/patches/revert_lim.patch:
    - revert the integrated menu patch. It won't be released in precise and
      triggers a regression (in bug #962085)
  * debian/patches/fix_953089_2.patch:
    - second trial to fix remaining corner cases
  * debian/patches/exit_1_if_composite_cant_init.patch:
    - try to workaround a crasher which seems to happen when the composite
      plugin failed to initialize. Hopefully exiting 1 will make gnome-session
      respawning compiz and then the init will work. (LP: #833729)
  * debian/patches/always_replace.patch:
    - right now, always replace the current WM as it seems that some people
      got another compositor running at the start of the session. This will
      hopefully workaround the issue that some people experience.
 -- Didier Roche <email address hidden> Fri, 23 Mar 2012 09:13:51 +0100

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
SF Basilix (sf-basilix) wrote :

I have the latest patched update for 12.04, 64 bit and this problem is still an issue. What's even worse is that with Virtualbox VMs running in fullscreen mode, the alt+tab combo within the VM triggers HUD outside the VM. This is not normal operation and should not occur until the right control key is pressed (releases the mouse controller from the VM).

I went ahead and moved the alt key trigger to the right alt key, but now I cannot use any microsoft (super) keys within my Windows VM because it launches the unity search bar.

These things should not be allowed to trigger from a full-screen VM.

Revision history for this message
Daniel van Vugt (vanvugt) wrote :

SF Basilix, you are describing bug 806255 so please subscribe to that one.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers