Ubuntu

gtk-window-decorator crashed with SIGSEGV in max_window_name_width()

Reported by Páll Haraldsson on 2012-02-21
616
This bug affects 141 people
Affects Status Importance Assigned to Milestone
Compiz Core
High
Daniel van Vugt
compiz (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

Clicked on this link:
http://cas.ee.ic.ac.uk/people/gac1/pubs/AntonioTRETS09.pdf

It opened in Document Viewer (evince). At the same time I got this compiz error and the window border was missing (not anymore, something gtk-window-decorator (not compiz), it seems, got restarted).

This compiz error happened previously, under I think the same situation (opening (another) PDF file, but then with the provided kernel. ATM I'm running oneiric kernel).

Hope this helps. This is my first Ubuntu bug report.

[I checked "reproducible" checkbox because this happened before, but on second thought I deleted "reproducible" from the optional tags. I'm guessing that reverts my decision. I tried clicking the link again and this did not happen again so it seems to be kind of random.]

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: compiz-gnome 1:0.9.7.0~bzr2995-0ubuntu4
ProcVersionSignature: Ubuntu 3.0.0-16.28-generic 3.0.17
Uname: Linux 3.0.0-16-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 295.20 Mon Feb 6 21:07:30 PST 2012
 GCC version: gcc version 4.6.2 (Ubuntu/Linaro 4.6.2-14ubuntu2)
.tmp.unity.support.test.0:

ApportVersion: 1.92-0ubuntu1
Architecture: amd64
CompizPlugins: [core,composite,opengl,decor,resize,grid,snap,gnomecompat,compiztoolbox,mousepoll,imgpng,place,vpswitch,regex,wall,move,session,animation,fade,workarounds,scale,expo,ezoom,unityshell]
CompositorRunning: compiz
CrashCounter: 1
Date: Tue Feb 21 13:50:58 2012
DistUpgraded: Log time: 2012-02-17 14:58:14.138882
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 295.20, 3.0.0-16-generic, x86_64: installed
 nvidia-current, 295.20, 3.2.0-16-generic, x86_64: installed
 nvidia-current, 295.20, 3.2.0-17-generic, x86_64: installed
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/gtk-window-decorator
GraphicsCard:
 NVIDIA Corporation G84 [Quadro FX 570] [10de:040e] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: NVIDIA Corporation Device [10de:0474]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120215)
JockeyStatus:
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
 xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
MachineType: Dell Inc. Precision WorkStation T3400
ProcCmdline: /usr/bin/gtk-window-decorator
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-16-generic root=UUID=2227a4a3-381a-4dc2-b952-24afff161852 ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x4194c4 <max_window_name_width+36>: cmpq $0x0,0x2d8(%rax)
 PC (0x004194c4) ok
 source "$0x0" ok
 destination "0x2d8(%rax)" (0x000002d8) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 max_window_name_width ()
 update_window_decoration_size ()
 ?? ()
 g_closure_invoke () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
UpgradeStatus: Upgraded to precise on 2012-02-17 (3 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
dmi.bios.date: 08/14/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A08
dmi.board.name: 0TP412
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 7
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA08:bd08/14/2008:svnDellInc.:pnPrecisionWorkStationT3400:pvr:rvnDellInc.:rn0TP412:rvr:cvnDellInc.:ct7:cvr:
dmi.product.name: Precision WorkStation T3400
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu4
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0~rc2-0ubuntu5
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0~rc2-0ubuntu5
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

StacktraceTop:
 max_window_name_width (win=0x0) at /build/buildd/compiz-0.9.7.0~bzr2995/gtk/window-decorator/decorator.c:418
 update_window_decoration_size (win=0x0) at /build/buildd/compiz-0.9.7.0~bzr2995/gtk/window-decorator/decorator.c:595
 active_window_changed (screen=<optimized out>) at /build/buildd/compiz-0.9.7.0~bzr2995/gtk/window-decorator/wnck.c:710
 closure_invoke_notifiers (notify_type=2, closure=0x1ab4fd0) at /build/buildd/glib2.0-2.31.18/./gobject/gclosure.c:282
 g_closure_invoke (closure=0x1ab4fd0, return_value=0x0, n_param_values=2, param_values=0x1c06950, invocation_hint=<optimized out>) at /build/buildd/glib2.0-2.31.18/./gobject/gclosure.c:773

Changed in compiz (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Rainer Rohde (rainer-rohde) wrote :

This just now happened to me as well.

i want to open some strange mp3 with video-player and this happend. But there are other programms still runing, so this need not be the trigger.

Yuri Glushaev (y-glushaev) wrote :

Crashed when wine-opengl (fullscreen) app had closed.

Josh Palmer (palmerjosh23) wrote :

Running a multi montor set up, Skype was full screen on my extra monitor, brought it to regular mode, and my window decorator crashed. Came back after clicking yes to restart compiz.

cliff tinker (cliff5555) wrote :

i launched the application stellarium in full screen mode when it crashed

Dmitriy (rzk333) wrote :

Having same compiz fail when wine apps crash or, sometimes, just from closing.

Franco Bombi (franco.bombi) wrote :

I was using VLC, compiz crahed at a window reshape

Omer Akram (om26er) on 2012-02-29
Changed in compiz-core:
importance: Undecided → Medium
status: New → Confirmed
importance: Medium → High
Changed in compiz (Ubuntu):
importance: Medium → High
Daniel van Vugt (vanvugt) wrote :

Looks like a simple crash to avoid. Both functions at the top of the stack are being called with a NULL pointer.

max_window_name_width (win=0x0) at /build/buildd/compiz-0.9.7.0~bzr2995/gtk/window-decorator/decorator.c:418
update_window_decoration_size (win=0x0) at /build/buildd/compiz-0.9.7.0~bzr2995/gtk/window-decorator/decorator.c:595

I do wonder why we didn't ever see this before though.

Changed in compiz-core:
milestone: none → 0.9.7.0
Omer Akram (om26er) on 2012-03-01
Changed in compiz-core:
status: Confirmed → Triaged
Changed in compiz (Ubuntu Precise):
milestone: none → ubuntu-12.04-beta-2
status: Confirmed → Triaged
Changed in compiz-core:
milestone: 0.9.7.0 → 0.9.7.2
Susan Cragin (susancragin) wrote :

I have had three crashes that I suspect are inter-related.
I just filed bugs on banf and nautilus, and then re-booted and this crash happened. In the earlier bugs also the window shaper was affected.
I hope the other bugs contain good information; if not, they can probably be considered duplicates of this one.

Changed in compiz-core:
assignee: nobody → Daniel van Vugt (vanvugt)
Changed in compiz-core:
status: Triaged → In Progress
RobWilkens (robwilkens) wrote :

This happenned to me on the following situation:
1. Installed Moneydance on 64-bit ubuntu with java.com official jre (ln -s /opt/jre1.6....... /opt/moneydance/jre) from moneydance.com (available as a trial version which is the same as real version but limitted data entry until unlocked). OpenJDK btw doesn't work well with this when it comes to installing extensions, and the 32-bit jre that came with it doesn't work on 64-bit ubuntu apparently, i had to manually download 64-bit jre and copy it to /opt.
2. Ran moneydance, it ran fine
3. I pinned moneydance ("lock to launcher")
4. I then tried running it from launcher and this happenned

Note, this program apparently can't run from being locked in launcher, probably because of the way it's a java program and launches from a script, if i go to command prompt and type 'moneydance' ... I probably have to manually create a .desktop file for it to launch it.

This could be because i clicked to launch a window and the window never launched and the window manager never found it, perhaps?

Daniel van Vugt (vanvugt) wrote :

Fix committed into lp:compiz-core at revision 3044

Changed in compiz-core:
status: In Progress → Fix Committed
Rosca Stefan (sarvigalava) wrote :

crashed at opening Netbeans :(

Itxaka (itxakaserrano) wrote :

This happened to me as well while trying to install vc2005sp1.exe from wine.

Me too opening Frostwire

arruah (arruah) wrote :

after exiting from Stellarium

RobWilkens (robwilkens) wrote :

I know fix was committed, i've been applying updates daily (or more often) but i still have this problem regularly. When should this fix make it into the beta? Just want to make sure i don't already have it and its still broken.

norberto (netcaster) wrote :

This bug duplicated #932251

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.7.2-0ubuntu1

---------------
compiz (1:0.9.7.2-0ubuntu1) precise-proposed; urgency=low

  [ Łukasz 'sil2100' Zemczak ]
  * New upstream snapshot:
    - Fix global menu not being ergonomical on large screens (LP: #682788)
    - Fix Alt+Right arrow key (LP: #943612)
    - Fix key bindings for actions while doing tap detection (LP: #944631)
    - Window movement is erratic and buggy, backport (LP: #923683)
    - CompScreenImpl::addAction(CompAction*): Assertion `priv->initialized'
      failed (LP: #946118)
    - gtk-window-decorator crash with SIGSEGV in max_window_name_width()
      (LP: #937815)
    - Finish the implementation of the locally integrated menubars
      (LP: #931245)
    - Unity/compiz intercepts keystrokes from grabbed windows (LP: #806255)
    - Pressing alt doesn't show the menu title bar in top panel (LP: #943194)
    - Fix Alt stealing focus from widgets (LP: #943851)
    - Fix Alt + drag (LP: #945373)
    - lp:compiz-core fails parallel builds (make -jN) (LP: #938417)
    - Changing the HUD shortcut disables all Alt-based combinations. And
      changing the Dash shortcut disables all Super-based shortcuts
      (LP: #945816)
    - Fix key bindings (such as Super) not working on empty workspace or on
      slow/loaded systems (LP: #953089)
    - compiz crashed with signal 5 in Glib::exception_handlers_invoke()
      (LP: #808007)
    - Fix segfault caused by r3043 (LP: #958540)
  * Removed cherry-picked patches:
    - debian/patches/fix_806255.patch
    - debian/patches/fix_923683.patch
    - debian/patches/fix_943194.patch
    - debian/patches/fix_944631.patch
    - debian/patches/fix_alt_pressing.patch
    - debian/patches/additional_alt_tapping_fix.patch

  [ Didier Roche ]
  * pick upstream fix, debian/patches/fix_953839.patch:
    [regression] Invisible resize border is now only 1px wide (LP: #953839)
  * debian/patches/revert_lim.patch:
    - revert the integrated menu patch. It won't be released in precise and
      triggers a regression (in bug #962085)
  * debian/patches/fix_953089_2.patch:
    - second trial to fix remaining corner cases
  * debian/patches/exit_1_if_composite_cant_init.patch:
    - try to workaround a crasher which seems to happen when the composite
      plugin failed to initialize. Hopefully exiting 1 will make gnome-session
      respawning compiz and then the init will work. (LP: #833729)
  * debian/patches/always_replace.patch:
    - right now, always replace the current WM as it seems that some people
      got another compositor running at the start of the session. This will
      hopefully workaround the issue that some people experience.
 -- Didier Roche <email address hidden> Fri, 23 Mar 2012 09:13:51 +0100

Changed in compiz (Ubuntu Precise):
status: Triaged → Fix Released
Changed in compiz-core:
status: Fix Committed → Fix Released
Alex (temporal-o) wrote :

Crashed by fullscreen mode of Adobe Acrobat Reader 9.4.7 and Google Earth.

The program 'gtk-window-decorator' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadWindow (invalid Window parameter)'.
  (Details: serial 12302 error_code 3 request_code 20 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

To post a comment you must log in.