Ubuntu 12.04, Expo desktop zoom out causes ugly screen flickering when dragging windows to other desktops

Bug #937740 reported by psypher on 2012-02-21
46
This bug affects 10 people
Affects Status Importance Assigned to Milestone
Compiz Core
Undecided
Unassigned
compiz (Ubuntu)
Low
Unassigned

Bug Description

When activating expo mode, either through the icon in the launcher or using super-s, dragging of a desktop causes really ugly screen flicker. The flicker is almost as if a snapshot of desktop 3 flashes on desktop 1 or desktop 2 flashes on desktop 4. It's like all the desktops suddenly swap around for a split second. Very ugly and detracts from the overall feature and experience. This issue did not exist before Unity.

I have attached a video showing this issue.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: compiz 1:0.9.7.0~bzr2995-0ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-17.26-generic-pae 3.2.6
Uname: Linux 3.2.0-17-generic-pae i686
.tmp.unity.support.test.0:

ApportVersion: 1.92-0ubuntu1
Architecture: i386
CompizPlugins: [core,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Tue Feb 21 13:22:15 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
DkmsStatus: virtualbox-guest, 4.1.8, 3.2.0-17-generic-pae, i686: installed
GraphicsCard: InnoTek Systemberatung GmbH VirtualBox Graphics Adapter [80ee:beef] (prog-if 00 [VGA controller])
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120220)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
MachineType: innotek GmbH VirtualBox
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_ZA:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_ZA.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-17-generic-pae root=UUID=a0a1f314-d62e-4234-8e3b-b8f22ad833c0 ro quiet splash vt.handoff=7
Renderer: Software
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH
version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu4
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0~rc2-0ubuntu5
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0~rc2-0ubuntu5
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

psypher (psypher246) wrote :
psypher (psypher246) wrote :

BTW this happens in 32 and 64bit on a physical machine and a virtual machine. Is not related to version or graphics driver

psypher (psypher246) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Danillo (danillo) wrote :

I'm having this issue too, not as severely as in the video, but noticeably.

In addition to this, I see flickering when I switch workspaces with ctrl+alt+arrows. Flickering can also be seen in the workspace switcher previews.

I'm using Precise Beta 1 with Compiz 0.9.7 and Unity 5.4.0 with Intel GM965 graphics. In fully updated Oneiric everything is fine.

Rutger Putter (rputter) wrote :

I'm also on the lastest Precise but with the ATI Mobility Radeon HD 3650. I'm using the opensource Radeon drivers and the flickering on Expo / Workspace Switching affect me too.

When using fglrx drivers, the flickering is gone. But then the system crashes on watching a video...

greg (grigorig) wrote :

I'm seeing the same with latest Precise on an Atom N270, GMA 950 netbook. This is quite distracting!

Danillo (danillo) wrote :

The desktop cube had this same regression the last cycle and the fix seems to be still being tested. It's bug #876198. Could this one be related? If it is, an user found a workaround hack for it. It's in comments #102 and #106 of that bug report.

Could someone see if the hack fixes this bug too? (I can't test it because I don't have another machine other than my work laptop right now.)

Changed in compiz (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Changed in compiz-core:
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 862430, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers