Ubuntu

Screen edge actions set in CCSM randomly don't work

Reported by Péter Trombitás on 2012-02-14
86
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
Compiz Core
Undecided
Unassigned
Unity
Undecided
Unassigned
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

After the upgrade, screen edge actions (for example, bottom right corner takes me into scale view) doesn't work any more. It might be some change of key name that is not upgraded in ccsm yet though.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: compiz 1:0.9.7.0~bzr2995-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-15.24-generic-pae 3.2.5
Uname: Linux 3.2.0-15-generic-pae i686
.tmp.unity.scope.cities: Error: [Errno 21] Ez egy könyvtár: '/tmp/unity-scope-cities'
.tmp.unity.support.test.0:

ApportVersion: 1.91-0ubuntu1
Architecture: i386
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,mousepoll,regex,gnomecompat,vpswitch,grid,obs,place,move,snap,session,imgpng,resize,wall,animation,expo,fade,workarounds,scale,ezoom,unityshell,scaleaddon]
CompositorRunning: compiz
Date: Tue Feb 14 18:40:11 2012
DistUpgraded: Fresh install
DistroCodename: precise
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2592] (rev 03) (prog-if 00 [VGA controller])
   Subsystem: IBM Device [1014:0582]
   Subsystem: IBM Device [1014:0582]
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha i386 (20120112)
MachineType: IBM 1871F1G
PackageArchitecture: all
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.2.0-15-generic-pae root=UUID=11e15e1c-e161-4b40-ac53-ec247046289c ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/29/2007
dmi.bios.vendor: IBM
dmi.bios.version: 70ET69WW (1.29 )
dmi.board.name: 1871F1G
dmi.board.vendor: IBM
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: IBM
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnIBM:bvr70ET69WW(1.29):bd05/29/2007:svnIBM:pn1871F1G:pvrThinkPadT43:rvnIBM:rn1871F1G:rvrNotAvailable:cvnIBM:ct10:cvrNotAvailable:
dmi.product.name: 1871F1G
dmi.product.version: ThinkPad T43
dmi.sys.vendor: IBM
version.compiz: compiz 1:0.9.7.0~bzr2995-0ubuntu1
version.libdrm2: libdrm2 2.4.30-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 8.0~rc2-0ubuntu5
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 8.0~rc2-0ubuntu5
version.xserver-xorg-core: xserver-xorg-core 2:1.11.4-0ubuntu3
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.99.901+git20120126-0ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20111219.aacbd629-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.17.0-1ubuntu3
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20111201+b5534a1-1build2

Péter Trombitás (trombipeti) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
neyfrota (ney-frota) wrote :

let me add more information

- bootup
- login
Loose my screen-edge settings (top-right:scale bottom-right:expo)
- launch ccsm
- go expo, expo edge,
- remove bottom-right, ok
- re-add bottom-right, ok.
Now expo start work again
- Go scale, bindings, initiate window picker for all windows
- remove top-right, ok
- readd top-right, ok.
Now scale start work again
- Close lid and laptop sleep
- open lid and wake up.
top-right and bottom-right still working
- logout
- login
top-right and bottom-right stop work again (and i have repeat all proccess to re-enable)

Just to know:, i just update [2012,mar,11 ~11pm -3 time] before test
# cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=12.04
DISTRIB_CODENAME=precise
DISTRIB_DESCRIPTION="Ubuntu precise (development branch)"
# uname -a
Linux neyfrota-desktop 3.2.0-18-generic-pae #28-Ubuntu SMP Fri Mar 2 22:11:12 UTC 2012 i686 i686 i386 GNU/Linux
# compiz --version
Compiz 0.9.7.0
# ccsm -v
CCSM 0.9.5.92

matthieu vidal (mvidal0001) wrote :

Hopefully Edge behaviour works perfectly with Windows 8

val (uval) wrote :

same pblm as described by neyfrota.
Reconfiguring the bindings wihtin compizconfig settings manager fixes it temporarly.
After a reboot, the pblm reappears.

matthieu vidal (mvidal0001) wrote :

the problem is still there

Vladimir Znak (init-sub) wrote :

Confirm that the problem exists after 12.04 release. I've noticed that sometimes it works if there are no any windows under the mouse cursor at the edge. Looks like the applications intercept mouse actions instead of being processed by compiz.

Changed in compiz-core:
status: New → Confirmed
summary: - Screen edge actions set in CCSM doesn't work anymore
+ Screen edge actions set in CCSM randomly don't work
Changed in compiz-core:
milestone: none → 0.9.8.0
Changed in unity:
status: New → Confirmed
Changed in compiz:
status: New → Confirmed
Changed in compiz:
milestone: none → 0.9.8.0
Changed in compiz-core:
milestone: 0.9.8.0 → none
Marcin Domański (marcin-doman) wrote :

Hi, just to you know, I've been running into this bug, too, ever since I upgraded to 12.04 (a few days after the release). I would love to have it fixed, I am quite used to the bottom-right corner, which I use for Scale windows.

From what I've noticed:
- it's pretty random, sometimes it does work, but most often it doesn't
- resetting the corner in CCSM seems to fix it, but only temporarily
- it might have to do with either maximized windows, or Google Chrome, which I have maximized, too. But this seems to be fixing it, too:
0) with Chrome and Terminal opened and maximized
1) show desktop
2) click on the desktop, then open a nautilus window (normal size, not maximized)
3) try the bottom-right corner again -> it's working!
4) but ... my Chrome window turns all white and broken. The only way to restore is to re-open it. And this has actually happened quite a few times for me, probably every time I tried this very fix for the bottom-right corner

Sadly, the last trick does not seem to be fixing my other corner, the bottom-left, which I use for showing the desktop.

matthieu vidal (mvidal0001) wrote :

This bug is still annoying ...

Vladimir Znak (init-sub) wrote :

The issue still exists in Quantal with compiz-0.9.8+bzr3249

Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 860375, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers