windows smoothly and slowly lag behind mouse cursor when using multiple monitors

Bug #920650 reported by Eduards Bezverhijs on 2012-01-23
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Compiz Core
Medium
Daniel van Vugt
compiz (Ubuntu)
Medium
Unassigned

Bug Description

I don't know for certain if this unity or compiz bug. I have experienced the same in ArchLinux with compiz 0.9.x.

Story (involving glxgears as a method of predicting slowness).
1. I'm using latest and greatest Van Vugt's PPA for Oneiric
2. When I start unity on a laptop with no monitor attached in 11.10, glxears shows me 2800 fps, everything seems to be smooth, no lags
3. When I attach VGA monitor to the system, glxgears show me about 1200 fps or so, it's still smooth, no lags
4. I try to open windows drag around, more windows, glxgears shows 600 (at this point windowses are kinda slowing behid the mouse pointer, sometimes it's so bad that if I move mouse fast around, windows still move around for 5-7 seconds after I stop)
5. More windows will make lag appear faster (well more resources used more slowness :))
6. This setup is not usable at work cause sometimes it's behaving quite ok for some time, but sometimes even 10 windows make it lag a lot

NOTE: The same driver version (fglrx), ubuntu 11.04 with 0.8.x compiz behaves excellent with 2 monitors as well, it works with ~40 windowses w/o any issues at all, it doesn't lag at all, it's smooth at all times, no heavy glxgears drop when adding second monitor (for comparison: it shows about 3500 at start (one monitor), adding monitor and opening a lot of windowes makes it show no less than 2500).

Somehow I feel that's compiz 0.9.x, as the same lagginess was present in archlinux using 0.9.x, with 0.8.x it was great in arch as well.

Additional info: fglrx 11.12, vsync off, radeon 3650 mobile

If You need any info, please ask, if needed I can try to test it in development version of compiz or precise.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.24.0-0ubuntu2.1
ProcVersionSignature: Ubuntu 3.0.0-14.23~ppa1-generic-tuxonice 3.0.9
Uname: Linux 3.0.0-14-generic-tuxonice x86_64
NonfreeKernelModules: fglrx
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu4
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,imgpng,snap,move,grid,resize,vpswitch,mousepoll,wall,place,gnomecompat,compiztoolbox,unitymtgrabhandles,regex,session,animation,expo,workarounds,ezoom,staticswitcher,fade,scale,unityshell]
CompositorRunning: compiz
Date: Mon Jan 23 22:31:56 2012
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 fglrx, 8.920, 3.0.0-14-generic-tuxonice, x86_64: installed
 fglrx, 8.920, 3.0.0-15-generic, x86_64: installed
GraphicsCard:
 ATI Technologies Inc Mobility Radeon HD 3650 [1002:9591] (prog-if 00 [VGA controller])
   Subsystem: Lenovo Device [17aa:2117]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111011)
JockeyStatus:
 xorg:fglrx_updates - ATI/AMD proprietary FGLRX graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
 xorg:fglrx - ATI/AMD proprietary FGLRX graphics driver (Proprietary, Enabled, In use)
MachineType: LENOVO 205545G
PccardctlIdent:
 Socket 0:
   no product info available
PccardctlStatus:
 Socket 0:
   no card
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: root=/dev/disk/by-label/root ro quiet splash vt.handoff=7 nomodeset vga=0x346 noswap noresume
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/14/2011
dmi.bios.vendor: LENOVO
dmi.bios.version: 6FET91WW (3.21 )
dmi.board.name: 205545G
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr6FET91WW(3.21):bd10/14/2011:svnLENOVO:pn205545G:pvrThinkPadT500:rvnLENOVO:rn205545G:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 205545G
dmi.product.version: ThinkPad T500
dmi.sys.vendor: LENOVO
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu6vv11
version.fglrx-installer: fglrx-installer N/A
version.ia32-libs: ia32-libs 20090808ubuntu26
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Eduards Bezverhijs (mjasnik) wrote :
Bilal Akhtar (bilalakhtar) wrote :

As you've already guesses, this is a compiz issue and not a Unity one.

affects: unity (Ubuntu) → compiz (Ubuntu)
Bilal Akhtar (bilalakhtar) wrote :

Also, does the issue occur with fglrx only? Have you tried it with the open source ATI driver?

Daniel van Vugt (vanvugt) wrote :

Eduards,

When you say you're using my PPA, is that ppa:vanvugt/compiz, ppa:vanvugt/unity or both? Please make sure you're using both for the best performance.

Also, please try enabling "Force full screen redraws (buffer swap) on repaint" in the Workarounds section of ccsm. I find this produces the fastest graphics experience with the PPAs (and presumably will in Ubuntu 12.04 too). The reason why it's not enabled by default (yet) is because it will incur slightly higher CPU usage.

Daniel van Vugt (vanvugt) wrote :

OK, I can see from the attached files that you only have ppa:vanvugt/compiz and not ppa:vanvugt/unity. That means you're missing the fix for bug 861061, so please try ppa:vanvugt/unity.

Eduards Bezverhijs (mjasnik) wrote :

Hi!

I have added unity but nothing was installed from unity PPA, that must be because today morning I updated the system (somehow yesterday there were no updates or I was using outdated servers) and new unity came from non-PPA sources which is newer.
But to my surprise now everything seems to be snappy as with 0.8.x, great work! I don't want to declare this fixed at this point, I'll check more when I'll get home (at work I use 11.04 + 0.8.x).
glxgears won't drop to 1000 after I add second monitor (this was 100% repeatable earlier), it stays about 3000, so this is the first indication that everything seems to be fine.

So, so far so good, I made bug report one day earlier than it was fixed :D Sorry :)

regards
Eduards

Daniel van Vugt (vanvugt) wrote :

While everything seems to be working I'm going to mark this bug as incomplete. If everything keeps working and there are no more comments for a while then it will expire.

Re: Unity updates, I am refreshing ppa:vanvugt/unity with the latest updates from oneiric-proposed today.

Changed in compiz-core:
status: New → Incomplete
Changed in compiz (Ubuntu):
status: New → Incomplete
Eduards Bezverhijs (mjasnik) wrote :

Hi!

I have checked things and they are good. Problem seems to be fixed. Thanks.

regards
Eduards

Eduards Bezverhijs (mjasnik) wrote :

Hi!

Too early I said everything is OK :( It appears that it's quite slow, maybe that was related to monitor sizes, at home I have 1680x1050 monitor (the same as laptop) but here at work I use 1280x1024 + laptop...
Expo is real slow, stutters like hell, glxgears say about 1000 or a bit less.
Here's the output, I added monitor, then run glxgears and then I removed it, see it's 3 times slower :(

4580 frames in 5.0 seconds = 915.950 FPS
4584 frames in 5.0 seconds = 915.856 FPS
4304 frames in 5.0 seconds = 860.729 FPS
4481 frames in 5.0 seconds = 895.409 FPS
4802 frames in 5.0 seconds = 960.303 FPS
4947 frames in 5.0 seconds = 988.372 FPS
2630 frames in 5.0 seconds = 525.977 FPS
12294 frames in 5.0 seconds = 2457.958 FPS
15616 frames in 5.0 seconds = 3123.126 FPS
15157 frames in 5.0 seconds = 3031.375 FPS
16533 frames in 5.0 seconds = 3306.475 FPS
15189 frames in 5.0 seconds = 3037.679 FPS
15787 frames in 5.0 seconds = 3157.373 FPS

I have ppa:vanvugt/compiz and ppa:vanvugt/unity enabled and system was updated yesterday.

regards
Eduards

Eduards Bezverhijs (mjasnik) wrote :

Hi!

This is from 0.8.6 (ubuntu 11.04):
---------------------
[user@laptop Desktop]$ glxgears
19247 frames in 5.0 seconds = 3849.346 FPS
20104 frames in 5.0 seconds = 4020.706 FPS
20427 frames in 5.0 seconds = 4084.689 FPS
19975 frames in 5.0 seconds = 3994.952 FPS
20957 frames in 5.0 seconds = 4190.939 FPS
20860 frames in 5.0 seconds = 4171.903 FPS
8556 frames in 5.4 seconds = 1573.052 FPS
16801 frames in 5.0 seconds = 3360.080 FPS
19385 frames in 5.0 seconds = 3876.973 FPS
19233 frames in 5.0 seconds = 3845.885 FPS
19571 frames in 5.0 seconds = 3914.026 FPS
^C
[user@laptop Desktop]$ compiz --version
compiz 0.8.6
[user@laptop Desktop]$
---------------------

Hope this shows the problem.

Overall experience using Unity is quite slow comparing to old gnome + compiz, I realized that for real only when tried to use that as my main machine.
It seems that 0.9.x is doing smth quite slowly compared to 0.8.x.

If needed I can provide anything that could help to solve the slowiness.

regards
Eduards

Changed in compiz-core:
status: Incomplete → New
Changed in compiz (Ubuntu):
status: Incomplete → New
Changed in compiz-core:
status: New → Confirmed
Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in compiz-core:
importance: Undecided → Medium
Changed in compiz (Ubuntu):
importance: Undecided → Medium
Changed in compiz-core:
status: Confirmed → Triaged
Changed in compiz (Ubuntu):
status: Confirmed → Triaged
walterav (walterav) wrote :

Compiz 0.9.7.6 regression? duplicate bug 982263

Opensource and Closed drivers affected on both ATI/AMD, Nvidia and Intel.

Suspend & login logout also affected!

Like Eduards Bezverhijs mentioned in post 6 this bug has really partly been fixed even on the multimonitor setup with high screen resolutions (I was really amazed to see that it finally worked!) but it also regressed back on the update of compiz 0.9.7.6. a couple of days ago. So somewhere between the first big compiz upgrade of 12.04 LTS in january or februari this was really fixed and performance was snappy and smooth even on a netbook with multimonitor, only after wake from suspend these former versions are also affected but logging out and login again fixed it.

I can confirm that this buggy behavior is not in compiz 0.9.7.2/4 version (suspend excluded) but on these version and the new compiz 0.9.7.6. after suspend especially the regressed compiz 0.9.7.6 (logout/login doesn't help in this version) becomes incredibly slow.

Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 874619, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

Changed in compiz-core:
assignee: nobody → Daniel van Vugt (vanvugt)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers