Ubuntu

Desktop-Effects Bug. Left Mouse Click doesn't work.

Reported by Benjamin Chung on 2007-03-09
46
This bug affects 7 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

To clarify bug:

When enabling Desktop-Effects, my left click on my mouse button does not function the way its suppose to. Only way I can left click on anything is to hold CTRL+ALT keys down.

Benjamin Chung (crazebenny) wrote :

To clarify bug:

When enabling Desktop-Effects, my left click on my mouse button does not function the way its suppose to. Only way I can left click on anything is to hold CTRL+ALT keys down.

description: updated
Julian Robbins (joolsr) wrote :

I get exactly the same problem. Running Feisty, up to date as of 20th March 2007.

using full ubuntu Nvidia drivers with nvidia Geforce 6600 PCI-E running 32 bit feisty but its actually a 64 bit amd pc.

what other info do you require ?

Matthew Buckett (buckett) wrote :

I get exactly the same problem with left clicks not working.

It seems to be related to screenshots, as after enabling desktop effects dragging an area with the left mouse causes that area to be saves as a screenshot on my desktop.

This persists through logouts and I still get the same symptoms when logging in with a failsafe gnome session from gdm.

Right clicks and middle clicks do however seem to work correctly.

Same problem. Running feisty up to date as of 27 march 2007.

Graphics card is a Nvidia 6800 with the binary nvidia drivers from the repositories
(1.0.9755+2.6.20.4-13..12)

As stated before, left clicks cause a screenshot dragging function.

Changed in compiz:
status: Unconfirmed → Confirmed
Paulo (holeoc) wrote :

I get exactly the same problem. Running Feisty

Santiago Canez (canez) wrote :

Disabling initiate_button under apps/compiz/plugins/screenshot/allscreens/options in gconf-editor fixes this for me.

Travis Watkins (amaranth) wrote :

We no longer enable the screenshot plugin in gutsy.

Changed in compiz:
status: Confirmed → Fix Released
Jean-Luc Boss (jlb74) wrote :

Hi,

I get this error since 2 weeks now, with gutsy, 64Bit AMD64 (X2 4400- Asus A8V), Nvidia 7600.

The aboce fix doesn't work for me ...

Best regards,
Jean-Luc

Travis Watkins (amaranth) wrote :

That is not possible. In addition to not enabling the screenshot plugin the root problem has also been fixed. This bug talks about the left mouse button not working the instance you enable visual effects. I have a feeling you're talking about some random lockup where the mouse moves but nothing else works.

Jean-Luc Boss (jlb74) wrote :

Hmm,

No, i've got that behaviour, with 64 Bit gutsy, i can only click with the left mouse button if i hold the shift or ctrl key.
A normal left click has no effect, enabling or disabling all plugins has no influence.
Currently i have no lock-up problem with compiz.

How can i check the current compiz version, i'm installing the updates as soon as they appear.
Best regards,
Jean-Luc

Travis Watkins (amaranth) wrote :

You're using a keyboard that doesn't have a Super (Windows) key?

Jean-Luc Boss (jlb74) wrote :

No, i have one :)

But i did never use it until now....

Travis Watkins (amaranth) wrote :

If your keyboard has a windows key this isn't your bug. Perhaps you have some invalid configuration. Install compizconfig-settings-manager and use it to reset all settings to defaults.

JLB (news-eserver) wrote :

Great :)

I had the compizconfig-settings-manager installed and i went to the Preference tab and i did a "Resore to defaults".
After this everything worked again...

Thank you Travis,
JL

John Rash (johnrash) wrote :

I had this same problem occur in 10.4 Lucid after an update and resetting Compiz to defaults using compizconfig-settings-manager fixed this for me as well.

Changed in compiz (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
Rob Bednark (rbednark2) wrote :

I had a similar problem. Twice now, my left-button on my mouse stopped working. The first time I rebooted. The second time, I was able to get it working again by holding down the right Ctrl key and left-clicking. I've now changed Visual Effects from "Normal" to "None" to see if that prevents it.

Richard Tuin (richardtuin) wrote :

I have a related issue:

Every now and then my left mouse button stops working. I have to reboot to solve the issue.
It occurs irregularly, that's the strange thing. I have no idea if it has to do with any key combination i press before it occurs.

Desktop effects are on.
@Rob Bednark, Did changing your Visual Effects settings help solve the problem?

Edward Cherlin (echerlin) wrote :

I get this frequently, now several times a day. Certain uses of the left mouse button stop working, but not all. Which uses fail is not predictable. When I first got it, Ctl-click worked for most uses. Now that has no effect.

Many times the mouse button stops working when I have made half of a text selection, just a starting point. Then even with the mouse button up, moving the mouse just moves the other end of the selection around. I can usually move the starting point of the selection with the arrow and other keys. There was a time when left-clicking produced the grabbing hand for click-and-drag, as with Super-click. No more. Sometimes the cursor changes shape normally between text, pointer, and pointing hand (for URLs) and sometimes not.

Workaround, up to a point: Key combinations. Tab to select buttons or menu options, Return to activate. Ctl-Alt-Tab to switch between apps in different workspaces. Alt-F1 to get to toolbar menus (sometimes). Ctl-Alt-Del works for shutting down most of the time. When it doesn't I get a Terminal from the Accessories menu, if possible and use

sudo halt

I have tried CompizConfig settings manager. Apparently I used to have that problem, but now I have a different one.

I have just now turned off Visual Effects. We shall see.

Ubuntu 10.4
Gnome
Firefox

All updates applied

Edward Cherlin (echerlin) wrote :

Nope. Turned off Visual Effects, still have the bug.

I have the same problem in ubuntu 10.10. The left button stops working but the right button stills working.

As a note, I tried to put the left-handed mouse settings, and at that time the right button
stopped working right and the left button started doing it, still with the same problem but
changed the physical buttons ¡

Oh01 (ydzregistrations) wrote :

Here is how I solved this in Ubuntu 10.04. First, thanks for the tip above to use Ctrl-Alt-Left Click for mouse clicks (Note: try also Ctrl-Shft-Left Click, whichever work). This workaround enabled me to do:

Applications > Ubuntu Software Centre> Search for COMPIZ > install "Advanced Desktop Effects Settings (ccsm) (Configure Compiz with CompizConfig)".

Then, in top Gnome panel, go to System > Preferences > CompizConfig Settings Manager > Preferenc (note typo in the UI; it's a gray button in left frame, below "Window Management") > Clear the check box next to "Enable integration into desktop environment".

Mouse buttons started to work normally again!

It seems to me like the bug might be in the Compiz "Enable integration into desktop environment" in Ubuntu 10.04 (and higher?). I wish I was technical enough to try verify myself. Thanks in advance for looking into it.

Xavi Ivars (xavi-ivars) wrote :

I've tried to solve this issue with the previous workaroud, but it didn't work.

I've got two laptops, one with a Nvidia graphic card, with Ubuntu 10.04, and the othe one with an embedded Intel graphic card and Ubuntu 10.10 (fresh install), and in both it happens randomly. I don't know what to do, and I'm afraid a might have to change back to another distro or to a Windows-based OS (being with Ubuntu since 5.04).

I also have two more PC (desktop) with 10.10 and the do not appeas on them.

I get this, too. I've found that if the left-mouse button stops working (on my external mouse), then if I click on the touchpad left-mouse button, all reverts to normal. It seems to be stuck in some sort of selection mode (sometimes text highlights as I move the mouse).

DodgeV83 (spamfrelow) wrote :

Just had this issue on a new 11.04 installation, post #21 fixed it for me. THANKS!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers