"Move to Another Workspace" causes window to disappear

Bug #885070 reported by Colan Schwartz on 2011-11-02
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Low
Unassigned

Bug Description

After logging into the "Ubuntu" session (this does not happen with "Ubuntu 2D", only 3D), moving a window to another workspace makes it disappear. I tried this with several applications in the launcher, and got the same result. Although the processes aren't dead, they no longer show as open in the Unity launcher, and disappear.

I've got a 3x3 workspace grid.

The other strange thing, which might be related, is that the pull-down menu always shows "Move to Workspace Right" even if it's not possible to go right, and no other relative options (Left, Up, Down) are ever shown even when it's possible to go in those directions given the current position in the grid.

I suppose this could be a compiz bug as it doesn't happen with metacity. I wasn't sure whether to file it under compiz or unity.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.24.0-0ubuntu2b1
ProcVersionSignature: Ubuntu 3.0.0-13.21-generic 3.0.6
Uname: Linux 3.0.0-13-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 280.13 Wed Jul 27 16:53:56 PDT 2011
 GCC version: gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3)
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,compiztoolbox,imgpng,snap,resize,put,gnomecompat,workarounds,scale,regex,move,mousepoll,place,ezoom,session,wall,switcher,staticswitcher,unityshell]
Date: Wed Nov 2 00:19:44 2011
DistUpgraded: Log time: 2011-10-01 19:34:45.083785
DistroCodename: oneiric
DistroVariant: ubuntu
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 nVidia Corporation C77 [GeForce 8200] [10de:0849] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:82f2]
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100427.1)
JockeyStatus:
 xorg:nvidia_173 - NVIDIA accelerated graphics driver (Proprietary, Disabled, Not in use)
 xorg:nvidia_173_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Disabled, Not in use)
 xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Enabled, In use)
MachineType: System manufacturer System Product Name
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
 SHELL=/bin/zsh
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-13-generic root=UUID=3c864589-1f17-472b-a1f3-cfd34aa59f84 ro splash
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-10-02 (30 days ago)
dmi.bios.date: 01/13/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0907
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: M3N78-VM
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0907:bd01/13/2009:svnSystemmanufacturer:pnSystemProductName:pvrSystemVersion:rvnASUSTeKComputerINC.:rnM3N78-VM:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: System Product Name
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu5
version.ia32-libs: ia32-libs 20090808ubuntu26
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Colan Schwartz (colan) wrote :
affects: unity (Ubuntu) → compiz (Ubuntu)
Changed in compiz (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Barneedhar (barneedhar) wrote :

I can no longer reproduce this bug. Marking it as invalid. If the OP can still reproduce this bug, please feel free to change the bug status.

Changed in compiz (Ubuntu):
status: Confirmed → Invalid
Colan Schwartz (colan) wrote :

Still getting this so setting it back to Confirmed.

Is there anything we can look for to provide more information?

Changed in compiz (Ubuntu):
status: Invalid → Confirmed
Sam Spilsbury (smspillaz) wrote :

I cannot reproduce this.

Sam Spilsbury (smspillaz) wrote :

Also not seeing "move to a workspace right" when it isn't possible to go right.

Colan Schwartz (colan) wrote :

With all of the latest updates in Proposed, I changed the profile from "Default" to "unity" in CompizConfig Settings Manager's Preferences section. That seemed to fix it. Thanks!

I get the same behavior - I right click on a window, select "Move To Workstation x", and the window just disappears (doesn't show on the workstation I select)

"With all of the latest updates in Proposed, I changed the profile from "Default" to "unity" in CompizConfig Settings Manager's Preferences section. That seemed to fix it. Thanks!"

I changed the profile, but still occurs

berend (berenddeboer) wrote :

I have exactly the same problem. This is on Precise.

After having all kinds of trouble (frequent random X freezes) I did a "reset to defaults" of the unity profile using Compiz preferences. Had to rebuild my settings after that, and that's also when move to workspace stopped working.

berend (berenddeboer) wrote :

If I switch to the defaults profile it works actually. And my difference is that I have "Desktop Wall" enabled instead of "Desktop Cube"/Rotate Cube.

berend (berenddeboer) wrote :

Suggestion: might the problem be that you have number of desktops > 1 in "Desktop Size"?

That was my problem I believe now.

Lee Gimblett (lee-gdstech) wrote :

I have suffered this issue without resoving it from a fresh install of Quantal which carried through the Raring upgrade. The exact same symptoms. I can confirm that berend's suggestion (#11) worked for me.

I thought that the the third destop size parameter in ccms -> General Options-> Desktop size-> Number of Desktops would be derived from the two above(Horizontal amd Veritical size), but its not. By putting it back to one the problem was solved. I have a straight 5 horizontal workaspace setup.

Glenn Washburn (crass) wrote :

I can also confirm that berend's suggestion (#11) worked for me. This was also the OP's issue as well (as can be seen in his GconfCompiz.txt).

What's the point of the "Number of Desktops" setting then?

Chris Doehring (chrisdoehring) wrote :

I'll add that berend's suggestion (#11) fits my case. To solve, I inspected settings using gsettings and I found number-of-desktops set to "2". When I set it to 1 (which I believe is the default value) the problem went away.

Here's an example from console:

# Find the keys I'm looking for.
gsettings list-keys org.compiz.core:/org/compiz/profiles/unity/plugins/core/
...
hsize
vsize
number-of-desktops
...

# Get the current value for number-of-desktops
gsettings get org.compiz.core:/org/compiz/profiles/unity/plugins/core/ number-of-desktops
2

# Set my desired values for number-of-desktops, and number of workspaces.
gsettings set org.compiz.core:/org/compiz/profiles/unity/plugins/core/ number-of-desktops 1
gsettings set org.compiz.core:/org/compiz/profiles/unity/plugins/core/ hsize 2
gsettings set org.compiz.core:/org/compiz/profiles/unity/plugins/core/ vsize 2

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers