Can't highlight bottom row of workspaces with mouse (Unity workspace switcher)

Bug #879971 reported by Thanos Lefteris on 2011-10-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Compiz
Low
Unassigned
compiz (Ubuntu)
Low
Unassigned

Bug Description

I have the default four workspaces. In the unity workspace switcher, when I single-click the top half of the area of a workspace, I can't highlight it. I can only select a space, when I click somewhere bellow the bottom half of its area (as defined by the orange border). This problem happens ONLY to the bottom two of the four available workspaces.

Also I can double click anywhere and the space switches. So, the problem is only with the selection/highlighting of the workspace.

I'm also using a multimonitor setup, if this has anything to do with it.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.22.0-0ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu3
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,move,resize,gnomecompat,vpswitch,place,mousepoll,grid,wall,snap,session,imgpng,regex,unitymtgrabhandles,animation,fade,workarounds,expo,scale,ezoom,unityshell]
CompositorRunning: compiz
Date: Sat Oct 22 18:37:08 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
GraphicsCard:
 Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:167e]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111011)
MachineType: Hewlett-Packard HP ProBook 4330s
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.0.0-12-generic root=/dev/mapper/ubuntu_vg-root_lv ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/13/2011
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: 68SRR Ver. F.09
dmi.board.name: 167E
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 22.1A
dmi.chassis.asset.tag: CNU13927P8
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.modalias: dmi:bvnHewlett-Packard:bvr68SRRVer.F.09:bd05/13/2011:svnHewlett-Packard:pnHPProBook4330s:pvrA0001D02:rvnHewlett-Packard:rn167E:rvrKBCVersion22.1A:cvnHewlett-Packard:ct10:cvr:
dmi.product.name: HP ProBook 4330s
dmi.product.version: A0001D02
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu5
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Thanos Lefteris (alefteris) wrote :
description: updated
Changed in unity (Ubuntu):
importance: Undecided → Low
Changed in unity:
importance: Undecided → Low
affects: unity (Ubuntu) → compiz (Ubuntu)
affects: unity → compiz
Bryce Harrington (bryce) wrote :

I'm not able to reproduce this behavior on Precise with Ubuntu on an Intel gfx laptop in a docking station. I tried both with a single monitor and with an external monitor. Single-clicking to select the workspace always worked, and doubleclicking seemed to work as well.

I did notice some wonky screen painting problem but that's a separate bug, which I'll file subsequently.

Would you mind testing to see if the problem also is resolved in your case in Precise? If you don't want to install Ubuntu Precise, it should be sufficient to boot a Live USB session, configure the monitors, and see if it is working properly now. You can get the current Live USB desktop image at http://cdimage.ubuntu.com/daily-live/current/ and create a USB boot drive using usb-creator.

Changed in compiz (Ubuntu):
status: New → Incomplete
Thanos Lefteris (alefteris) wrote :

Tested with the 16/12 daily live of precise and I still have an issue. When clicking the 3rd workspace someplace (I don't remember the position), it will highlight the 1st one, instead of the 3rd. I can also see messed up graphics in the laptop monitor, when using the workspace switcher. In my primary monitor, it is rendered fine.

My configuration is the following:
 - External monitor connected by HDMI to laptop, 1920x1080, primary
 - Laptop internal monitor, 1366x768, placed right of the primary
 - Intel graphics

Bryce Harrington (bryce) on 2012-01-04
Changed in compiz (Ubuntu):
status: Incomplete → Confirmed
Bryce Harrington (bryce) wrote :

Hmm, well I still am unable to reproduce it. The corrupted graphics I mentioned earlier are also gone.

Please re-test with unity 5.2 (or newer).

Changed in compiz (Ubuntu):
status: Confirmed → Incomplete
dino99 (9d9) wrote :

That version has reached EOL since a while, so it will not receive update. If that issue still exist, report again using ubuntu-bug.

Changed in compiz (Ubuntu):
status: Incomplete → Invalid
Changed in compiz:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints