compiz doesn't show any windows with VirtualBox guest additions

Bug #876999 reported by Stephen Wade on 2011-10-18
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned
nautilus (Ubuntu)
Undecided
Unassigned

Bug Description

Host configuration:
VirtualBox 4.1.4 – Mac OS X 10.7.2

Guest configuration:
Ubuntu 11.10
2 processors – 1 GB RAM
128 MB video memory – 3D acceleration enabled

The VirtualBox guest additions were installed through "Additional Drivers". After rebooting, all the UI is visible including the login screen and the Unity interface, but when any application is opened, its window is invisible.

Notes:
When the virtual machine is logged in with "Ubuntu 2D", I can run "compiz --replace" and get compiz working properly.
The problem occurred on both a VM upgraded from 11.04 to 11.10 and a fresh install of 11.10 (used for screencasts below).
The problem occurred using both the guest additions package from "Additional Drivers" and the guest additions ISO shipped with VirtualBox.

"Ubuntu" video here: http://screencast.com/t/wZIug5RsG3fh
"Ubuntu 2D" video here: http://screencast.com/t/R6LsrTVyIC

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Daeld (daeld-daeldia) wrote :

Also affects me in the same way. Try this for a temporary workaround:

Log in to Ubuntu (3D) as normal. Open a window. Window is invisible.
Click on Workspace Switcher on the dock. The windows become visible again. Click on the workspace to use the window. (note that the title bar is still invisible if not maximised. If maximised, there will still be some minor problems. Using workspace switcher will fix most of these.

Now this is not a long-term workable solution, but it may help others work in the environment in question and be able to come up with a solution or a better workaround.

Daeld (daeld-daeldia) wrote :

Additional info:

opening the terminal is annoying because even after using the Workspace Switcher, it is still invisible.

Fro some reason, typing "killall nautilus" will make the terminal look and work normally (at least until you close it). Unfortunately this does not fix anything else.

Daeld (daeld-daeldia) wrote :

More info (I typed too soon before)

I can now confirm that typing "killall nautilus" will fix all application windows until a nautilus instance is loaded (eg opening the home folder). This will cause all other windows to become invisible again. However, retyping killall nautilus will fix again.

Obviously this is only a debugging workaround as the user cannot still use nautilus. It seems, therefore, that this is related to Compiz's interactions with Nautilus under Unity (3D).

Daeld (daeld-daeldia) wrote :

OK as a temporary workaround:
Step 1: Login to Unity
Step 2: type Alt-F2 (or fn-alt-F2 on a Mac)
Step 3: type "killall nautilus" (without the ") and press enter (you will now be able to see windows, but don't open any nautilus windows)
Step 4: install pcmanfm (or other file manager either from terminal: "sudo apt-get install pcmanfm" or from Software Centre)
Step 5: open a window with the new file manager and add it to the unity launcher
Step 6: remove the nautilus home folder from the launcher

When you reboot and log in again, you would have to follow steps 2 again, so to prevent that there should be a way to automate the killall nautilus command. However, I tried to just put it in the start-up applications and this killed the gnome session.

Daeld (daeld-daeldia) wrote :

Sorry to post yet again, but after further testing, it seems that, although the above works OK, there are still some other bugs that are likely to be part of the same problem:

1. The launcher will not always (almost never) reveal itself when there is a maximized window
2. The dashboard will sometimes reveal itself underneath an open window
3. The dashboard seems to always reveal itself underneath a maximized window
4. Same for fn-alt-F2
5. Because we killed nautilus, the desktop no longer works as a folder

Still, that's at least something to work on.

Also, in case anyone smart finds this useful: the Workspace Switcher (WS) trick has to be done after almost every change to the window (as if it does not refresh). Before finding that killall nautilus helped, i tried doing an update. The interesting thing is that in the WS view, the window updated itself without any visible problem (ie the progress bar and the details worked as normal), but when back to the window, it would stay static.

Claudio Satriano (claudiodsf) wrote :

I can confirm on my side that this is Nautilus-related.

Should we upgrade the bug description accordingly?

Daeld (daeld-daeldia) wrote :

I think the key is that this seems to be related to a problem in how VirtualBox 4.1.4 works on a Mac to host a Unity guest. This is not a problem in my normal installation of Ubuntu. I don't know why it only appears to be affecting the Mac version of VirtualBox. However, I suspect that the nautilus crew would say that the problem lies in how VirtualBox on the Mac handles their program. The onus would therefore be on VirtualBox to fix whatever problem there might be.

In my limited experience, it seems that VirtualBox has been having problems with Ubuntu Unity since late in 11.04 on the Mac.

Stephen Wade (stephenwade) wrote :

I haven't had any problems with Unity on 11.04, only after upgrading to 11.10.

I'll add this bug to the nautilus project as well.

Is there a bug tracker or some problem reporting tool for VirtualBox that should be notified?

I seem to have found an alternative workaround. In gnome-tweaks (advanced settings) , under Desktop, choose "have file manager handle the desktop" to "off". It seems to me that this makes the invisible windows bug to disappear. The price, I guess,
is that you do not have icons on the desktop anymore. But you can use nautilus. And dont have to do the "killall nautilus" routine.
For some this might be less annoying workaround.

Daeld (daeld-daeldia) wrote :

I can confirm that camillo's workaround works perfectly on my machine.

Changed in compiz (Ubuntu):
status: Confirmed → In Progress
status: In Progress → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

affects: nautilus → nautilus (Ubuntu)
Changed in nautilus (Ubuntu):
status: New → Confirmed
Changed in nautilus (Ubuntu):
status: New → Confirmed
Stephen Wade (stephenwade) wrote :

Just got around to testing camillo's fix and it works fine! For those who can't find the "Advanced Settings" tool, you may have to install package gnome-tweak-tool.

Matthew Sedam (sedammatthew) wrote :

I reported this bug to Virtualbox - http://www.virtualbox.org/ticket/9863

Duwe (pdmes) wrote :

This also happens to me
On Virtualbox 4.1.12 Using latest Ubuntu 12.04 On Mac OS x 10.7.3 ATI X1900 Graphic card

fcole90 (fcole90) wrote :

As part of the big bug clear up for 16.04 we have reviewed this bug and we will not be working on it in the near future. Sorry we can't offer you a fix. We will of course review patches if anyone submits them. Please stop by IRC to discuss this option.

tags: added: desktop-bugscrub-wontfix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.