Ubuntu

When switching workspaces with rotate/cube previous Ws contents are momentarily displayed

Reported by Doug McMahon on 2011-10-17
828
This bug affects 172 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
compiz (Ubuntu)
Medium
Unassigned

Bug Description

this started appearing right after the release of unity-4.20.0-0ubuntu1
The symptoms are pretty much the same as seen in this bug though the issue with the workspace switcher(expo) started a bit earlier & at that point rotate/cube was still ok
bug 861088
The above bug seems to have been fixed with compiz-1:0.9.6+bzr20110929-0ubuntu4/5 but the issue remains when using rotate/cube instead of wall

The flashing is seen in all means of switching with rotate, ie. crtl+alt=arrow keys, scroll on desktop, ect.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: compiz 1:0.9.6+bzr20110929-0ubuntu5
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 280.13 Wed Jul 27 16:55:43 PDT 2011
 GCC version: gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3)
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu3
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,vpswitch,mousepoll,snap,wall,grid,place,move,resize,gnomecompat,imgpng,regex,session,animation,workarounds,unitymtgrabhandles,fade,expo,scale,ezoom,unityshell]
CompositorRunning: compiz
Date: Mon Oct 17 00:30:16 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current-updates, 280.13, 2.6.39-3-generic, i686: installed
 nvidia-current-updates, 280.13, 3.0.0-12-generic, i686: installed
GraphicsCard:
 nVidia Corporation G86 [GeForce 8400M GS] [10de:0427] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0209]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
JockeyStatus:
 xorg:nvidia_173 - NVIDIA accelerated graphics driver (Proprietary, Disabled, Not in use)
 xorg:nvidia_173_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Disabled, Not in use)
 xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Enabled, In use)
MachineType: Dell Inc. XPS M1330
PackageArchitecture: all
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=a575c31a-af71-4dfc-ac88-a0d8c94a7335 ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
XorgConf:
 Section "Device"
   Identifier "NVIDIA GeForce"
   Driver "nvidia"
   Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x3322; PowerMizerDefaultAC=0x1"
 EndSection
dmi.bios.date: 12/26/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A15
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA15:bd12/26/2008:svnDellInc.:pnXPSM1330:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: XPS M1330
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu5
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Doug McMahon (mc3man) wrote :
Doug McMahon (mc3man) wrote :

new bug report specific to rotate/cube
Bug 876198

Doug McMahon (mc3man) wrote :

ingnore above comment - posted in wrong report

Glen Shrubsall (stinkeye) wrote :

Same problem.
Switching workspaces when using the cube and ctrl+alt+arrow produces a momentary flash of the previous workspace
you just switched from.
Also when using ctrl+alt+shift+arrow to rotate with window, after the flash the moved window disappears back
to the previous workspace.
Clean install of ubuntu 11.10 using unity.

Compiz Version: 1:0.9.6+bzr20110929-0ubuntu3
Processor: AMD Athlon(tm) II X2 240 Processor × 2
Memory: 2G
Graphics Processor: GeForce 210/PCI/SSE2/3DNOW!
NVIDIA Driver Version: 285.05.09
OS type: 32bit

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
David Rando (david-rando) wrote :

Sane here, i'm running ubuntu oneiric on a laptop with an intel 4500hd, with exactly that problem.

I tried upgrading compiz from the proposed repository and the bug is still there.

Ayzen (ayzen-quwe) wrote :

I'm also affected by this annoying bug. And it seems that bug is not related to video cards. I have this bug on computers with Radeon and Intel cards...

Doug McMahon (mc3man) on 2011-10-17
description: updated
Jmadero (jmadero) wrote :

Agreed, two more machines showing the bug both on intel card though

glennric (glennric) wrote :

This happens for me to. I didn't realize the ctrl+alt+shift+arrow issue though until I read Glen Shrubsall's comment, but that happens for me as well. So it is impossible to move a window to another workspace with keyboard shortcuts. Dragging the window with the mouse still works, but I much prefer using the keyboard shortcut. I hope this gets fixed soon.

glennric (glennric) wrote :

By the way, I am not using unity. I am using the GNOME Classic session, and these issues occur there as well.

Michal Voců (michal-vocu) wrote :

Same here, happens on all my three machines (Intel, ATI cards), with or without unity. Very annoying.

Unc0nn3ct3d (netflow) wrote :

I can also confirm this bug. It is possible to move windows to another worspace by dragging them over with the mouse but that is the only way.

Unc0nn3ct3d (netflow) wrote :

I found a pretty rough workaround for this. If you move the window with ctrl-alt-shift left/right and then when yhou get it where you want it quickly let go of shift and just rotate the cube somewhere else the window will stay in place.

Same here with ATI's privative driver, Ubuntu 11.10 and Gnome in fallback mode.

Also, the window in the final desktop looses the focus, forcing to click on it with the mouse to regain it and be able to type. This is very annoying when coding with the editor in one desktop, and with the documentation in other desktop.

Ayzen (ayzen-quwe) wrote :

Raster, I noticed that focus problem appears only in Cube. Maybe we should open separate issue for this bug?

Ayzen: yes, good idea.

mia1dolfan (mia1dolfan) wrote :

Still not assigned to anybody? Fix fast please.... Nvidia Binary too

cro (cro) wrote :

This appears to happen regardless of window manager. I've seen this behaviour in Unity, Gnome classic, XFCE4, LXDE, Lubuntu and MATE (the Gnome2 fork).

The focus issue appears in all the above, as well as the moving windows with keyboard shortcuts. A serious regression seems to have been introduced with Ubuntu 11.10 that affects a range of display issues.

Changed in compiz (Ubuntu):
importance: Undecided → Medium
Sam_ (and-sam) wrote :

Possibly dupe Bug #874862

selectstar (martinsarsini) wrote :

I am not sure if this is allowed to do in launchpad.net
I am having the same issue, but I am also having an issue that I think is related: when switching workspaces with rotate cube the focus stays on active window of last screen.
I have opened a separate bug fort this Bug #885125

Sam_ (and-sam) wrote :

Should there be a new bug filed regarding #4 issue ctrl+alt+shift+arrow doesn't move selected window to another workspace? Workaround here: move window by right click on menu (not possible in full screen mode).

Fabounet (fabounet03) wrote :

+1 here for the glitch, and +1 for the ctrl+alt+shift+arrow
nVidia 7300, proprietary drivers, Unity disabled

Tanker Bob (tankerbob) wrote :

+1 for the behavior here with ctrl-alt-arrow. Even happens when rotating the cube with the mouse. When you stop on a desktop, the old one flashes there momentarily. nVidia 8800GTS, current proprietary drivers, using Unity.

gunwald (gunwald) wrote :

I can confirm that bug. It occurs on my machine on every cube rotation event. It is really annoying bug! I tried with fglrx and radeon, both the same problem.

mia1dolfan (mia1dolfan) wrote :

The message I'm started to get in 11.04, and even more in 11.10 is that Ubuntu doesn't care about there power users anymore. Sorry everybody, just hope it gets fixed by luck in 12.04. This issue doesn't affect the out of box experience, someone has to change a setting to expose this. Changing settings not allowed!

Ellis Rahhal (elrah) wrote :

I'm an person with obsessive compulsive disorder, and this bug makes it impossible for me to use compiz.

Andy (andy-xillean) wrote :

I am thinking something could be tweaked in ccsm so I have tried toggling a few things in ccsm but no luck. Still having this problem. I suspect its something minor but who knows at this point. Does anyone have any suggestions for a workaround for this issue?

CarVac (airplaniac2002) wrote :

Possibly related to this problem (which I'm experiencing on Intel graphics) is when I switch desktops, the momentary flashing seems to focus on the last window used on the other desktop, meaning I have to click or alt-tab to select a window on the current desktop before I can type or use any keyboard shortcuts. It's incredibly irritating.

I also have window focus issues with the scale plugin, which may or may not be related: when I click to select a window in that plugin, the window sometimes receives the click, doing something that I don't want it to do.

Andrew Rowls (eternicode) wrote :

I'm suffering from this, too; rotate cube shows a flash of the previous workspace, moving a window with rotate cube borks after the rotation, and using "fade" for my focus animation causes a flicker instead of a smooth fade ( might be #147141 ).

Oneiric x64, Intel core i5-2430M HD3000 integrated graphics with i915 driver. My environment is built up from an ubuntu server base, so no unity. Xdm + ~/.xinitrc + compiz is my wm.

My workaround until this is resolved is to use Desktop Wall instead of Cube. Wall works really well for both desktop switching and window moving -- probably because it's the primary workspace manager for Unity.

gunwald (gunwald) wrote :

Is there any hope that this bug will be fixed soon? Or is it recommended to change the compiz configuration for all my 12 workplaces telling everyone that due to a bug he has to get used to a new effect. Desktop cube with this bug became unfortunately unusable, this flickering drives you crazy.

Gabriele (gabriele-puppis) wrote :

Is this bug still unassigned?? It is not just the flickering that drives you crazy, it is also the fact that you cannot rotate the desktop with a window (so you cannot move windows between different workspaces). I am quite disappointed with this last distribution...too many bugs.

More than 1 month and this bug is still unassigned... that's very sad! This 11.10 version really disappointed me

Jorrit (skimbu) wrote :

I have the same issue also you see the ´flash´ from the window on the previous work space.

quequotion (quequotion) wrote :

Sam mentioned in bug 874862 (comment #14) that he's worked out a fix but it needs testing.

That testing would be much easier if there were at least a bzr branch with the code.

Why is this being held back?

>Sam Spilsbury (smspillaz) wrote on 2011-10-20:
>...
>Actually, the fix for this was insanely complicated.
>
>I've done it but it requires a bit more testing because its a big
>change to the way we do rendering.
>...

nshiell (nshiell) wrote :

I also see it with Nvidia propriety driver (Ubuntu 11.10)
Window flash after rotate noticeable
"move with window" feature not working, just leaves the window on the original workspace

I have the exactly same issues here on my computers running Ubuntu 11.10: Acer aspire one 532h with Intel Corporation N10 family and Acer Aspire R3610 with nVidia Corporation ION VGA.

One thing I notice is that if I go to System Definitions > System info, graphics there appear as UNKNOWN, don't know if it is related to bug or not, but it is weird since graphics info appears if I use command line: lspci. This happens in both machines.

Hope someone can fix this, cause these are, for me, is much used to switch screens and change window from one screen to another.

Also, I found that when I try to 'drag and drop' one window from one screen to other, the process never finishes... Rotation slows down as mouse gets closer to the left/right screen border.

achess (achess) wrote :

Same problem. VAIO VGN-FZ11S. NVIDIA GeFORCE 8400M GT GPU. Ubuntu 11.10 - Unity.

Samuel Longiaru (longiaru) wrote :

Same problem under Linux Mint 12 Lisa w/ 3.0.0-12-generic(x86_64) kernel, gnome classic, GeForce GT 220 using NVidia proprietary 280.13 driver.

cccccccc (cccccccc) wrote :

I use no unity, but have 11.10 and it's nasty!
Somebody has posted video:
http://www.youtube.com/watch?v=vKWLavhaOuw
I also have problem, that hotkey "move window to right" (or left) moves window right, but after "flicker" it is "sent" back where it was before...

achess (achess) wrote :

Come on guys. Assign this bug. It's incredibly annoying!

Sam_ (and-sam) on 2012-02-05
tags: added: amd64 precise
33 comments hidden view all 113 comments
Maximinus (max-thrax) wrote :

It seems that the developer I was communicating with was mistaken as to the cause of this issue - and he's "not really supposed to use work time to support things like the cube."

The root of the problem here seems to be that Canonical/Ubuntu developers have decided that, even though their new pet project Unit depends on Compiz, they don't actually support Compiz; as seen in the mailing list discussion mentioned here several comments back, some of them are even pushing to remove the CompizConfig Settings Manager from official Ubuntu repos completely, because people use it to break things and then file bugs. The actual problem here is surely that they've broken Compiz (or "upgraded" to a broken version because they haven't tested properly before upgrading - I'm not sure which, but I'm also not sure which is worse) and are ignoring that fact because it's part of Compiz that the all-holy Unity doesn't use by default.

Ubuntu seems to be moving rapidly away from a good base that anybody can easily tweak to suit them, and towards a pre-packaged box that breaks if you so much as think about tweaking it to suit you. I've been using Ubuntu since the relatively early days, but it seems to be becoming exactly that which I sought to avoid by moving to Ubuntu as my primary OS - a precarious arrangement which is liable to topple if looked at the wrong way. (Yes, it's always been possible to break Ubuntu - but you used to have to actively try doing something out of the ordinary to do so!)

If anybody can suggest an alternative distro that includes kernel >= 3.0, Gnome (preferably 2, but I'll take 3 if it's a stable build which plays nice with Compiz) and Compiz (a working version - not this unsupported, broken mess), I might just have to switch. I can't downgrade to an earlier Ubuntu, as the main reason for moving to 11.10 was to get kernel 3.0; 2.6 doesn't support half the hardware in this laptop.

>
> If anybody can suggest an alternative distro that includes kernel >=
> 3.0, Gnome (preferably 2, but I'll take 3 if it's a stable build which
> plays nice with Compiz) and Compiz (a working version - not this
> unsupported, broken mess), I might just have to switch. I can't
> downgrade to an earlier Ubuntu, as the main reason for moving to 11.10
> was to get kernel 3.0; 2.6 doesn't support half the hardware in this
> laptop.
>
>
You can always revert to Lucid and use oneiric Kernel. Works just fine!
 https://launchpad.net/~kernel-ppa/+archive/ppa?field.series_filter=lucid

This is going to cover your needs for an other year...

You can also follow mate development to see if they come up with a solution
in LMDE.

Gabriele (gabriele-puppis) wrote :

I could not agree more with Maximinus, especially on the fact that Ubuntu is becoming a pre-packaged distribution. Anyway, such is the life of any OS, apparently.

Markus Wells (mwells-a) wrote :

 Add me to Maximinus' camp too. I have turned a lot of people on to ubuntu for the very reason that it is inherently "tweekable." I have to say that it REALLY makes me mad that they would forget where their (almost) entire code base comes from and try to become the next Apple or Microsoft.

 Please consider this friendly warning Canonical management, brought to you by a loyal user whose loyaly is rapidly fraying: The world doesn't need another Microsoft or Apple, and if you try to become like them IN ANY WAY you risk legions of you followers jumping ship, forking the code, and thumbing their nose at you. I'm usually right about these things - you would do well to heed this friendly warning.

 All that said, count me among the numbers having the flashing windows with the rotating cube problem.

 What do you say guys - is it time to fork Ubuntu or what?

Sam_ (and-sam) wrote :

Well then, if someone here is able to fork Ubuntu why not fix compiz?
btw. it's easier to install any kernel on a given OS than to find one which runs compiz well.

Maximinus (max-thrax) wrote :

I don't have the time (nor the knowledge/skills, though if I had even more time, I could probably fix that...) to fork Ubuntu - or even to try to fix Compiz at this stage.

My laptop (my primary machine) has just broken again (due to flawed power socket design), so I may well end up doing a clean setup on a new machine soon. If I do, in lieu of a better option, I might have to try the above solution from sterios - Lucid with Oneiric's kernel (thanks for linking to that PPA - if it applies cleanly and doesn't break anything, that's about a million times better than the reports I'd seen of trying to use 3.x on earlier 'buntus).

Cybro Dejitaru (cybrodejitaru) wrote :

I added natty repos with this package http://ppa.launchpad.net/guido-iodice/compiz-0.8.6-natty/ubuntu on Xubuntu 11.10 . Downgrade compiz to 0.8.6 and it works fine .

GeForce 450 GTS with Nvidia Driver 290.10

Gabriele (gabriele-puppis) wrote :

@Cybro

Do you know where we can find analogous oneiric repos?

Cybro Dejitaru (cybrodejitaru) wrote :

@Gabriele

I just added this
deb http://gr.archive.ubuntu.com/ubuntu/ natty main restricted
deb-src http://gr.archive.ubuntu.com/ubuntu/ natty main restricted
to /etc/apt/sources.list to Xubuntu 11.10 ( oneiric)
then i added this package i write above and its works fine .
I don't believe this is gonna work in Unity because compiz 0.8.6 is old.

Gabriele (gabriele-puppis) wrote :

I tried, I added the following lines to /etc/apt/sources.list

deb http://gr.archive.ubuntu.com/ubuntu/ natty main restricted
deb-src http://gr.archive.ubuntu.com/ubuntu/ natty main restricted
deb http://ppa.launchpad.net/guido-iodice/compiz-0.8.6-natty/ubuntu/ natty main
deb-src http://ppa.launchpad.net/guido-iodice/compiz-0.8.6-natty/ubuntu/ natty main

but on checking updates I get a message that says that I can only do a "partial update"
(it then claims that ubuntu-desktop is missing).

Do you know how to solve this, or if I am doing something wrong?

BTW. thanks for the help!

Gabriele (gabriele-puppis) wrote :

Ok, I think I have solved it: just removed unity-lens-applications (apparently it was still there and asking for ubuntu-desktop even if I uninstalled unity!). Next step to reboot and check!

Gabriele (gabriele-puppis) wrote :

Well, now compiz works perfectly fine... the problem is that the usual close/maximize/minimize buttons for the various applications have disappeared! I am slowly getting there...!

amnesia (amnesia-y) wrote :

I switched to Arch and everything works great, but it's an older version of compiz (0.8.8-3). I'm not sure what features the newer version brings, but I'm not missing anything I care about.

quequotion (quequotion) wrote :

The main developer supposedly had a fix for this in November, but it has never surfaced in any public bzr repositories.

Where compiz once had a thriving community, there's now only a ghost-town of a forum, a painfully out of date website, and a dead git repository replaced by a mess of bzr branches with no apparent development strategy or focus.

Compiz has been declared dead in the blogosphere.

Support for it has been removed from other distros.

Cube is NOT a niche interest; it WAS the defining characteristic of the compiz desktop.

What is going on here?

Gabriele (gabriele-puppis) wrote :

Never mind, I just reinstalled Lucid from scratch, after the login in Oneiric had completely gone due to another bug in Unity!

I have to say that going back to the old robust Lucid is such a relief!

I think I will never upgrade again, at least for the time Lucid support is available.

Gabriele (gabriele-puppis) wrote :

BTW. a lot of bugs has gone by switching from Oneiric to Lucid, e.g.: window focus on change of desktop, keyboard search inside folders, rabbitvcs repositories, resolution on switching to secondary screen, ...

I have never noticed how many new bugs have been introduced, and never solved, with the last three distros!

amnesia (amnesia-y) wrote :

@quequotion, I agree it is sad and I'm a bit surprised at the lack of uptake tbh. Too many people mistakingly dismiss compiz as just eye candy, but for me that is just a bonus, it has an incredible array of useful desktop management/interface features that other window managers simply do not match. The amount of flexibility to me is unrivaled. It's disheartening that it is becoming extinct.

Sam_ (and-sam) wrote :

Unsolved with 0.9.7
compiz:
  Installed: 1:0.9.7.0~bzr2995-0ubuntu1
  Candidate: 1:0.9.7.0~bzr2995-0ubuntu1
  Version table:
 *** 1:0.9.7.0~bzr2995-0ubuntu1 0

A M R (antonio-mrdp) wrote :

I'v been upgrading ubuntu in the belief that newer is better. Now I've reached 12.04 precise and the cube flash remains.
IMHO users can not expect developers fighting with tons of codelines in order to fix compiz, bout I'd dare to ask ubuntu people to build a package containing an old compiz version and a couple of lines of instructions to downgrade it. No more than two hours of their time.

It's not difficult to install debian stable and kernel 3.2 using backports or so, but I feel bad leaving ubuntu.

Cybro Dejitaru (cybrodejitaru) wrote :

@A M R

I believe that older versions of compiz would not work with unity .

Lee (lee-sodnpoo) wrote :

I fixed it by downgrading to 0.9.4 from natty - instructions are available here: http://sodnpoo.com/posts.xml/oneiric_compiz_downgrade.xml

Lee, thank you for that!

How about to add a "sudo apt-get update" and a
"compiz-plugins-extra=0.9.4-0ubuntu3" ?

On Sat, Feb 18, 2012 at 11:33 AM, Lee <email address hidden> wrote:

> I fixed it by downgrading to 0.9.4 from natty - instructions are
> available here:
> http://sodnpoo.com/posts.xml/oneiric_compiz_downgrade.xml

Lee (lee-sodnpoo) wrote :

Glad I could help :) I've updated my post to include the update and extras.

> Lee, thank you for that!
>
> How about to add a "sudo apt-get update" and a
> "compiz-plugins-extra=0.9.4-0ubuntu3" ?
>
> On Sat, Feb 18, 2012 at 11:33 AM, Lee <email address hidden> wrote:
>
> > I fixed it by downgrading to 0.9.4 from natty - instructions are
> > available here:
> > http://sodnpoo.com/posts.xml/oneiric_compiz_downgrade.xml

quequotion (quequotion) wrote :

Be careful!

Unless you intend to usea lot of Natty packages or downgrade to Natty, I wouldn't recommend adding the entire Natty repos to your sources and updating.

A much more safe workaround would be to download the packages individually and install them with dpkg.

We have to push for or contribute to a fix in Oneiric/Precise.

I have an idea, but not a very good one.

If we know 0.9.4-0ubuntu3 did not have this bug, but 0.9.6+bzr20110929-0ubuntu5 does not,
Then we simply have to compile and run each version of compiz between them to find the exact lines of code that cause this problem.

Anybody have a week of free time coming up?

quequotion (quequotion) wrote :

* If we know 0.9.4-0ubuntu3 did not have this bug, but 0.9.6+bzr20110929-0ubuntu5 does,

type-o

quequotion (quequotion) wrote :

one more thing,

If you're going to use the older version and wait it out, you need to learn about apt-pinning.
Unless those packages are pinned, the next upgrade will overwrite them with the latest version.
You'll be right back where you started.

Here are some guides:
Best I can find (incomplete, rambling): http://wiki.debian.org/AptPreferences#Pinning
Official doc (incomplete, outdated and inaccurate): http://www.debian.org/doc/manuals/apt-howto/ch-apt-get.en.html (section 3.10)

It's not the only way, but to make it simple, in "/etc/apt/preferences", for each downgraded package, add:

Package: package-name
Pin: version 0.0-0ubuntu0.0
Pin-Priority: 1001

niksam (ainka420) wrote :

Please fix it... so annoying...

MojoRisin (mojorisin) wrote :

Is there anything new?

Doug McMahon (mc3man) wrote :

It's been said elsewhere this is/will be worked on, if true then at best for 12.04, as far as 11.10 well, too bad, ect.

If it's not forth coming in 12.04 there is a source edit hack that works very well, after several days of testing on 12.04 I've only seen flashing maybe 3 times total. (this edit was written for 12.04 & the current compiz-core

So here am happy with the hack, would be better if Ubuntu fixed, though one way or the other will have rotate/cube back in business here

Attached screen shows using 'scroll on desktop'

Ben Spiers (unpairedbracket) wrote :

Does it also fix switching workspaces with a window?

gunwald (gunwald) wrote :

Doug McMahon, please tell us where to get that hack, and if possible, how we can use it! Please!

Piotr (piotrtokaj) wrote :

Doug McMahon - I would also like to know how to get that hack working. So far in the beta version of Precise the bug still occurs

Doug McMahon (mc3man) wrote :

If on 12.04 & wanting to gain some relief then come over to Ubuntu Forums & we'll get you hooked up & working to the extent it can. There are a couple of things possibly broken in rotate not related to these patches, one thing it doesn't fix (rotate with window

This is a hack, hopefully it will be truly fixed at some point, YMMV, ect.

The patch is here in post 77, you'll need to be a member to download

Any questions, help, ect. should be posted in Ubuntu Forums, not here. Either in that thread or start a new one in the same subforum - Ubuntu+1

I strongly suggest if trying just to do a mv & cp as noted, don't do a make install

http://ubuntuforums.org/showthread.php?t=1923363&page=4

Doug McMahon (mc3man) wrote :

Was hesitant to post link, but what's done is done -
we were testing/using this a couple of weeks ago, in that case the bzr source could be used.
Atm it can't, so until compiz upgrades you'll need to use the current 12.04 compiz source to rebuild the plugin
Posted a new thread giving basic instruction there, if help is needed ask there but note there is no great intention to support

http://ubuntuforums.org/showthread.php?t=1938942

Daniel van Vugt (vanvugt) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 862430, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Feel free to continue to report any other bugs you may find.

mnrl (zxcq14) wrote :

same problem!!!

William Meng (wlmeng11) wrote :

Same problem.
Happens on with both Desktop Wall and Cube.
Using Gnome Classic.
Nvidia GTX 560 with proprietary drivers installed.

Moving the window, then letting go of shift and then moving back to another workspace without the window works for me.

This problem is not present when using a "no effects" session.

sprop (fpoblete-kamanga) wrote :

The "Lee (lee-sodnpoo) wrote on 2012-02-18" solution works for me. However I will add a couple advices.

First deinstall compiz "sudo apt-get remove compiz*" and "sudo apt-get autoremove" all without cuotes.

Proceed like Lee says and after that, declick the Natty repositories from the Update Manager.

Besides, add the following packages to the "ignored packages" (I'm translating form spanish so not sure this is the righ tab name) in the Update Manager to be sure compiz will not update:

compizconfig-backend-gconf, compizconfig-settings-manager, compiz-core, compiz-gnome, compiz-plugins, compiz-plugins-extra, compiz-plugins-main, libcompizconfig0, libdecoration0, python-compizconfig.

gidantribal (aedo999) wrote :

Maximinus (max-thrax) wrote on 2012-02-07:
I can't agree more with you.

same problem here. ubuntu shall abandon compiz at his point

hate_bugs_89 (oyv-soppelpost) wrote :

I have this issue. Linux Mint 13, Nvidia Geforce GTX 560 M.
Also, to drag a window with your mouse across the workspaces on the cube is borked. The window goes mental. It flickers, flies around and ends up on the previous screen again, even if you try to drag it across.

Displaying first 40 and last 40 comments. View all 113 comments or add a comment.