Compiz will not redraw anything, anywhere with nvidia-current

Bug #875564 reported by quequotion on 2011-10-16
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

In Oneiric, while in the Compiz+Unity desktop using nvida-curent, no windows, menus, panels, or notifications will redraw.

Unless they are dragged or the cube rotated; they display only their initial state (often invisible).

This seems to be a compounding of problems I had in Natty, where redraw would lag after inital login.
The workaround then was to restart the xserver, which no longer works.

Please tell me what details are necessary to identify the problem.

quequotion (quequotion) wrote :

The nvidia drivers I've tried so far are 280 and 285.

Both worked fairly well in Natty, though never perfectly.

jayprakash (jay-jay-cz) wrote :

I don't think it's a problem with compiz nor nvidia-comon.

The same happened to me this morning with upgrade.
In the morning I was still on 10.10.

from apt/history.log (I removed some packages like thunderbird from the list) :
Upgrade:
linux-image-2.6.35-30-generic:amd64 (2.6.35-30.60, 2.6.35-30.61),
linux-generic:amd64 (2.6.35.30.38, 2.6.35.30.39),
linux-headers-2.6.35-30-generic:amd64 (2.6.35-30.60, 2.6.35-30.61),
tzdata-java:amd64 (2011j-0ubuntu0.10.10, 2011k-0ubuntu0.10.10),
linux-headers-generic:amd64 (2.6.35.30.38, 2.6.35.30.39),
linux-image-generic:amd64 (2.6.35.30.38, 2.6.35.30.39),
linux-headers-2.6.35-30:amd64 (2.6.35-30.60, 2.6.35-30.61),
ibpq-dev:amd64 (8.4.8-0ubuntu0.10.10, 8.4.9-0ubuntu0.10.10),
tzdata:amd64 (2011j-0ubuntu0.10.10, 2011k-0ubuntu0.10.10),
libpq5:amd64 (8.4.8-0ubuntu0.10.10, 8.4.9-0ubuntu0.10.10),
linux-libc-dev:amd64 (2.6.35-1030.60, 2.6.35-1030.61),

After that I tried nouveau, starting with older kernel, upgrade to natty, xorg-edgers ...
Now i'm running on Safe mode desktop.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
quequotion (quequotion) wrote :

>>jayprakash

Are you sure you are experiencing the same bug?

How did your desktop's behavior change with each attempt?

For me, only the Unity/Compiz desktop with nvidia is broken.

Nouveau was "working" as well as it ever does, before I removed it and reinstalled nvidia (after a severely botched upgrade to Oneiric and several hours of hacking). Unity 2D is also working for me (it's better than safe mode... a little...)

In other news, on a hunch I enabled the "desktop gears" decoration in compiz. With the gears spinning inside the cube, compiz seems forced to constantly redraw the screen. Thus windows, menus, panels, and notifications are also redrawing.

Unfortunately, the gears are glitched in an Escher-esque way and the cube still flickers the previous side over the current one on rotate (looks like the cube and window rotate, then the window follows you for a moment, then goes back to it's appropriate side) as it was doing before.

quequotion (quequotion) wrote :

I know developers are busy people, but I could really use some feedback on this issue.

For the moment I've purged all unity3d and compiz related packages and files from my system.

I am using unity2d for a desktop, but it has a few issues that really make using my computer unberable. (waiting forever to populate the applications lens in unity, no possiblity of vsync in metacity, etc etc).

Just a few weeks ago, I really impressed some friends with with compiz on Natty and now I don't know how I could explain all that awesomeness they saw is broken.

quequotion (quequotion) wrote :

Update

It seems this is an upgrade issue.

Finally impatience got the better of me and I wiped the system clean and started over, just like I used to do it in Winblow$ 95.

Compiz more or less works now with settings equivalent to what I had in Natty.

Giacomo Mirabassi (giacmir) wrote :

I had this behaviour after the end-upgrade reboot. At the next system restart the problem disappeared. I still have a strange window redraw problem:

if I open a window in front of another one and then click on the one below the window come to the front and then rapidly disappears and reappears. Can't say if this is related to this bug or is a completely new one.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers