screen flashes on rotate cube

Bug #874862 reported by Redmar on 2011-10-15
604
This bug affects 122 people
Affects Status Importance Assigned to Milestone
Compiz
Undecided
Unassigned
Compiz Core
Undecided
Unassigned
compiz (Ubuntu)
Low
Unassigned

Bug Description

Running ubuntu oneiric, fully up to date.
When triggering rotate cube the screen very briefly flashes at the end of the rotation animation. The flashes appear to be the windows on the workspace you are leaving. The flash only occurs when you are moving away from a workspace that contains windows.

To reproduce you simply have to enable rotate cube and trigger rotate using ctrl + alt + arrow key.
I will attach my compiz profile for your convenience, enabling rotate with unity always gives a load of conflicts to resolve otherwise.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: compiz 1:0.9.6+bzr20110929-0ubuntu3
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
NonfreeKernelModules: fglrx
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu3
Architecture: i386
CheckboxSubmission: 045aa0966acaa96c74f09312b4b4de72
CheckboxSystem: b5acb6c9ca4017b1d44043910f45329d
CompizPlugins: [core,composite,opengl,compiztoolbox,decor,resize,move,place,cube,grid,rotate,scale,scaleaddon,unityshell]
CompositorRunning: compiz
Date: Sat Oct 15 09:28:46 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus: fglrx, 8.881, 3.0.0-12-generic, i686: installed
EcryptfsInUse: Yes
GraphicsCard:
 ATI Technologies Inc RV730XT [Radeon HD 4670] [1002:9490] (prog-if 00 [VGA controller])
   Subsystem: XFX Pine Group Inc. Device [1682:2931]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110901)
JockeyStatus:
 xorg:fglrx_updates - ATI/AMD proprietary FGLRX graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
 xorg:fglrx - ATI/AMD proprietary FGLRX graphics driver (Proprietary, Enabled, In use)
MachineType: Acer Aspire M5500
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, no user)
 LANG=nl_NL.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=c3966ea2-ff82-488b-9efc-091a02cf2492 ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 06/18/2007
dmi.bios.vendor: Phoenix Technologies, LTD
dmi.bios.version: R01-B0
dmi.board.name: FG965M
dmi.board.vendor: Acer
dmi.chassis.type: 3
dmi.chassis.vendor: Acer
dmi.modalias: dmi:bvnPhoenixTechnologies,LTD:bvrR01-B0:bd06/18/2007:svnAcer:pnAspireM5500:pvrR01-B0:rvnAcer:rnFG965M:rvr:cvnAcer:ct3:cvr:
dmi.product.name: Aspire M5500
dmi.product.version: R01-B0
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu3
version.fglrx-installer: fglrx-installer N/A
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Redmar (redmar) wrote :
Redmar (redmar) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
selectstar (martinsarsini) wrote :

ApportVersion: 1.23-0ubuntu3
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,grid,resize,place,compiztoolbox,vpswitch,move,imgpng,mousepoll,gnomecompat,regex,wobbly,session,animation,fade,cube,rotate,expo,ezoom,scale,unityshell]
DistroCodename: oneiric
DistroRelease: Ubuntu 11.10
DistroVariant: ubuntu
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
NonfreeKernelModules: fglrx
Package: unity 4.22.0-0ubuntu3
PackageArchitecture: amd64
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Tags: oneiric running-unity oneiric running-unity oneiric running-unity oneiric running-unity ubuntu
Uname: Linux 3.0.0-12-generic x86_64
UnreportableReason: Please work this issue through technical support channels first.
UpgradeStatus: Upgraded to oneiric on 2011-10-15 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

tags: added: apport-collected

apport information

apport information

Andrey (waster2008) wrote :

Have the same bug with Nvidida 9500 card and proprietay drivers.

Tanker Bob (tankerbob) wrote :

Have the same symptoms with NVidia 8800GTS card and "current" proprietary drivers.

Peter Gaultney (petergaultney) wrote :

Same bug with NVIDIA GeForce GTX 260 and current proprietary drivers.

Matias Barletta (mrb-lionix) wrote :

+1 Gforce 8600 GT - Kubuntu 11.10 - nvidia-current drivers. Can't even move windows to next desktop, it goes back to previous one after the flash!

+1 here, Sony Vaio VPCSB series - ATI Radeon 6470M - Ubuntu 11.10 - open source drivers. Same problem, screen flickering after rotation and can't move windows to next desktop with keyboard shortcuts (ctrl + alt+ shift + left or right).

I wonder if Canonical test these things before realease a new version, this bug isn't hard to reproduce at all...

I noticed another bug: when rotating the cube with mouse (normaly, ctrl + alt + button 1) it kinda goes crazy after getting into next cube face and ends up showing upper or bottom caps...

On Wed, Oct 19, 2011 at 11:15 PM, Rafael Brandão
<email address hidden> wrote:
> +1 here, Sony Vaio VPCSB series - ATI Radeon 6470M - Ubuntu 11.10 - open
> source drivers. Same problem, screen flickering after rotation and can't
> move windows to next desktop with keyboard shortcuts (ctrl + alt+ shift
> + left or right).
>
> I wonder if Canonical test these things before realease a new version,
> this bug isn't hard to reproduce at all...

Actually, the fix for this was insanely complicated.

I've done it but it requires a bit more testing because its a big
change to the way we do rendering.

>
> --
> You received this bug notification because you are a member of compiz
> packagers, which is subscribed to compiz in Ubuntu.
> https://bugs.launchpad.net/bugs/874862
>
> Title:
>  screen flashes on rotate cube
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/874862/+subscriptions
>
> _______________________________________________
> Mailing list: https://launchpad.net/~compiz
> Post to     : <email address hidden>
> Unsubscribe : https://launchpad.net/~compiz
> More help   : https://help.launchpad.net/ListHelp
>

--
Sam Spilsbury

quequotion (quequotion) wrote :

>>smspillaz

Is your fix in the git-hub?

Change is good!

Miguel A. Roman (elitelune) wrote :

Had the bug on all the Nvidia drivers I tried, even Nouveau.

To be sure, I put the thing on a bootable usb, started it up, downloaded ccsm, switched it to desktop cube, rotated it around with ccsm still open, and I got a flash of ccsm after rotating. When rotating back, I got a flash of the previous screen.

Changed in compiz (Ubuntu):
importance: Undecided → Low
Sam_ (and-sam) wrote :

Since there is a similar Bug #876198 and unsure which one is the culprit attached videos. The issue occurs on rotate either via mouse wheel or shortcut.
unity:
  Installed: 4.24.0-0ubuntu2b1
  Candidate: 4.24.0-0ubuntu2b1
  Version table:
 *** 4.24.0-0ubuntu2b1 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     4.22.0-0ubuntu3 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages

compiz:
  Installed: 1:0.9.6+bzr20110929-0ubuntu5
  Candidate: 1:0.9.6+bzr20110929-0ubuntu5
  Version table:
 *** 1:0.9.6+bzr20110929-0ubuntu5 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1:0.9.6+bzr20110929-0ubuntu3 0

Sam_ (and-sam) wrote :

*-display
       description: VGA compatible controller
       product: RV710 [Radeon HD 4350]
       vendor: ATI Technologies Inc
       physical id: 0
       bus info: pci@0000:01:00.0
       version: 00
       width: 64 bits
       clock: 33MHz
       capabilities: vga_controller bus_master cap_list rom
       configuration: driver=radeon latency=0

Two weeks and this bug isn't even assigned to someone... :(

David Rando (david-rando) wrote :

smspillaz is working on this, as i can read above

fz (fz0002) wrote :

This happens on my Thinkpad T420 with Sandy Bridge. I am using Xubuntu with Compiz.

Realramnit (realramnit) wrote :

This happens also on Thinkpad X220i, Oneiric, 64bit. And it affects also the AWN Applet Shiny Switcher.

I'm running a HP z800 with a NVIDIA Quadro 4000 card - I'm running Ubuntu 11.10 with Unity enabled.

Same problem. VAIO VGN-FZ11S. NVIDIA GeFORCE 8400M GT GPU. Ubuntu 11.10 - Unity.

Smeagol (gollum12345678) wrote :

Is anyone really working on this bug? I had experience the same problem since the installation of Oneric...

LATITUDE E6500. NVIDIA GPU QUADRO NVS 160M. Ubuntu 11.10 - Unity with Compiz using nvidia-current drivers

roemer2201 (roemer2201) wrote :

@Sam_ (and-sam)

Try this:

Check Compiz Settings Manager:
Go to Animations -> Focus Animations -> Select the one Animation -> click "edit" -> Set "Focus Effect" to "None"

Does this solve your problem?

Redmar (redmar) wrote :

@roemer2201

That does not work for me. This also is a duplicate of bug https://bugs.launchpad.net/bugs/876198, so if you have more info on this please add it there. Thanks!

chargersfan (chargersfan) wrote :

I'd like to add that I also tried to disable the Animations plugin completely, and it causes the ccsm to crash. Output in the terminal simply says "Segmentation fault". Compiz, with animations is unaffected by the crash. Hope this helps.

streetdaddy (streetdaddy) wrote :

Same issue with:

Macbook Pro 5,4
Ubuntu 11.10 w/ Unity

MoGa (mr-3sool) wrote :

Same problem, Vaio netbook VPCYB13KX

rcspam (rcspam) wrote :

Same bug GeForce 9800gt

Jason Eisner (jason-cs) wrote :

These problems also happen on my Thinkpad T61 with a fresh install of Linux Mint 13 (a derivative of Ubuntu 12.04 Precise).
Right now I have to use Expo in order to move windows among faces of the cube.

Same exact issue on Mint 13 running MATE on a 13" MacBook Pro.

mehmet.nural (zxcq14) wrote :

same problem with nvidia gt520m

same bug:

lenovo W510
NVidia Quadro 880M

FatTony (fattony4) wrote :

i just updated compiz to 1:0.9.7.8-0ubuntu1.4...
it's so annoying - still no fix! i'm, btw, running ubuntu without graphics chip (gpu's on my sandy bridge processor). it most likely has nothing at all to do with drivers but with compiz itself.
i installed compiz 0.8.x once and screen rotation worked nicely.
somebody PLEASE find a solution!

To post a comment you must log in.