The larger windows, moving towed.

Bug #864330 reported by Adrián
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Compiz Core
Fix Committed
High
Sam Spilsbury
Unity
Fix Committed
High
Sam Spilsbury
compiz (Ubuntu)
Fix Released
High
Sam Spilsbury
Oneiric
Fix Released
High
Sam Spilsbury

Bug Description

steps:
1. Open nautilus.
2. Maximize.
3. Move the window.
You will see a slowdown.

EDIT: Also happens when switching between applications with multiple windows on the unity alt-tab

Testcase:

1. Maximize a window, pull it down, you shouldn't see windows jump around
2. Open two of the same application, open another application in the alt-tab, switch from the application with one window to the application with two, you shouldn't see jumping windows

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.20.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu2
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,resize,place,imgpng,move,session,gnomecompat,compiztoolbox,mousepoll,vpswitch,wall,grid,wobbly,screenshot,regex,thumbnail,animation,workarounds,expo,ezoom,staticswitcher,fade,scale,unityshell]
CompositorRunning: compiz
Date: Sat Oct 1 23:17:36 2011
DistUpgraded: Log time: 2011-08-12 20:00:23.116487
DistroCodename: oneiric
DistroVariant: ubuntu
GraphicsCard:
 ATI Technologies Inc RV350 AS [Radeon 9550] [1002:4153] (prog-if 00 [VGA controller])
   Subsystem: PC Partner Limited Device [174b:0200]
   Subsystem: PC Partner Limited Device [174b:0201]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110803.1)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: ASUSTek Computer Inc. K8N
ProcEnviron:
 LANG=hu_HU.utf8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=4d145e22-358d-424c-af08-7fee97796b8e ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-09-26 (5 days ago)
dmi.bios.date: 02/16/2006
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1011.005
dmi.board.name: 'K8N'
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1011.005:bd02/16/2006:svnASUSTekComputerInc.:pnK8N:pvrSystemVersion:rvnASUSTeKComputerINC.:rn'K8N':rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: K8N
dmi.product.version: System Version
dmi.sys.vendor: ASUSTek Computer Inc.
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu1
version.ia32-libs: ia32-libs 20090808ubuntu25
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Related branches

Revision history for this message
Adrián (jaksi) wrote :
Changed in unity:
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Changed in unity:
importance: Undecided → Low
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity:
milestone: none → 4.24.0
Revision history for this message
Omer Akram (om26er) wrote :

Whats the issue exactly? I dont seem to understand :p

Changed in unity (Ubuntu):
importance: Undecided → Low
Revision history for this message
Adrián (jaksi) wrote :
Changed in unity:
milestone: 4.24.0 → 4.26.0
Revision history for this message
Sam Spilsbury (smspillaz) wrote :

The issue is that you see jumping around windows because synchronous movement is forced sometimes

Changed in unity:
importance: Low → High
Revision history for this message
Adrián (jaksi) wrote :

I do not understand the question! Google translate does not translate clearly.

Changed in compiz-core:
importance: Undecided → High
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 0.9.6
status: New → Confirmed
description: updated
Changed in compiz-core:
status: Confirmed → Fix Committed
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
affects: unity (Ubuntu) → compiz (Ubuntu)
Changed in compiz (Ubuntu):
importance: Low → High
description: updated
Revision history for this message
Sam Spilsbury (smspillaz) wrote :
Download full text (8.1 KiB)

Proposed follow up fix pending verification:

=== modified file 'debian/patches/fix-864330.patch'
--- debian/patches/fix-864330.patch 2011-10-12 10:06:03 +0000
+++ debian/patches/fix-864330.patch 2011-10-17 07:10:33 +0000
@@ -1,8 +1,8 @@
 === modified file 'plugins/move/src/move.cpp'
 Index: compiz-0.9.6+bzr20110929/plugins/move/src/move.cpp
 ===================================================================
---- compiz-0.9.6+bzr20110929.orig/plugins/move/src/move.cpp 2011-10-12 17:00:11.359395413 +0800
-+++ compiz-0.9.6+bzr20110929/plugins/move/src/move.cpp 2011-10-12 17:00:22.599451570 +0800
+--- compiz-0.9.6+bzr20110929.orig/plugins/move/src/move.cpp 2011-10-17 15:09:58.353653059 +0800
++++ compiz-0.9.6+bzr20110929/plugins/move/src/move.cpp 2011-10-17 15:10:07.081696339 +0800
 @@ -525,7 +525,7 @@
    Window xid = CompOption::getIntOptionNamed (options, "window", 0);
    int lock = CompOption::getIntOptionNamed (options, "active", 0);
@@ -14,8 +14,8 @@
   }
 Index: compiz-0.9.6+bzr20110929/src/privatescreen.h
 ===================================================================
---- compiz-0.9.6+bzr20110929.orig/src/privatescreen.h 2011-10-12 17:00:11.319395193 +0800
-+++ compiz-0.9.6+bzr20110929/src/privatescreen.h 2011-10-12 17:00:22.599451570 +0800
+--- compiz-0.9.6+bzr20110929.orig/src/privatescreen.h 2011-10-17 15:09:58.369653137 +0800
++++ compiz-0.9.6+bzr20110929/src/privatescreen.h 2011-10-17 15:10:07.081696339 +0800
 @@ -111,6 +111,8 @@
      virtual ~PendingEvent ();

@@ -45,8 +45,8 @@
      bool removeIfMatching (const PendingEvent::Ptr &p, XEvent *);
 Index: compiz-0.9.6+bzr20110929/src/privatewindow.h
 ===================================================================
---- compiz-0.9.6+bzr20110929.orig/src/privatewindow.h 2011-10-12 17:00:11.243394758 +0800
-+++ compiz-0.9.6+bzr20110929/src/privatewindow.h 2011-10-12 17:00:22.599451570 +0800
+--- compiz-0.9.6+bzr20110929.orig/src/privatewindow.h 2011-10-17 15:09:58.385653215 +0800
++++ compiz-0.9.6+bzr20110929/src/privatewindow.h 2011-10-17 15:10:07.125696557 +0800
 @@ -211,7 +211,7 @@

   void readIconHint ();
@@ -66,8 +66,8 @@
   struct timeval lastConfigureRequest;

Index: compiz-0.9.6+bzr20110929/src/window.cpp
 ===================================================================
---- compiz-0.9.6+bzr20110929.orig/src/window.cpp 2011-10-12 17:00:11.283395067 +0800
-+++ compiz-0.9.6+bzr20110929/src/window.cpp 2011-10-12 17:02:55.120207454 +0800
+--- compiz-0.9.6+bzr20110929.orig/src/window.cpp 2011-10-17 15:09:58.357653075 +0800
++++ compiz-0.9.6+bzr20110929/src/window.cpp 2011-10-17 15:10:29.229806152 +0800
 @@ -868,13 +868,16 @@

       }
@@ -116,7 +116,25 @@

   if (serverFrameGeometry.x () == xwc.x)
       valueMask &= ~(CWX);
-@@ -1012,7 +1015,6 @@
+@@ -1004,6 +1007,17 @@
+
+ }
+
++ compiz::X11::PendingEvent::Ptr pc =
++ boost::shared_static_cast<compiz::X11::PendingEvent> (compiz::X11::PendingConfigureEvent::Ptr (
++ new compiz::X11::PendingConfigureEvent (
++ screen->dpy (), serverFrame, valueMask, &xwc)));
++
++ pendingConfigures.add (pc);
++ if (priv->mClearCheckTimeout.active ())
++ priv->mClearCheckT...

Read more...

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.6+bzr20110929-0ubuntu5

---------------
compiz (1:0.9.6+bzr20110929-0ubuntu5) oneiric-proposed; urgency=low

  * debian/patches/fix-864330.patch:
    - fix windows which can have towed moving (LP: #864330)
  * debian/patches/fix-864478.patch:
    - Window shading is broken (LP: #864478)

compiz (1:0.9.6+bzr20110929-0ubuntu4) oneiric-proposed; urgency=low

  * debian/control:
    - don't suggest nvidia-glx, it's part of the old initial packaging
      and probably a bad hint on non nvidia system (LP: #844218)
  * Cherry-pick upstream patches:
    - Windows should not automatically be focused when opened if the focus
      is on another application (LP: #748840)
    - Launcher - If a spread contains minimised windows, when the spread
      exits, the minimised windows momentarily appear on the desktop
      before disappearing (LP: #863328)
    - reproducible stacking bug in compiz (LP: #869316)
    - Click-dragging a window that's stacked above a fullscreen window will
      cause it to go underneath the fullscreen window (LP: #869919)
    - sometimes the keyboard input doesn't go to the apparently focussed
      dialog (LP: #869967)
    - Opening mumble can cause it to be stacked above the dash if you
      open the dash at the same time (LP: #865863)
    - Sometimes configure events are missed and windows move slow as a result
      (LP: #866752)
    - Workaround ubuntu desktop unity. Mouse at the left side doesn't reveal
      launcher (LP: #832150)
 -- Didier Roche <email address hidden> Wed, 12 Oct 2011 10:44:49 +0200

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
Changed in compiz (Ubuntu Oneiric):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers