compiz crashed with SIGSEGV in PrivateWindow::configureFrame()

Bug #861909 reported by Taufik on 2011-09-28
482
This bug affects 100 people
Affects Status Importance Assigned to Milestone
Compiz Core
High
Sam Spilsbury
Unity
Fix Released
High
Sam Spilsbury
compiz (Ubuntu)
Critical
Sam Spilsbury
Oneiric
Critical
Sam Spilsbury
unity (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

compiz crashed with SIGSEGV in PrivateWindow::configureFrame()

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity 4.18.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu2
Architecture: i386
CrashCounter: 1
Date: Thu Sep 29 06:47:00 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110921.2)
ProcCmdline: compiz
SegvAnalysis:
 Segfault happened at: 0x8088bd0 <_ZN13PrivateWindow14configureFrameEP15XConfigureEvent+144>: mov 0x34(%eax),%edx
 PC (0x08088bd0) ok
 source "0x34(%eax)" (0x00000034) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 PrivateWindow::configureFrame(XConfigureEvent*) ()
 CompScreen::handleEvent(_XEvent*) ()
 PrivateCompositeScreen::handleEvent(_XEvent*) () from /usr/lib/compiz/libcomposite.so
 CompScreen::handleEvent(_XEvent*) ()
 PrivateGLScreen::handleEvent(_XEvent*) () from /usr/lib/compiz/libopengl.so
Title: compiz crashed with SIGSEGV in PrivateWindow::configureFrame()
UpgradeStatus: Upgraded to oneiric on 2011-09-28 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors: (gwibber-service:1823): libindicate-WARNING **: Menu being changed when the indicator is visible. Listeners will NOT be notified of this change.

Taufik (ambless) wrote :

StacktraceTop:
 frame (this=0x0) at /build/buildd/compiz-0.9.6/src/window.cpp:5641
 PrivateWindow::configureFrame (this=0x8d8b6d8, ce=0x92c5578) at /build/buildd/compiz-0.9.6/src/window.cpp:2007
 CompScreen::handleEvent (this=0x8b79b98, event=0x92c5578) at /build/buildd/compiz-0.9.6/src/event.cpp:1057
 PrivateCompositeScreen::handleEvent (this=0x8c0fcd0, event=0x92c5578) at /build/buildd/compiz-0.9.6/plugins/composite/src/screen.cpp:102
 CompScreen::handleEvent (this=0x8b79b98, event=0x92c5578) at /build/buildd/compiz-0.9.6/src/event.cpp:987

Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Neil J. Patel (njpatel) on 2011-09-29
visibility: private → public
Changed in unity:
importance: Undecided → High
milestone: none → 4.20.0
status: New → Triaged
Didier Roche (didrocks) on 2011-09-29
Changed in unity:
milestone: 4.20.0 → 4.22.0
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Bilal Shahid (s9iper1) wrote :

i confirm this too with latest updated oneiric and also file a duplicate bug
 bug/863313

Didier Roche (didrocks) on 2011-09-30
Changed in unity (Ubuntu):
status: Confirmed → Triaged
Didier Roche (didrocks) on 2011-09-30
Changed in unity (Ubuntu):
importance: Medium → Critical
David Barth (dbarth) on 2011-09-30
Changed in unity:
status: Triaged → Fix Committed
Changed in unity (Ubuntu):
status: Triaged → Fix Committed
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
Glenn Chugg (glennlchugg) wrote :

I had this occur on me when my HDD's were asleep, while it was trying to open a Folder Selection window it caused the crash to occur, lets hope the committed fix addresses this situation too.

Rocko (rockorequin) wrote :

I experienced this just now after resuming the laptop and typing the password into the screensaver.

tags: added: rls-mgr-o-tracking
Changed in unity (Ubuntu Oneiric):
milestone: none → ubuntu-11.10
tags: added: bugpattern-needed
Didier Roche (didrocks) on 2011-10-03
affects: unity (Ubuntu Oneiric) → compiz (Ubuntu Oneiric)
Svivi (svivi) wrote :

It happened when I tried to switch between the Firefox and the Nautilus.
I had to restart the X.

Alan (alancarvalho) wrote :

Nautilus is closing alone. Just a click on any directory and it is closing.

I am facing the same problem as Alan. Although nautilus as root doesn't
crash.

On Tue, Oct 4, 2011 at 4:32 AM, Alan <email address hidden> wrote:

> Nautilus is closing alone. Just a click on any directory and it is
> closing.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (865561).
> https://bugs.launchpad.net/bugs/861909
>
> Title:
> compiz crashed with SIGSEGV in PrivateWindow::configureFrame()
>
> Status in Unity:
> Fix Committed
> Status in “compiz” package in Ubuntu:
> Fix Committed
> Status in “compiz” source package in Oneiric:
> Fix Committed
>
> Bug description:
> compiz crashed with SIGSEGV in PrivateWindow::configureFrame()
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.10
> Package: unity 4.18.0-0ubuntu1
> ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
> Uname: Linux 3.0.0-12-generic i686
> NonfreeKernelModules: nvidia
> ApportVersion: 1.23-0ubuntu2
> Architecture: i386
> CrashCounter: 1
> Date: Thu Sep 29 06:47:00 2011
> ExecutablePath: /usr/bin/compiz
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110921.2)
> ProcCmdline: compiz
> SegvAnalysis:
> Segfault happened at: 0x8088bd0
> <_ZN13PrivateWindow14configureFrameEP15XConfigureEvent+144>: mov
> 0x34(%eax),%edx
> PC (0x08088bd0) ok
> source "0x34(%eax)" (0x00000034) not located in a known VMA region
> (needed readable region)!
> destination "%edx" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: unity
> StacktraceTop:
> PrivateWindow::configureFrame(XConfigureEvent*) ()
> CompScreen::handleEvent(_XEvent*) ()
> PrivateCompositeScreen::handleEvent(_XEvent*) () from
> /usr/lib/compiz/libcomposite.so
> CompScreen::handleEvent(_XEvent*) ()
> PrivateGLScreen::handleEvent(_XEvent*) () from
> /usr/lib/compiz/libopengl.so
> Title: compiz crashed with SIGSEGV in PrivateWindow::configureFrame()
> UpgradeStatus: Upgraded to oneiric on 2011-09-28 (0 days ago)
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
> XsessionErrors: (gwibber-service:1823): libindicate-WARNING **: Menu being
> changed when the indicator is visible. Listeners will NOT be notified of
> this change.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/861909/+subscriptions
>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.6+bzr20110929-0ubuntu2

---------------
compiz (1:0.9.6+bzr20110929-0ubuntu2) oneiric; urgency=low

  * debian/patches/02_fix_autofocus_minimize_window.patch:
    - closing a window gives focus to last minimized window (LP: #862719)
  * debian/patches/03_fix_configureframe.patch:
    - compiz crashed with SIGSEGV in PrivateWindow::configureFrame()
      (LP: #861909)
 -- Didier Roche <email address hidden> Tue, 04 Oct 2011 08:29:38 +0200

Changed in compiz (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Changed in compiz-core:
status: New → Fix Committed
assignee: nobody → Sam Spilsbury (smspillaz)
importance: Undecided → High
Didier Roche (didrocks) on 2011-10-04
Changed in unity:
status: Fix Committed → Fix Released
David Gomes (davidgomes) wrote :

I just got this error in compiz 0.9.6.

Alan (alancarvalho) wrote :

That's exactaly the version of my compiz (0.9.6).

Changed in compiz-core:
milestone: none → 0.9.7
Changed in compiz-core:
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in unity (Ubuntu Oneiric):
status: New → Won't Fix
Will Cooke (willcooke) on 2015-09-16
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers