compiz crashed with SIGSEGV in PrivateWindow::addWindowStackChanges()

Bug #861793 reported by Pixel on 2011-09-28
492
This bug affects 90 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Sam Spilsbury
compiz (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

after nautilus crash screen freeze, i've changed to session tt1 (ctrl+alt+f1) and return to desktop (ctrl+alt+f7).
system responsive but crash occours.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity 4.18.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic i686
ApportVersion: 1.23-0ubuntu2
Architecture: i386
CrashCounter: 1
Date: Wed Sep 28 22:28:07 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110927)
ProcCmdline: compiz
SegvAnalysis:
 Segfault happened at: 0x808420a <_ZN13PrivateWindow21addWindowStackChangesEP14XWindowChangesP10CompWindow+42>: mov 0x34(%edx),%ebx
 PC (0x0808420a) ok
 source "0x34(%edx)" (0x00000034) not located in a known VMA region (needed readable region)!
 destination "%ebx" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 PrivateWindow::addWindowStackChanges(XWindowChanges*, CompWindow*) ()
 CompWindow::lower() ()
 CompScreen::handleEvent(_XEvent*) ()
 PrivateCompositeScreen::handleEvent(_XEvent*) () from /usr/lib/compiz/libcomposite.so
 CompScreen::handleEvent(_XEvent*) ()
Title: compiz crashed with SIGSEGV in PrivateWindow::addWindowStackChanges()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout disk lpadmin plugdev sambashare

Pixel (fabio-colinelli) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Neil J. Patel (njpatel) on 2011-09-28
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
importance: Undecided → Critical
milestone: none → 4.20.0
status: New → Confirmed
Jason Warner (jasoncwarner) wrote :

I just got this after a reboot. I didn't do anything special, though, to get the error.

Rainer Rohde (rainer-rohde) wrote :

Just happened to me right after logging in.

Jason Smith (jassmith) wrote :

Scope seems to be limited to starting compiz before any windows have been mapped. (Hence all the reboot comments)

There is a loop in there that is no protected with an if, should be a simple fix for sam :)

Jason Smith (jassmith) on 2011-09-29
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-09-29
Changed in unity:
status: Fix Committed → Fix Released
affects: unity (Ubuntu) → compiz (Ubuntu)
Ant Dickens (antonydickens) wrote :

Occurred after inserting a USB pendrive. System still seems functional.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.6+bzr20110929-0ubuntu1

---------------
compiz (1:0.9.6+bzr20110929-0ubuntu1) oneiric; urgency=low

  * New upstream snapshot:
    - Workspace switcher makes windows lose decorations (LP: #853951)
    - compiz crashed with SIGSEGV in PrivateWindow::addWindowStackChanges()
      (LP: #861793)
    - sometimes, restored window placed too high (LP: #716521)
    - can't maximize windows on second monitor and Qt windows displayed in
      wrong place (LP: #861341)
  * 091_no_use_gnome_but_desktop_file.patch:
    - partially committed upstream, no more needed
 -- Didier Roche <email address hidden> Thu, 29 Sep 2011 09:21:42 +0200

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
tags: added: rls-mgr-o-tracking
Petri Kutvonen (kutvonen) wrote :

I am still getting the same crash with 1:0.9.6+bzr20110929-0ubuntu1. This happened within 60 seconds after login on a newly booted machine (but *after* the one window - Terminal - had been opened).

Koen Verweij (kfverweij) wrote :

Also still getting this. Should I open a new bug report? It seems to be the same problem.

No I believe its the same also

On 30/09/11 19:31, Koen Verweij wrote:
> Also still getting this. Should I open a new bug report? It seems to be
> the same problem.
>

Omer Akram (om26er) wrote :

are there any steps to reproduce this bug? a test case would make it easier to fix.

Changed in unity:
status: Fix Released → Fix Committed
Tim Penhey (thumper) on 2011-10-25
Changed in unity:
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in unity (Ubuntu Oneiric):
status: New → Won't Fix
Will Cooke (willcooke) on 2015-09-16
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.