compiz crashed with SIGSEGV in CompScreen::insertServerWindow()

Bug #857487 reported by Igor Lemos
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Compiz
High
Sam Spilsbury
Compiz Core
High
Sam Spilsbury
compiz (Ubuntu)
Medium
Sam Spilsbury

Bug Description

sem detalhes

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: unity 4.16.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic i686
ApportVersion: 1.23-0ubuntu1
Architecture: i386
CrashCounter: 1
Date: Fri Sep 23 11:56:42 2011
ExecutablePath: /usr/bin/compiz
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110901)
ProcCmdline: compiz
SegvAnalysis:
 Segfault happened at: 0x806d081 <_ZN10CompScreen18insertServerWindowEP10CompWindowm+193>: mov 0xc(%eax),%eax
 PC (0x0806d081) ok
 source "0xc(%eax)" (0x00000025) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unity
StacktraceTop:
 CompScreen::insertServerWindow(CompWindow*, unsigned long) ()
 PrivateWindow::reconfigureXWindow(unsigned int, XWindowChanges*) ()
 CompWindow::configureXWindow(unsigned int, XWindowChanges*) ()
 CompWindow::updateAttributes(CompStackingUpdateMode) ()
 PrivateWindow::processMap() ()
Title: compiz crashed with SIGSEGV in CompScreen::insertServerWindow()
UpgradeStatus: Upgraded to oneiric on 2011-09-23 (0 days ago)
UserGroups: adm admin lpadmin nopasswdlogin sambashare

Revision history for this message
Igor Lemos (l88os) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 CompScreen::insertServerWindow (this=0x8cb8350, w=0x94df1a8, aboveId=16778542) at /build/buildd/compiz-0.9.5.94+bzr20110919/src/screen.cpp:2672
 PrivateWindow::reconfigureXWindow (this=0xa200b20, valueMask=96, xwc=0xbfb3e64c) at /build/buildd/compiz-0.9.5.94+bzr20110919/src/window.cpp:2740
 CompWindow::configureXWindow (this=0x99d7e68, valueMask=96, xwc=0xbfb3e64c) at /build/buildd/compiz-0.9.5.94+bzr20110919/src/window.cpp:2967
 updateAttributes (stackingMode=CompStackingUpdateModeInitialMap, this=0x99d7e68) at /build/buildd/compiz-0.9.5.94+bzr20110919/src/window.cpp:3708
 CompWindow::updateAttributes (this=0x99d7e68, stackingMode=CompStackingUpdateModeInitialMap) at /build/buildd/compiz-0.9.5.94+bzr20110919/src/window.cpp:3630

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in unity (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
visibility: private → public
Revision history for this message
Sam Spilsbury (smspillaz) wrote :

This case should never be hit. Nevertheless, I'll fix the crash, but if we're hitting this case something is going very wrong, and I'd like to find out more, so I'm going to make the error message public by default.

Changed in unity:
status: New → Confirmed
status: Confirmed → In Progress
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 4.22.0
importance: Undecided → High
Changed in unity (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz:
status: New → Fix Committed
Changed in compiz-core:
status: New → Fix Committed
Changed in compiz:
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz-core:
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 0.9.6
Changed in compiz:
importance: Undecided → High
Changed in compiz-core:
importance: Undecided → High
Didier Roche (didrocks)
Changed in unity (Ubuntu):
status: In Progress → Invalid
affects: unity (Ubuntu) → ubuntu
affects: ubuntu → compiz (Ubuntu)
Changed in compiz (Ubuntu):
status: Invalid → Fix Committed
Changed in unity:
status: In Progress → Fix Committed
Didier Roche (didrocks)
Changed in unity:
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.6+bzr20110929-0ubuntu3

---------------
compiz (1:0.9.6+bzr20110929-0ubuntu3) oneiric; urgency=low

  * debian/patches/04_fix_insertServerWindow_crash.patch:
    - compiz crashed with SIGSEGV in CompScreen::insertServerWindow()
      (LP: #857487)
  * debian/patches/05_fix_reconfigureXWindow_crash.patch:
    - compiz crashed with SIGABRT in raise() (LP: #857738)
 -- Didier Roche <email address hidden> Tue, 04 Oct 2011 13:49:01 +0200

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
Changed in compiz-core:
status: Fix Committed → Fix Released
Stephen M. Webb (bregma)
Changed in compiz:
status: Fix Committed → Fix Released
no longer affects: unity (Ubuntu)
no longer affects: unity
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers