compiz crashed with SIGSEGV in CompWindow::~CompWindow()

Bug #856921 reported by Moshe Krumbein on 2011-09-23
954
This bug affects 149 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Critical
Sam Spilsbury
compiz (Ubuntu)
High
Sam Spilsbury
Oneiric
High
Sam Spilsbury
unity (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

trying to print a test page to my newly connected wireless printer. test page failed too.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: compiz-core 1:0.9.5.94+bzr20110919-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,decor,regex,compiztoolbox,place,move,session,gnomecompat,snap,grid,vpswitch,mousepoll,animation,resize,imgpng,unitymtgrabhandles,expo,workarounds,wall,ezoom,fade,scale,unityshell]
CompositorRunning: compiz
Date: Thu Sep 22 20:23:37 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 02) (prog-if 00 [VGA controller])
   Subsystem: Hewlett-Packard Company Device [103c:3674]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110921.2)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
 Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
 Bus 001 Device 003: ID 04f2:b293 Chicony Electronics Co., Ltd
MachineType: Hewlett-Packard HP 630 Notebook PC
ProcCmdline: compiz
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=35266c3f-97df-40cc-aa1d-fc9db567bb9a ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x44403a <_ZN10CompWindowD2Ev+698>: mov 0x20(%rax),%r12
 PC (0x0044403a) ok
 source "0x20(%rax)" (0x00000060) not located in a known VMA region (needed readable region)!
 destination "%r12" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 CompWindow::~CompWindow() ()
 CompWindow::~CompWindow() ()
 PrivateScreen::removeDestroyed() ()
 PrivateScreen::processEvents() ()
 CompEventSource::callback() ()
Title: compiz crashed with SIGSEGV in CompWindow::~CompWindow()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 07/27/2011
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.22
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 3674
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 28.37
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.22:bd07/27/2011:svnHewlett-Packard:pnHP630NotebookPC:pvr058B100000204C10002020100:rvnHewlett-Packard:rn3674:rvr28.37:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.name: HP 630 Notebook PC
dmi.product.version: 058B100000204C10002020100
dmi.sys.vendor: Hewlett-Packard
version.compiz: compiz 1:0.9.5.94+bzr20110919-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

StacktraceTop:
 id (this=0x4c34420) at /build/buildd/compiz-0.9.5.94+bzr20110919/src/window.cpp:4825
 CompWindow::~CompWindow (this=0x3e6d320, __in_chrg=<optimized out>) at /build/buildd/compiz-0.9.5.94+bzr20110919/src/window.cpp:5736
 CompWindow::~CompWindow (this=0x3e6d320, __in_chrg=<optimized out>) at /build/buildd/compiz-0.9.5.94+bzr20110919/src/window.cpp:5791
 PrivateScreen::removeDestroyed (this=0x16ed570) at /build/buildd/compiz-0.9.5.94+bzr20110919/src/screen.cpp:4203
 PrivateScreen::processEvents (this=0x16ed570) at /build/buildd/compiz-0.9.5.94+bzr20110919/src/screen.cpp:757

Changed in compiz (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
visibility: private → public
Changed in compiz (Ubuntu Oneiric):
importance: Medium → High
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
milestone: none → ubuntu-11.10
tags: added: rls-mgr-o-tracking
David Barth (dbarth) wrote :

I've seen this one and Sam should have a fix released in the Tuesday upload

Changed in compiz (Ubuntu Oneiric):
status: Confirmed → In Progress
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Sam Spilsbury (smspillaz)
pablomme (pablomme) wrote :

Just in case this adds anything useful: I've seen this bug on both my desktop and laptop, both while about to launch a dist-upgrade from update-manager, exactly when the gksu prompt was supposed to display. In this incarnation, the bug makes compiz crash, attempting to restart it by switching to a VT and launching "DISPLAY=:0 unity --replace" briefly displays a full desktop which cannot be interacted with, and eventually crash again. The second time I got this, I went to a VT and did "killall gksu", and only then compiz was able to restart successfully.

So I guess this has to do with gksu's screen grab clashing with the recent stacking-order compiz fixes (never got this crash before Thursday). I should add that not every invocation of gksu causes this; a gksu dialogue correctly popped up while going through the apport bug reporting process.

Christopher (soft-kristal) wrote :

Same as #7. Doesn't seem to affect updating via Synaptic though.

Download full text (4.8 KiB)

Thx Christopher,
I enjoy trying the beta & submitting the stuff I find. I'm not much of a
linux guru, but learning fast. Just hope my stuff helps even a little bit.
Cheers
John

"The world ends when you're dead. Until then, you got more punishment in
store. Stand it like a man, and give some back."
....Al Swearengen - Deadwood

On Mon, Sep 26, 2011 at 13:07, Christopher <email address hidden>wrote:

> Same as #7. Doesn't seem to affect updating via Synaptic though.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (858513).
> https://bugs.launchpad.net/bugs/856921
>
> Title:
> compiz crashed with SIGSEGV in CompWindow::~CompWindow()
>
> Status in “compiz” package in Ubuntu:
> In Progress
> Status in “compiz” source package in Oneiric:
> In Progress
>
> Bug description:
> trying to print a test page to my newly connected wireless printer.
> test page failed too.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 11.10
> Package: compiz-core 1:0.9.5.94+bzr20110919-0ubuntu1
> ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
> Uname: Linux 3.0.0-11-generic x86_64
> .tmp.unity.support.test.0:
>
> ApportVersion: 1.23-0ubuntu1
> Architecture: amd64
> CompizPlugins:
> [core,bailer,detection,composite,opengl,decor,regex,compiztoolbox,place,move,session,gnomecompat,snap,grid,vpswitch,mousepoll,animation,resize,imgpng,unitymtgrabhandles,expo,workarounds,wall,ezoom,fade,scale,unityshell]
> CompositorRunning: compiz
> Date: Thu Sep 22 20:23:37 2011
> DistUpgraded: Fresh install
> DistroCodename: oneiric
> DistroVariant: ubuntu
> ExecutablePath: /usr/bin/compiz
> GraphicsCard:
> Intel Corporation Core Processor Integrated Graphics Controller
> [8086:0046] (rev 02) (prog-if 00 [VGA controller])
> Subsystem: Hewlett-Packard Company Device [103c:3674]
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110921.2
> )
> Lsusb:
> Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
> Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
> Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
> Bus 001 Device 003: ID 04f2:b293 Chicony Electronics Co., Ltd
> MachineType: Hewlett-Packard HP 630 Notebook PC
> ProcCmdline: compiz
> ProcEnviron:
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic
> root=UUID=35266c3f-97df-40cc-aa1d-fc9db567bb9a ro quiet splash vt.handoff=7
> SegvAnalysis:
> Segfault happened at: 0x44403a <_ZN10CompWindowD2Ev+698>: mov
> 0x20(%rax),%r12
> PC (0x0044403a) ok
> source "0x20(%rax)" (0x00000060) not located in a known VMA region
> (needed readable region)!
> destination "%r12" ok
> SegvReason: reading NULL VMA
> Signal: 11
> SourcePackage: compiz
> StacktraceTop:
> CompWindow::~CompWindow() ()
> CompWindow::~CompWindow() ()
> PrivateScreen::removeDestroyed() ()
> PrivateScreen::processEvents() ()
> CompEventSource::callback() ()
> Title: compiz crashed with SIGSEGV in CompWindow::~CompWindow()
> UpgradeSta...

Read more...

razor7 (ghiamar) wrote :

Hi, i don't know if this is the correct bug, but in my machine, most of the time, ubuntu 11.10 beta 2 freezes with no error or log message, just freezes all the screen, no mouse movement possible, not ctrl+alt+ (f1,f2,f3,f4) possible either, just reset button and try again.

My spects
Asus p5qc (Intel P45)
Intel Core2Quad (2666 MHz)
2GB ram (DDR1333)

I think that my mother is not quite compatible. But until Ubuntu 10.04 worked like a charm!

Fayer Michael (fayer012) wrote :

This error occurred when closing Empathy. My system: Ubuntu 11.10

Didier Roche (didrocks) on 2011-09-27
Changed in unity:
status: New → Triaged
importance: Undecided → High
milestone: none → 4.20.0
assignee: nobody → Sam Spilsbury (smspillaz)
tags: added: didrocks-oneiric-list

Happened for me when I was exporting drawing from LibreOffice Draw to *.gif format

tags: removed: bugpattern-needed
tags: added: bugpattern-written

multiple crashes after updating today, Pentium P6100 lenovo edge 15

dtx_2503@yahoo.com (dtx-2503) wrote :

Just exit xchat (xchat/exit) and crash...

Neil J. Patel (njpatel) on 2011-09-29
Changed in unity:
importance: High → Critical
Changed in unity:
status: Triaged → Fix Committed
Changed in compiz (Ubuntu Oneiric):
status: In Progress → Fix Committed
Didier Roche (didrocks) on 2011-09-29
Changed in unity:
status: Fix Committed → Fix Released
Bartek (styk444) on 2011-10-09
Changed in compiz (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in unity (Ubuntu Oneiric):
status: New → Won't Fix
Will Cooke (willcooke) on 2015-09-16
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers