Ubuntu

compiz crashed with SIGSEGV in XFindOnExtensionList()

Reported by DanielFCaicedoT on 2011-09-21
306
This bug affects 84 people
Affects Status Importance Assigned to Milestone
Unity
High
Sam Spilsbury
compiz (Ubuntu)
High
Sam Spilsbury
Oneiric
High
Sam Spilsbury

Bug Description

las ventanas no estan cambiando con el alt+tab

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: compiz-core 1:0.9.5.94+bzr2803-0ubuntu5
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Es un directorio: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 280.13 Wed Jul 27 16:53:56 PDT 2011
 GCC version: gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3)
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu1
Architecture: amd64
CompizPlugins: [core,bailer,detection,composite,opengl,compiztoolbox,decor,vpswitch,resize,regex,grid,move,mousepoll,gnomecompat,place,snap,imgpng,wall,animation,fade,workarounds,expo,scale,session,unitymtgrabhandles,ezoom,unityshell]
CompositorRunning: compiz
CrashCounter: 1
Date: Wed Sep 21 18:41:24 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 280.13, 3.0.0-11-generic, x86_64: installed
 nvidia-current, 280.13, 3.0.0-9-generic, x86_64: installed
 vboxhost, 4.1.2, 3.0.0-11-generic, x86_64: installed
ExecutablePath: /usr/bin/compiz
GraphicsCard:
 nVidia Corporation GT216 [GeForce GT 330M] [10de:0a29] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: Toshiba America Info Systems Device [1179:fd30]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110903)
JockeyStatus:
 xorg:nvidia_current - Controlador para tarjetas gráficas NVIDIA (Privativo, Activado, En uso)
 kmod:nvidia_current - nvidia_current (Privativo, Desactivado, No está en uso)
MachineType: TOSHIBA Satellite A665
ProcCmdline: compiz
ProcEnviron:
 LANGUAGE=es_CO:es
 PATH=(custom, no user)
 LANG=es_CO.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-11-generic root=UUID=f7cf0c8a-bebb-487f-a517-4e41ae060687 ro quiet splash vt.handoff=7
SegvAnalysis:
 Segfault happened at: 0x7f620f396649 <XFindOnExtensionList+25>: cmp %esi,(%rax)
 PC (0x7f620f396649) ok
 source "%esi" ok
 destination "(%rax)" (0x000000f1) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: compiz
StacktraceTop:
 XFindOnExtensionList () from /usr/lib/x86_64-linux-gnu/libX11.so.6
 ?? () from /usr/lib/nvidia-current/libGL.so.1
 glXReleaseTexImageEXT () from /usr/lib/nvidia-current/libGL.so.1
 TfpTexture::~TfpTexture() () from /usr/lib/compiz/libopengl.so
 TfpTexture::~TfpTexture() () from /usr/lib/compiz/libopengl.so
Title: compiz crashed with SIGSEGV in XFindOnExtensionList()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 09/14/10
dmi.bios.vendor: TOSHIBA
dmi.bios.version: 1.80
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: NWQAA
dmi.board.vendor: TOSHIBA
dmi.board.version: 1.00
dmi.chassis.asset.tag: *
dmi.chassis.type: 9
dmi.chassis.vendor: TOSHIBA
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnTOSHIBA:bvr1.80:bd09/14/10:svnTOSHIBA:pnSatelliteA665:pvrPSAW3U-0DG03C:rvnTOSHIBA:rnNWQAA:rvr1.00:cvnTOSHIBA:ct9:cvrN/A:
dmi.product.name: Satellite A665
dmi.product.version: PSAW3U-0DG03C
dmi.sys.vendor: TOSHIBA
version.compiz: compiz 1:0.9.5.94+bzr2803-0ubuntu5
version.ia32-libs: ia32-libs 20090808ubuntu22
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

DanielFCaicedoT (dfcaicedo) wrote :

StacktraceTop:
 XFindOnExtensionList (structure=0xd914d0, number=11) at ../../src/InitExt.c:120
 ?? () from /tmp/tmpRlKos1/usr/lib/nvidia-current/libGL.so.1
 glXReleaseTexImageEXT () from /tmp/tmpRlKos1/usr/lib/nvidia-current/libGL.so.1
 TfpTexture::~TfpTexture (this=0x5729420, __in_chrg=<optimized out>) at /build/buildd/compiz-0.9.5.94+bzr2803/plugins/opengl/src/texture.cpp:435
 TfpTexture::~TfpTexture (this=0x5729420, __in_chrg=<optimized out>) at /build/buildd/compiz-0.9.5.94+bzr2803/plugins/opengl/src/texture.cpp:445

Changed in compiz (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
visibility: private → public
Changed in compiz (Ubuntu Oneiric):
status: Confirmed → Triaged
importance: Medium → High
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
milestone: none → ubuntu-11.10
tags: added: rls-mgr-o-tracking
David Barth (dbarth) on 2011-09-23
Changed in compiz (Ubuntu Oneiric):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Sam Spilsbury (smspillaz)
Changed in unity:
assignee: nobody → Sam Spilsbury (smspillaz)
importance: Undecided → High
status: New → Triaged
milestone: none → 4.20.0
Sam Spilsbury (smspillaz) wrote :

This looks like a broken driver. There's no reason why glXReleaseTexImageEXT would crash, at least reading http://www.opengl.org/registry/specs/EXT/texture_from_pixmap.txt. Unless a lot of people can reproduce this, we'll need to consider things other than this.

I'm going to double check that with RAOF though.

Omer Akram (om26er) wrote :

Looking at all the duplicate bug reports, this is specific to nvidia binary blob.

Rainer Rohde (rainer-rohde) wrote :

This happens just now when right-clicking on the thunderbird icon in the launcher, and at first it was unresponsive; the second time around I was able to quit thunderbird, but the whole desktop became unresponsive then compiz crashed...

Regression (gitsfans) wrote :

Same here with but with Firefox. I try to close an instance of Nautilus via Menu/File/Quit and the desktop freezes and after few seconds recover from compiz crash with firefox down. I started a new instance of firefox and found that even the download windows of firefox was still active.

 sudo apt-get install gtk2-engines-pixbuf

Michael Flaig (mflaig) wrote :

In my case compiz crash and after recovery all terminals had crashed.
Nautilus was also about to crash. Still was there but unresponsive

Still there is something not all right with Xorg and compiz after the restart of compiz.
Both Xorg and compiz eating a lot more cpu and system is a bit laggy

Rory Holland (blazemore) wrote :

I can confirm this crashes with fglrx driver.

Roman Yepishev (rye) wrote :

In my case it happened when I tried to minimize the windows.
After compiz restart the performance became unbearable. I have filed this as LP:859705 in case something can be done for it.

Bryce Harrington (bryce) wrote :

It looks to me like an incorrect pointer is being passed from NVIDIA's GL blob into XFindOnExtensionList(), so I concur with Sam's analysis that it's a driver bug, probably specific to -nvidia. This should be escalated to NVIDIA.

Bryce Harrington (bryce) wrote :

Rory, logs and backtrace or it didn't happen.

(This looks much like an NVIDIA-specific bug so far. If -fglrx has a similar crash, it could be coincidental, but should be investigated in its own right regardless, so please file a separate bug report.)

Changed in unity:
status: Triaged → Fix Released
Changed in compiz (Ubuntu Oneiric):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers