Compiz on Kubuntu Oneiric does not show panels

Bug #852061 reported by fejes on 2011-09-16
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

After a recent update this week, the latest version of compiz appears to prevent panels from showing up in KDE.

1) I am using Kubuntu Oneiric with all packages up to date.
2) The problem first occured in the past week, and is still present in compiz 1:0.9.5.94+bzr2803-0ubuntu5)
3) What I expect: When logging into Kubuntu, I should have the desktop appear, windows should appear, and the panel(s) should appear. Compiz should start, and I should be able to use compiz as I would use kwin, as a window manager.
4) What happens: when logging into Kubuntu, I see the desktop appear, I see a few windows appear, but the panels never show up. Compiz starts, and I can rotate the desktop cube, but I never have access to the menus or tools on the panel.
5) workaround. I can can right click on the desktop, and select "run command", then type in "kwin --replace". Immediately, my panels appear, and compiz is turned off.

I still prefer to use compiz over kwin, so I would appreciate if anyone could tell me why panels are being blocked by compiz - or if I need to change a setting somewhere to make it work.

(KDE compatibility is turned on in CCSM, although the KDE/QT event loop integration is turned off.)

fejes (anthony-fejes) wrote :

This problem is still present, however, if I switch back to compiz, (compiz --replace), the panel remains, and I can continue using compiz as before. However, further bugs now show up.

I can no longer close the panel settings dialog. Previously, attempting to close the panel settings dialog would cause compiz to hang (taking 100% cpu), although that now seems to no longer be the case. Instead, the panel settings dialognow remains open, and can not be hidden. (It is also present on all desktops. Oddly enough, I can click on things underneath (as the panel settings dialog is semi transparent... opening and "closing" it multiple times just makes it less and less transparent, although I can still click on things below, though I can no longer see them)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
The Punisher (melprinsi) wrote :

I confirm the bug; I tested Compiz over Nvidia and ATI proprietary drivers; same result.

fejes (anthony-fejes) wrote :

I have started using Pickled Penguin... er... Precise Pangolin. The bug is still present and still a show stopper. Kubuntu can not be used with Compiz as long as panels do not appear.

fejes (anthony-fejes) wrote :

As of this morning, using KDE 4.8, the bug appears to be fixed. I don't know which of the 4.8 packages fixed it, but it's now working as expected upon restart with the current build.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers