Small lag in nvidia performance mode 'upscaling' when needed by compiz, ect.

Bug #843383 reported by Doug McMahon on 2011-09-06
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Unity
Confirmed
Undecided
Unassigned
compiz (Ubuntu)
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned

Bug Description

I see this quite plainly with rotate and desktop based viewport switching, (scroll on desktop), where after a short period of idle there is always an initial lag when switching desktops, after which all is normal till next idle period.
A more generic case -

Open any non maxed window, a terminal will do
Grab and move the window, it does so easily and smoothly
Do nothing for about 30 -40 secs
Grab and move the window again, there is a small lag and stickiness to the movement, after a sec or 2 compiz 'catches 'up and goes back to normal

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: compiz 1:0.9.5.92+bzr2791-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic i686
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 280.13 Wed Jul 27 16:55:43 PDT 2011
 GCC version: gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-7ubuntu2)
Architecture: i386
CompizPlugins: [core,composite,opengl,decor,text,imgpng,compiztoolbox,fade,resize,mousepoll,cube,rotate,gnomecompat,vpswitch,move,scale,regex,expo,place,unityshell,scaleaddon]
CompositorRunning: compiz
Date: Tue Sep 6 19:19:58 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
DkmsStatus:
 nvidia-current, 280.13, 3.0.0-10-generic, i686: installed
 nvidia-current, 280.13, 3.0.0-9-generic, i686: installed
GraphicsCard:
 nVidia Corporation G86 [GeForce 8400M GS] [10de:0427] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: Dell Device [1028:0209]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110831)
JockeyStatus:
 xorg:nvidia_173 - NVIDIA accelerated graphics driver (Proprietary, Disabled, Not in use)
 xorg:nvidia_current-update - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, Not in use)
 xorg:nvidia_173-update - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
MachineType: Dell Inc. XPS M1330
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-10-generic root=UUID=ad432a25-9ac2-4357-9630-7b4a0dc3deb2 ro quiet splash vt.handoff=7
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/26/2008
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A15
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA15:bd12/26/2008:svnDellInc.:pnXPSM1330:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: XPS M1330
dmi.sys.vendor: Dell Inc.
version.compiz: compiz 1:0.9.5.92+bzr2791-0ubuntu2
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Doug McMahon (mc3man) wrote :
Doug McMahon (mc3man) wrote :

going to mark invalid because I see the same in unity-2d. ( though not in gnome-shell nor gnome-session-fallback w/ effects
So something is slightly amiss in unity*, where don't know

Changed in compiz (Ubuntu):
status: New → Invalid
Doug McMahon (mc3man) wrote :

As of an install of 11/04 only see this behavior in unity 3d so might as well re-open. If there is anything to it maybe it can be addressed for the 12.04 release.

Changed in compiz (Ubuntu):
status: Invalid → New
Alex Launi (alexlauni) wrote :

Don't experience this, but anyway does not appear to be a compiz bug if it's happening with 2d as well.

Changed in compiz (Ubuntu):
status: New → Invalid
Doug McMahon (mc3man) wrote :

I do only see this only in compiz now as per last comment, unity-2d, Gs, fallback are fine.
Anyway - tracked this down to the performance levels on nvidia card. When doing certain actions in compiz there is a small lag till the gpu bumps up to max performance from the lowest setting in the default adaptive mode.

Whether some or all nvidia cards show this small lag don't know, possibly it's a local hardware issue, don't have any other nvidia setups around to check. The response time of the card in 11.04 seems to be the same where I don't see this effect

Doug McMahon (mc3man) wrote :

Just to note: am judging the 'reported' bump up time from nvidia-setting which may not be reflective of how quickly the card actually does so.
In unity-2d, Gs & 11.04 (compiz 0.8) nvidia-settings reports the same, but only in 11.10 does this small lag show up.

Doug McMahon (mc3man) on 2011-10-15
summary: - lag in compiz after a short period of idle
+ Small lag in nvidia performance mode 'upscaling' when needed by compiz,
+ ect.
Changed in compiz (Ubuntu):
status: Invalid → New
Doug McMahon (mc3man) wrote :

I think this is a bug & regression
Now if it only affects me on this hardware well - too bad for me

The results of the lag are easiest seen when doing compiz actions after the performance mode has dropped down to the lowest (mode 0), moving a window is a decent test as prevviouslt outlined

This also can affect scrolling in browers, firefox in particular
Just to re note: not seen in unty-2d, gnome-shell, gnome-fallback, nor in 11.04 same hardware
Also obviously not seen when using nouveau

So I'm re-opening in case there are other laptop w/ nvidia-current users who can see the same behavior

tags: added: regression-release
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in compiz (Ubuntu):
status: New → Confirmed
Omer Akram (om26er) wrote :

is it bug 870181 you are facing, could you read the comment#4 there and try that, I just tried what you described in the description and the problem didn't happen (i use nvidia-current with 9800gtx+)

Omer Akram (om26er) on 2012-01-27
Changed in unity:
status: New → Confirmed
Doug McMahon (mc3man) wrote :

Omar - it is similar to 870181, just to note, the changes made by Daniel van Vugt have no effect here when using the nvidia drivers

Omer Akram (om26er) wrote :

Its now bug 764330, could you skim through it and see if there's a solution for you. You might want to wait for new compiz to land in precise to test as that release is exected to resolve things.

Doug McMahon (mc3man) wrote :

I'm now using 12.04 with compiz 0.9.7.0~bzr2995-0ubuntu1 & can say this has actually gotten worse. Most obvious affected are opening context menus & indicator menus.
When the nvidia performance level is at the lowest of 0, (default state) opening the menus lags & usually shows a clear box first

Additionally now the Dash open in a delayed fashion, may be other area's with degraded perf

This clearly may be hardware specific, possibly nvidia chips such as here (8400m) can no longer operate in a compiz env when @ performance level 0 & the upclocking is slow.

Though the changes to 0.9.7 have either made more operations require higher clock speed(s) or have otherwise degraded perf on chipsets like this with nvidia drivers

Changed in unity (Ubuntu):
status: New → Confirmed
To post a comment you must log in.