CTRL+ALT+T doesn't open a terminal anymore

Bug #820266 reported by Paolo Sammicheli on 2011-08-03
86
This bug affects 17 people
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
Medium
Didier Roche

Bug Description

ISO Testing Alpha3, install manual partitioning.

CTRL+ALT+T doesn't open a terminal anymore

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-7.9-generic 3.0.0
Uname: Linux 3.0.0-7-generic i686
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
Date: Wed Aug 3 11:48:54 2011
DistUpgraded: Fresh install
DistroCodename: oneiric
DistroVariant: ubuntu
GraphicsCard:
 nVidia Corporation G84 [GeForce 8600 GTS] [10de:0400] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:8241]
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110802.1)
MachineType: System manufacturer P5K-E
ProcEnviron:
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-7-generic root=UUID=2fdc104f-acad-4f09-8dd7-16ca82a0ae83 ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/25/2007
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0307
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5K-E
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0307:bd05/25/2007:svnSystemmanufacturer:pnP5K-E:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5K-E:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: P5K-E
dmi.product.version: System Version
dmi.sys.vendor: System manufacturer
peripherals:
 /desktop/gnome/peripherals/mouse:
   cursor_theme = DMZ-White
version.compiz: compiz 1:0.9.5.0-0ubuntu2
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11~1-0ubuntu4
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11~1-0ubuntu4
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu6
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.2-1ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.0-3ubuntu2
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Related branches

Paolo Sammicheli (xdatap1) wrote :
tags: added: iso-testing
Doug McMahon (mc3man) on 2011-08-05
Changed in unity (Ubuntu):
status: New → Confirmed
Download full text (3.2 KiB)

and why is this a unity bug?

On Fri, Aug 5, 2011 at 1:52 PM, Doug McMahon <email address hidden> wrote:
> ** Changed in: unity (Ubuntu)
>       Status: New => Confirmed
>
> --
> You received this bug notification because you are subscribed to unity
> in Ubuntu.
> https://bugs.launchpad.net/bugs/820266
>
> Title:
>  CTRL+ALT+T doesn't open a terminal anymore
>
> Status in “unity” package in Ubuntu:
>  Confirmed
>
> Bug description:
>  ISO Testing Alpha3, install manual partitioning.
>
>  CTRL+ALT+T doesn't open a terminal anymore
>
>  ProblemType: Bug
>  DistroRelease: Ubuntu 11.10
>  Package: unity 4.6.0-0ubuntu1
>  ProcVersionSignature: Ubuntu 3.0.0-7.9-generic 3.0.0
>  Uname: Linux 3.0.0-7-generic i686
>  Architecture: i386
>  CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
>  CompositorRunning: compiz
>  Date: Wed Aug  3 11:48:54 2011
>  DistUpgraded: Fresh install
>  DistroCodename: oneiric
>  DistroVariant: ubuntu
>  GraphicsCard:
>   nVidia Corporation G84 [GeForce 8600 GTS] [10de:0400] (rev a1) (prog-if 00 [VGA controller])
>     Subsystem: ASUSTeK Computer Inc. Device [1043:8241]
>  InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110802.1)
>  MachineType: System manufacturer P5K-E
>  ProcEnviron:
>   LANG=it_IT.UTF-8
>   SHELL=/bin/bash
>  ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-7-generic root=UUID=2fdc104f-acad-4f09-8dd7-16ca82a0ae83 ro quiet splash vt.handoff=7
>  SourcePackage: unity
>  UpgradeStatus: No upgrade log present (probably fresh install)
>  dmi.bios.date: 05/25/2007
>  dmi.bios.vendor: American Megatrends Inc.
>  dmi.bios.version: 0307
>  dmi.board.asset.tag: To Be Filled By O.E.M.
>  dmi.board.name: P5K-E
>  dmi.board.vendor: ASUSTeK Computer INC.
>  dmi.board.version: Rev 1.xx
>  dmi.chassis.asset.tag: Asset-1234567890
>  dmi.chassis.type: 3
>  dmi.chassis.vendor: Chassis Manufacture
>  dmi.chassis.version: Chassis Version
>  dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0307:bd05/25/2007:svnSystemmanufacturer:pnP5K-E:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5K-E:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
>  dmi.product.name: P5K-E
>  dmi.product.version: System Version
>  dmi.sys.vendor: System manufacturer
>  peripherals:
>   /desktop/gnome/peripherals/mouse:
>     cursor_theme = DMZ-White
>  version.compiz: compiz 1:0.9.5.0-0ubuntu2
>  version.libdrm2: libdrm2 2.4.26-1ubuntu1
>  version.libgl1-mesa-dri: libgl1-mesa-dri 7.11~1-0ubuntu4
>  version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
>  version.libgl1-mesa-glx: libgl1-mesa-glx 7.11~1-0ubuntu4
>  version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu6
>  version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
>  version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.2-1ubuntu2
>  version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.0-3ubuntu2
>  version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1
>
> To manage notificatio...

Read more...

Jean-Baptiste Lallement (jibel) wrote :

Terminal shortcut is defined in gnome-control-center/keyboard shortcut settings.

affects: unity (Ubuntu) → gnome-control-center (Ubuntu)
Changed in gnome-control-center (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
importance: Undecided → Medium
status: Confirmed → Triaged
Doug McMahon (mc3man) wrote :

IT is available in g-c-c- > keyboard > launchers in gnome-shell. If set there then it enables it in compiz > gnomecompat > commands where it is currently disabled by default
So unity should stop using gnomecompat and g-c-c instead

Didier Roche (didrocks) wrote :

It was on my TODO list, we'll have a second look later.

Changed in gnome-control-center (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Didier Roche (didrocks)
Omer Akram (om26er) on 2011-08-29
Changed in gnome-control-center (Ubuntu):
milestone: none → ubuntu-11.10-beta-2
Paolo Rotolo (paolorotolo) wrote :

I can confirm this bug on Ubuntu 11.10 Beta and Ubuntu DVD 11.10.
Also the Delete key (Canc) does not work...

Didier Roche (didrocks) on 2011-09-06
affects: gnome-control-center (Ubuntu) → compiz (Ubuntu)
Changed in compiz (Ubuntu):
milestone: ubuntu-11.10-beta-2 → none
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.5.92+bzr2791-0ubuntu2

---------------
compiz (1:0.9.5.92+bzr2791-0ubuntu2) oneiric; urgency=low

  * debian/rules, debian/compiz-gnome.install, debian/compiz-keybindings.sed:
    - readd and tweak some compiz keys for g-c-c and Gnome integration
      This fixes Ctrl + Alt + T to open a terminal (LP: #820266)
 -- Didier Roche <email address hidden> Tue, 06 Sep 2011 11:45:59 +0200

Changed in compiz (Ubuntu):
status: Triaged → Fix Released

This is still not fixed for me.

christopher@christopher-VirtualBox:~$ dpkg -s compiz | grep Version
Version: 1:0.9.5.92+bzr2791-0ubuntu2

Didier Roche (didrocks) wrote :

@Warrioring64: you need to reset it to ctrl + alt + T in gnome-control-center for people who have already upgraded (in the keyboard panel)

Ah, thanks! Working now.

Hadmut Danisch (hadmut) wrote :

Walter,

please see the file attached.

And no, I am not willing to do much more gymnastics for reporting bugs in methods that ubuntu keeps continuously changing and where it takes such hints to find out how to report a bug.

Within the last months, I've spent (wasted) several full workdays just for analyzing and reporting ubuntu bugs, just to find most of them ignored by ignorant maintainers who tend to close as invalid or mark as non fixed even without understanding the bug or by simply not wanting to fix the bug. Several of the bugs are not even bugs in the common sense but have been intentionally invented by poor system design or could have been prevented by regular work. Meanwhile I found several bugs - where programs crashed and unity asked me to report them - beeing closed automatically, because the "apport retracing service" says that I should have updated the system before and discards the bug report, just because it thinks that the packages are not the latest - although I just upgraded the system five minutes ago. It's just that german ubuntu mirrors lag behind. So I found myself beeing harassed just between two different programs.

And if I had been asked to report bugs to launchpad, but cannot do it in the way I had been asked and should read a long manual instead - I then again feel my time wasted.

I hate to say, but besides making the desktop worse with every release, ubuntu makes bug reporting more difficult (and even fruitless in most cases).

Paul Sladen (sladen) wrote :

According to bug #821505, this is still not fixed.

Paul Sladen (sladen) wrote :

Hadmut: I have filed the issue about Apport and lagging mirrors as bug #845754 now that you've raised it; and subscribed you to it. Hopefully Martin Pitt can have a look into what is happening.

Didier Roche (didrocks) wrote :

@Paul: it is fixed, the issue is that people who ran gnome-control-center in oneiric before this fix won't have the key assigned.
For them, they have to run gnome-control-center, go on keyboard/shortcuts/launchers -> run a terminal and assign back Ctrl + Alt + T.

People upgrading now from natty aren't affected.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers