dialogs really slow to be displayed since the compiz update

Bug #812711 reported by Didier Roche on 2011-07-19
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Compiz
Medium
Sam Spilsbury
Compiz Core
Medium
Sam Spilsbury
Unity
Fix Released
Medium
Sam Spilsbury
compiz (Ubuntu)
Medium
Sam Spilsbury
Oneiric
Medium
Sam Spilsbury
unity (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

1. Click on the power indicator
2. select close session
the dialog appearing looks like it "jumped" (seems to be due to a resize from the new unity dialogs to a normal window behavior, as this dialogs is shown with the unity dialog style in metacity).
This happens with a lot of gtkdialog (like "this program is already running")

Didier Roche (didrocks) on 2011-07-19
tags: added: 0.9.5.0
Sebastien Bacher (seb128) wrote :

confirmed, on my laptop i5 cpu with intel card I can see dialogs getting a wrong geometry and no decoration for some seconds then they get updated and display as they should, it happens with gedit, nautilus, apport dialog...not tested anything else yet but it's likely to not be software specific

Changed in compiz (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
importance: Undecided → High
status: New → Confirmed
Changed in unity:
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
importance: Undecided → High
status: New → Confirmed
summary: - Some dialogs jumps before appearing
+ dialogs really slow to be displayed since the compiz update
Sebastien Bacher (seb128) wrote :

the login is taking 15 seconds instead of 3 seconds to display the background as well since that update

David Barth (dbarth) on 2011-07-20
Changed in unity:
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Sam Spilsbury (smspillaz)
David Barth (dbarth) wrote :

As a stop gap measure, the new dialog style should be disabled until further analysis is done of the root cause for poor performance. There are other more important bugs to fix.

Changed in unity:
milestone: none → 4.4.0
importance: High → Medium
Changed in compiz (Ubuntu Oneiric):
importance: High → Medium
David Barth (dbarth) on 2011-07-21
Changed in unity:
milestone: 4.4.0 → 4.6.0
Didier Roche (didrocks) on 2011-08-01
Changed in unity:
milestone: 4.6.0 → 4.8.0
Changed in unity:
status: Confirmed → Fix Committed
Changed in compiz (Ubuntu Oneiric):
status: Confirmed → Fix Committed
Changed in compiz-core:
status: New → Fix Committed
importance: Undecided → Medium
assignee: nobody → Sam Spilsbury (smspillaz)
milestone: none → 0.9.6
Omer Akram (om26er) on 2012-01-20
Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Changed in compiz-core:
status: Fix Committed → Fix Released
Changed in compiz (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
Rolf Leggewie (r0lf) wrote :

oneiric has seen the end of its life and is no longer receiving any updates. Marking the oneiric task for this ticket as "Won't Fix".

Changed in unity (Ubuntu Oneiric):
status: New → Won't Fix
Changed in compiz:
assignee: nobody → Sam Spilsbury (smspillaz)
importance: Undecided → Medium
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers