Ubuntu

[regression] Compiz Resize plugin: When "Default Resize Mode" = Normal, resizing is extremely slow and CPU intensive

Reported by Guillaume on 2011-06-29
166
This bug affects 34 people
Affects Status Importance Assigned to Milestone
Compiz
High
Unassigned
Compiz Core
High
Unassigned
Ubutter
Undecided
Unassigned
compiz (Ubuntu)
Undecided
Unassigned

Bug Description

I always use normal resizing with compiz before, but when I upgraded-it to 11.04, with the new compiz, I got a very very slow resize about to one or two frame/second. I use now the rectangle before the fix. I hope this will be solved before 11.10

my compiz version is: 1:0.9.4+bzr20110606-0ubuntu1~natty1

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xorg 1:7.6+4ubuntu3.1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86_64 Kernel Module 270.41.06 Mon Apr 18 14:53:56 PDT 2011
 GCC version: gcc version 4.5.2 (Ubuntu/Linaro 4.5.2-8ubuntu4)
Architecture: amd64
CompizPlugins: [core,bailer,crashhandler,detection,composite,opengl,imgjpeg,decor,obs,imgsvg,grid,regex,vpswitch,imgpng,compiztoolbox,place,mousepoll,move,animation,notification,mag,showmouse,winrules,dbus,workarounds,screenshot,animationaddon,reflex,resize,text,session,gnomecompat,wall,wobbly,expo,ezoom,scale,scalefilter,scaleaddon,staticswitcher,unityshell,bench]
CompositorRunning: compiz
Date: Wed Jun 29 01:47:45 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus:
 virtualbox-ose, 4.0.4, 2.6.38-8-generic, x86_64: installed
 nvidia-current, 270.41.06, 2.6.38-8-generic, x86_64: installed
GraphicsCard:
 nVidia Corporation GT215 [GeForce GTS 360M] [10de:0cb1] (rev a2) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:203c]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
JockeyStatus: xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, Not in use)
MachineType: ASUSTek Computer Inc. G60JX
ProcEnviron:
 LANGUAGE=en_CA:en
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-8-generic root=UUID=d405ed83-489b-424c-8d7f-3f1b232cd18b ro quiet splash vt.handoff=7
Renderer: Unknown
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
XorgConf:
 Section "Device"
  Identifier "Default Device"
  Option "NoLogo" "True"
 EndSection
dmi.bios.date: 12/10/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 203
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: G60JX
dmi.board.vendor: PEGATRON CORPORATION
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: PEGATRON Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr203:bd12/10/2009:svnASUSTekComputerInc.:pnG60JX:pvr1.0:rvnPEGATRONCORPORATION:rnG60JX:rvr1.0:cvnPEGATRONComputerInc.:ct10:cvr1.0:
dmi.product.name: G60JX
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTek Computer Inc.
version.compiz: compiz 1:0.9.4+bzr20110606-0ubuntu1~natty1
version.ia32-libs: ia32-libs 20090808ubuntu13
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3.1
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Related branches

lp:~smspillaz/compiz-core/compiz-core.work_923683
Merged into lp:compiz-core/0.9.8 at revision 3110
Daniel van Vugt: Approve on 2012-04-24
Alan Griffiths: Approve on 2012-04-23
Sam Spilsbury: Pending requested 2012-04-19
Superseded for merging into lp:compiz-core
Daniel van Vugt: Needs Fixing on 2012-04-19
Sam Spilsbury: Pending requested 2012-04-18
Alan Griffiths: Pending requested 2012-04-18
Superseded for merging into lp:compiz-core/0.9.5
Daniel van Vugt: Resubmit on 2012-02-06
Alan Griffiths: Needs Fixing on 2012-02-02
Guillaume (gufide-g) wrote :
Richard van der Hoff (richvdh) wrote :

Is there anything we can do to help investigate this?

Changed in compiz (Ubuntu):
status: New → Confirmed

In my case there it's not slow: it doesn't work at all with some applications, it works normally with others.
The ones that don't resize are Firefox, Nautilus, evince, Thunderbird and Compiz Configuration Settings. To complete a resize I have to release the mouse button, only then the window resizes itself.
The applications that resize following the motion of my pointer are Terminal, Libreoffice (when I manage to grab its resize handle) and VirtualBox.
I didn't try other programs as I just updated from 10.10. I only tried Ubuntu Classic.
I'm using an ATI X1600 Mobility card. From my dmesg file:

[ 9.204295] [drm] radeon defaulting to kernel modesetting.
[ 9.204299] [drm] radeon kernel modesetting enabled.
[ 9.204370] radeon 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 9.204377] radeon 0000:01:00.0: setting latency timer to 64
[ 9.207041] radeon 0000:01:00.0: VRAM: 256M 0x0000000000000000 - 0x000000000FFFFFFF (256M used)
[ 9.207044] radeon 0000:01:00.0: GTT: 512M 0x0000000010000000 - 0x000000002FFFFFFF
[ 9.207119] radeon 0000:01:00.0: irq 46 for MSI/MSI-X
[ 9.207125] radeon 0000:01:00.0: radeon: using MSI.
[ 9.207154] [drm] radeon: irq initialized.
[ 9.208745] [drm] radeon: 256M of VRAM memory ready
[ 9.208750] [drm] radeon: 512M of GTT memory ready.
[ 9.210532] [drm] radeon: 1 quad pipes, 2 z pipes initialized.
[ 9.211533] radeon 0000:01:00.0: WB enabled
[ 9.559625] [drm] radeon: ring at 0x0000000010001000
[ 9.559794] [drm] radeon: ib pool ready.
[ 9.622084] [drm] radeon: power management initialized
[ 10.048794] fbcon: radeondrmfb (fb0) is primary device
[ 10.049009] fb0: radeondrmfb frame buffer device
[ 10.049019] [drm] Initialized radeon 2.8.0 20080528 for 0000:01:00.0 on minor 0

Setting the resize mode to stretch works for all applications but the inability to smoothly resize Firefox with mode Normal really affects web development so I'm considering to revert to the previous compiz as explained in http://www.webupd8.org/2011/05/how-to-downgrade-to-compiz-086-in.html

summary: - Normal resize with the new compiz is slow
+ Compiz Resize plugin: When "Default Resize Mode" = Normal, resizing is
+ extremely slow and CPU intensive

I'm seeing most of the CPU is consumed by Xorg. However I think that's misleading and it's not a driver/xorg issue at all. Because a very large amount of the CPU is also consumed by the app being resized. This means (almost certainly) that the problem is simply compiz sending too many resize events to the window. Haven't checked the source code yet to verify...

Daniel van Vugt (vanvugt) wrote :

Confirmed this is still a problem in oneiric. On an i7, nautilus is using 70% of a core just when resizing its window.

Changed in compiz-core:
status: New → Confirmed
importance: Undecided → High
Changed in compiz-core:
assignee: nobody → Daniel van Vugt (vanvugt)
status: Confirmed → Triaged
summary: - Compiz Resize plugin: When "Default Resize Mode" = Normal, resizing is
- extremely slow and CPU intensive
+ [regression] Compiz Resize plugin: When "Default Resize Mode" = Normal,
+ resizing is extremely slow and CPU intensive
Daniel van Vugt (vanvugt) wrote :

This might be a duplicate of bug 361573, but unlikely. This bug affects all windows whereas bug 361573 was just a couple of window types. Also, I suspect this bug is a regression in compiz 0.9, while the other bug is in compiz 0.8.

Daniel van Vugt (vanvugt) wrote :

Well, I have tried removing all the synchronization logic and everything that could cause feedback in the Resize plugin, and it made no difference. Good that deleting the code didn't make things worse. Bad that this bug still remains. Maybe it's something to do with the decorator?...

Any ideas Sam?

Changed in compiz-core:
assignee: Daniel van Vugt (vanvugt) → nobody
darkmatch (alexanderr-otto) wrote :

Still there on Ubuntu 12.04 Beta. Please fix that, normal resize should be able.

Daniel van Vugt (vanvugt) wrote :

I believe this was fixed with: lp:~smspillaz/compiz-core/compiz-core.work_923683
which was fix committed in lp:compiz-core (0.9.8) revision 3110.

Changed in compiz-core:
milestone: none → 0.9.8.0
status: Triaged → Fix Committed
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz:
milestone: none → 0.9.8.0
status: New → Fix Committed
importance: Undecided → High
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in compiz-core:
milestone: 0.9.8.0 → none
Changed in compiz-core:
status: Fix Committed → Triaged
Changed in ubutter:
status: New → Fix Committed
Changed in compiz:
status: Fix Committed → Fix Released
Daniel van Vugt (vanvugt) wrote :

This bug was fixed in the package compiz - 1:0.9.8.0-0ubuntu1

---------------
compiz (1:0.9.8.0-0ubuntu1) quantal-proposed; urgency=low

  * debian/control, debian/rules:
    - enable gles on armel and armhf
    - use dh-translations rather than custom code

  [ Sam Spilsbury ]
  * Enable OpenGL ES building
    - Refresh debian/patches/workaround_broken_drivers.patch
    - Remove non-ported plugins from compiz-plugins
    - Add FindOpenGLES2.cmake to compiz-dev

  [ Timo Jyrinki ]
  * New upstream release.
    - Code to make compiz work on GLES. This includes several changes
      to the compiz API. (LP: #201342) (LP: #901097) (LP: #1004251)
      (LP: #1037710)
    - Draft first 0.9.8.0 NEWS and bump VERSION
  * debian/patches/compiz-package-gles2.patch:
    - Remove, obsoleted by the upstream GLES work
  * Disable plugins that don't work on pure GLES on armhf/armel:
    - bench, firepaint, mblur, showmouse, splash, showrepaint, td, widget
 -- Sebastien Bacher <email address hidden> Fri, 31 Aug 2012 22:59:50 +0200

Changed in compiz (Ubuntu):
status: Confirmed → Fix Released
Changed in ubutter:
status: Fix Committed → Fix Released
Javier Melero (ricmelero) wrote :

Using ubuntu 12.10, the bug is still there.

I've set resize window mode to normal, then when I resize a windows, the app who's windows is being resized uses most of cpu.

Ubuntu 12.10, 64 bits, Fresh install.
Compiz 0.9.8.4.
NVIDIA Driver Version: 304.51

Hardware
vostro 1320,
intel core2duo q6600
4 gb ram, ddr2
video geforce 9300m

It is even much worse then before. Now on my machine (Intel Core i5 with integrated GPU) Ubuntu 12.10 (64) completely freezes for 10-20 secs, when I try to resize a window.

Esokrates (esokrarkose) wrote :

I can confirm this bug on Ubuntu 13.04 (latest update from December 5). The windows resize very slowly and the grey areas are very big. Furthermore there is a much too high cpu usage.

Compiz 0.9.9
(compiz 1:0.9.9~daily12.12.05-0ubuntu1)
NVIDIA Driver Version: 310.19
(Graphics Card: Nvidia Quadro 1000M)

I am ready to help with testing.

Daniel van Vugt (vanvugt) wrote :

This bug is marked Fix Released in 0.9.8.

If there is a regression of any sort, please log a new bug using this command:
    ubuntu-bug compiz
And move the discussion there.

But if you're using the NVIDIA driver, please look to bug 1027211 instead.

JP (caldas-lopes) wrote :

Same problem with an ATI Card on Ubuntu 12.10 64bits. Updated Compiz 1:0.9.8.4+bzr3412-0ubuntu0.1.
It happens with every driver, from the open-source to the closed latest beta.

Daniel van Vugt (vanvugt) wrote :

This bug is marked Fix Released in 0.9.8.

If there is a regression of any sort, please log a new bug using this command:
    ubuntu-bug compiz
And move the discussion there.

But if you're using the NVIDIA driver, please look to bug 1027211 instead.

Paulo Narciso (p-narciso) wrote :

Don't mark this bug as fixed because it's not.
I experience this bug in Ubuntu 12.10 using compiz_0.9.9~daily12.12.05bzr3517
Resizing is still very slow and cpu consuming.

Esokrates (esokrarkose) wrote :

I can confirm this bug as being driver independent. I have tested the nouveau driver and the issue is exactly the same. This bug is definitely not fixed and should be reopened.

Daniel van Vugt (vanvugt) wrote :

The fix for this bug was released over three months ago. I agree this does not always mean the bug was fixed properly. Maybe something was missed. Maybe something regressed. Or maybe you have some graphics driver that was never tested. It happens.

To help our workflow, help us find the remaining issues sooner, and to be able to fix the remaining issues sooner, please log a new bug:
    ubuntu-bug compiz

Nvidia users, please look at bug 1027211 instead.

mehmet (mehmet-nrl) wrote :

Normal resizing still so slow with mesa gallium drivers.

Daniel van Vugt (vanvugt) wrote :

Please log a new bug if you still have problems. Bug 1027211 really needs to be made just about moving windows. We want to treat resizing separately.

Elijah Lynn (elijah-lynn) wrote :

Still an issue on 13.04 w/compiz 0.9.9.0. Too lazy to file new bug.

Normal is unusable. Very hard to do responsive web development like this.

Changed in compiz:
assignee: Sam Spilsbury (smspillaz) → nobody
Changed in compiz-core:
assignee: Sam Spilsbury (smspillaz) → nobody
To post a comment you must log in.