Mouse can enter "no go" area of dual monitor setup

Bug #792164 reported by Mark Johnson on 2011-06-03
This bug affects 1 person
Affects Status Importance Assigned to Milestone
compiz (Ubuntu)
xorg-server (Ubuntu)

Bug Description

Binary package hint: nautilus

I will attach a diagram of my monitor layout. The builtin monitor is set to 1024x768. The external monitor is set to 1920x1080 and is positioned above the built-in. The right hand edge of the two monitors line up. This leaves a rectangular "no go" area on the lower left, where the mouse cursor should be unable to go. However, it can enter this area.

The Launcher appears on the built-in monitor. However, it does not appear when the mouse cursor reaches the left hand edge of the monitor. One must continue moving the mouse cursor, through the "no go" area to reach the left edge of the "no go" area before the Launcher appears. Then, one must move the mouse cursor back to the right until it reappears on the built-in monitor and then get it back into the Launcher before that disappears.

What I expect should happen is that the Launcher should appear when the mouse cursor reaches the left edge of the built-in monitor.

With the mouse cursor in the external monitor, the Launcher appears when the cursor reaches the left hand edge of the external monitor. This is reasonable. This edge is also lined up with the left edge of the "no go" area.

Another expectation I have that is not honored in this scenario is that the mouse acts as though it enters this "no go" area. See above about having to move the mouse further left after it disappears off the left edge of the built-in before the Launcher appears. Another example is that the mouse can be moved off the bottom edge of the external monitor into the "no go" area. One must then move the mouse significantly to the right before it appears in the built-in monitor.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: nautilus 1:
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
Date: Thu Jun 2 19:34:10 2011
ExecutablePath: /usr/bin/nautilus
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

Mark Johnson (mrj001) wrote :
affects: nautilus (Ubuntu) → compiz (Ubuntu)

Compiz is not in charge of the pointer. I tried to make it restrict movement
with concentric input windows last cycle and that didnt work.
On Oct 20, 2011 3:58 PM, "Sebastien Bacher" <email address hidden> wrote:

> ** Package changed: nautilus (Ubuntu) => compiz (Ubuntu)
> --
> You received this bug notification because you are a member of compiz
> packagers, which is subscribed to compiz in Ubuntu.
> Title:
> Mouse can enter "no go" area of dual monitor setup
> To manage notifications about this bug go to:
> _______________________________________________
> Mailing list:
> Post to : <email address hidden>
> Unsubscribe :
> More help :

Changed in compiz (Ubuntu):
status: New → Invalid
Bryce Harrington (bryce) wrote :

Hey mrj001,

You filed this bug report against natty, but I see it's still open and
doesn't appear to have much activity recently. So, now that oneiric
is released and stable, this may be a good point for you to upgrade
and re-test if this issue is still present there.

If it's solved in the new release and you think it's worth backporting
the fix, please indicate that. Or if having the fix in the new release
is good enough, feel free to close out the bug (or let us know and we'll
close it.)

If it's not solved, leave the bug report open. I can't promise we'll
get to it (we get way more bugs filed than we can usually get to), but
your testing and feedback can help out if and when we do.

Changed in xorg (Ubuntu):
status: New → Incomplete
Bryce Harrington (bryce) on 2011-11-18
affects: xorg (Ubuntu) → xorg-server (Ubuntu)
bugbot (bugbot) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xorg-server (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints