always on top windows don't remain always on top when there is a fullscreen window active

Bug #789827 reported by Sam Spilsbury on 2011-05-29
18
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Sam Spilsbury
compiz (Ubuntu)
Undecided
Sam Spilsbury
unity (Ubuntu)
Undecided
Sam Spilsbury

Bug Description

Binary package hint: compiz

See the description, fullscreen a window, mark another one always on top, the always on top one doesn't end up on top of the fullscreen one when really it should.

EDIT: We can't fix the original bug, however, this bug report was about making OnBoard stack above fullscreen windows, which we can now do.

Sam Spilsbury (smspillaz) wrote :

Quick note here that fixing this one seems to violate the EWMH, but it doesn't really make any sense to me that an always-on-top window should not be always on top when a fullscreen window is present.

Changed in unity:
milestone: none → 3.8.16
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
importance: Undecided → High
importance: High → Medium
status: New → Confirmed
Didier Roche (didrocks) on 2011-05-30
Changed in unity (Ubuntu):
status: New → Confirmed
David Barth (dbarth) on 2011-06-15
Changed in unity:
milestone: 3.8.16 → alpha2

This should be fixed by the application itself in this case:

http://mail.gnome.org/archives/wm-spec-list/2011-May/msg00016.html

On Wed, Jun 15, 2011 at 4:32 PM, David Barth <email address hidden> wrote:
> ** Changed in: unity
>    Milestone: 3.8.16 => alpha2
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/789827
>
> Title:
>  always on top windows don't remain always on top when there is a
>  fullscreen window active
>
> Status in Unity:
>  Confirmed
> Status in “compiz” package in Ubuntu:
>  New
> Status in “unity” package in Ubuntu:
>  Confirmed
>
> Bug description:
>  Binary package hint: compiz
>
>  See the description, fullscreen a window, mark another one always on
>  top, the always on top one doesn't end up on top of the fullscreen one
>  when really it should.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/unity/+bug/789827/+subscriptions
>

--
Sam Spilsbury

Didier Roche (didrocks) on 2011-07-05
Changed in unity:
milestone: 4.2.0 → 4.4.0
Didier Roche (didrocks) on 2011-07-21
Changed in unity:
milestone: 4.4.0 → 4.6.0
steubens (steubens) wrote :

i often have movies above firefox that is running fullscreen on windows; i would like to be able to do this with linux, i don't mind adding the properties to windows manually to use whatever facility might exist in the future to do it, but i'd like say; "always on top" from the compiz window decorator menu to have them on top of fullscreen windows, or at least an option i can change in ccsm to say that it's ok for _ABOVE to be on top of _FULLSCREEN :D

Didier Roche (didrocks) on 2011-08-01
Changed in unity:
milestone: 4.6.0 → 4.8.0
Changed in unity:
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Changed in compiz (Ubuntu):
status: New → Fix Committed
assignee: nobody → Sam Spilsbury (smspillaz)
Changed in unity (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
description: updated
Omer Akram (om26er) on 2011-12-08
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers