Switcher window borders are not properly unmapped with (unity|gtk)-window-decorator

Bug #789580 reported by glennric on 2011-05-28
104
This bug affects 22 people
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Sam Spilsbury
compiz (Ubuntu)
Medium
Sam Spilsbury
Natty
Undecided
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Unassigned

Bug Description

Binary package hint: compiz

Install compiz 1:0.9.4+bzr20110606-0ubuntu1~natty1 from natty-proposed.

Test case:
1. Show desktop.
2. Open a terminal from the menu, and move it away from the center of the screen where the switcher will appear. Make sure that it still has focus.
3. Hold down Alt-Tab to activate and show the switcher.
4. While the switcher is still visible move the mouse to a point above the very bottom of the gray switcher window. Within a pixel or two of the bottom is sufficient.
5. Release Alt-Tab.
6. Click at the mouse position found in step 4. The desktop should take focus.

I have noticed that this happens with both the "Static Application Switcher" and the "Application Switcher" compiz plugins, however it does not happen with the other switcher plugins.

Changed in compiz (Ubuntu):
status: New → Confirmed
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
Changed in unity:
status: New → Confirmed
importance: Undecided → Medium
Changed in compiz (Ubuntu):
importance: Undecided → Medium
Changed in unity:
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
milestone: none → 3.8.16
status: Confirmed → In Progress
Changed in compiz (Ubuntu):
status: Confirmed → In Progress
Didier Roche (didrocks) on 2011-05-30
Changed in unity (Ubuntu):
status: New → In Progress
Sam Spilsbury (smspillaz) wrote :

Test case:

0) Have an empty desktop with one window open and out of the way of where the switcher window will appear
1) Alt-tab
2) Move mouse to the very bottom of where the switcher window was (alt-tab again to check)
3) Click in that area and drag
4) You should see the nautilus selection rect

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in compiz (Ubuntu):
status: In Progress → Fix Committed
glennric (glennric) wrote :

Where is this fix available? I can build from source, I just need to know where to obtain this fixed source. Neither the bzr repository for unity-window-decorator, nor the git repository for compiz seem to have had any commits since this bug was posted.

Didier Roche (didrocks) on 2011-06-01
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Natty):
status: New → Fix Released
description: updated
Dmitry Shachnev (mitya57) wrote :

> Install compiz 1:0.9.4+bzr20110531-0ubuntu1 from natty-proposed
There is no such package, see https://launchpad.net/ubuntu/+source/compiz.

Also, this bug should not affect Unity, since I get this with Classic Ubuntu session.

Changed in compiz (Ubuntu Natty):
status: New → Confirmed
Dmitry Shachnev (mitya57) wrote :

My mistake, it affects Unity (U-w-d).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.4+bzr20110606-0ubuntu1

---------------
compiz (1:0.9.4+bzr20110606-0ubuntu1) oneiric; urgency=low

  * New bug fix release:
    - Switcher window borders are not properly unmapped with
      (unity|gtk)-window-decorator (LP: #789580)
    - maximized window is displaced (LP: #772612)
    - Unity launcher gets visible while screensaver is active (LP: #771391)
    - 1 pixel icons in notification-area-applet when compiz is the windows
      manager (LP: #767095)
  * debian/patches/00_bzr_fix_apps_without_startupid.patch:
    - removed: upstream
 -- Didier Roche <email address hidden> Mon, 06 Jun 2011 16:18:08 +0200

Changed in compiz (Ubuntu):
status: Fix Committed → Fix Released
Dmitry Shachnev (mitya57) wrote :

I can confirm that this bug is fixed in compiz 1:0.9.4+bzr20110606-0ubuntu1~natty1 from ppa:didrocks.

description: updated
Changed in compiz (Ubuntu Natty):
status: Confirmed → Fix Committed

Accepted compiz into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Dmitry Shachnev (mitya57) wrote :

OK with the version from -proposed.

description: updated
tags: added: compiz-0.9 verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package compiz - 1:0.9.4+bzr20110606-0ubuntu1~natty1

---------------
compiz (1:0.9.4+bzr20110606-0ubuntu1~natty1) natty-proposed; urgency=low

  * New bug fix release:
    - Switcher window borders are not properly unmapped with
      (unity|gtk)-window-decorator (LP: #789580)
    - maximized window is displaced (LP: #772612)
    - Unity launcher gets visible while screensaver is active (LP: #771391)
    - 1 pixel icons in notification-area-applet when compiz is the windows
      manager (LP: #767095)
  * debian/patches/00_bzr_fix_apps_without_startupid.patch:
    - removed: upstream
 -- Didier Roche <email address hidden> Wed, 01 Jun 2011 10:23:26 +0200

Changed in compiz (Ubuntu Natty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers