panels get stacked incorrectly on vp switch

Bug #788981 reported by Sam Spilsbury on 2011-05-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Unity
Fix Released
Medium
Sam Spilsbury
compiz (Ubuntu)
Medium
Sam Spilsbury
Natty
Undecided
Unassigned
Oneiric
Medium
Sam Spilsbury
unity (Ubuntu)
Medium
Unassigned
Natty
Undecided
Unassigned
Oneiric
Medium
Unassigned

Bug Description

Binary package hint: compiz

Install compiz 1:0.9.4+bzr20110531-0ubuntu1 from natty-proposed:

Test case:
1) Open a window fullscreen and another not fullscreen
2) Switch viewports
3) Open a window
4) Switch back to the previous viewprot
5) Alt-tab
5) Alt-tab again
6) Switch viewports again

When switching viewports with fullscreen windows to a nonfullscreened window, that window will end up on top of the panels.

Related branches

Changed in unity:
status: New → Confirmed
Changed in compiz (Ubuntu):
status: New → Confirmed
Changed in unity:
importance: Undecided → Medium
Changed in compiz (Ubuntu):
importance: Undecided → Medium
Changed in unity:
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
Changed in compiz (Ubuntu):
assignee: nobody → Sam "SmSpillaz" Spilsbury (smspillaz)
Changed in unity:
milestone: none → 3.8.16
Changed in compiz (Ubuntu):
milestone: none → natty-updates
Didier Roche (didrocks) on 2011-05-30
Changed in unity (Ubuntu):
status: New → Confirmed
Sam Spilsbury (smspillaz) wrote :

Test case

1) Open a window fullscreen and another not fullscreen
2) Switch viewports
3) Open a window
4) Switch back to the previous viewprot
5) Alt-tab
5) Alt-tab again
6) Switch viewports again

At no point should any of the two normal windows be allowed to float on top of the panel, nor at any point should one of those two windows be visible (eg above the fullscreen window) and also no panel visible. The panel should not be visible when the fullscreen window is on top.

Changed in unity:
status: Confirmed → Fix Committed
Changed in compiz (Ubuntu):
status: Confirmed → Fix Committed
Changed in unity (Ubuntu):
status: Confirmed → Fix Committed
Didier Roche (didrocks) on 2011-06-01
description: updated
Changed in unity (Ubuntu Natty):
status: New → Fix Released
Changed in unity (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released
Changed in compiz (Ubuntu):
status: Fix Committed → In Progress
Changed in unity:
status: Fix Released → In Progress
Changed in unity (Ubuntu):
status: Fix Released → In Progress
Changed in unity (Ubuntu Natty):
status: Fix Released → In Progress
Changed in unity:
milestone: 3.8.16 → backlog
Changed in compiz (Ubuntu):
milestone: natty-updates → oneiric-alpha-1
Sam Spilsbury (smspillaz) wrote :

Retargeting to oneric due to merge problems

Didier Roche (didrocks) on 2011-06-06
Changed in unity:
milestone: backlog → 3.8.16
David Barth (dbarth) wrote :

Same, this is a long term fix, not something that can land in a natty SRU.

Changed in unity:
milestone: 3.8.16 → none
Changed in compiz (Ubuntu):
milestone: oneiric-alpha-1 → oneiric-alpha-2
Changed in unity (Ubuntu):
importance: Undecided → Medium
milestone: none → oneiric-alpha-2
Changed in unity:
milestone: none → alpha2
Didier Roche (didrocks) on 2011-07-05
Changed in unity:
milestone: 4.2.0 → 4.4.0
Martin Pitt (pitti) on 2011-07-07
Changed in compiz (Ubuntu):
milestone: oneiric-alpha-2 → oneiric-alpha-3
Changed in unity (Ubuntu):
milestone: oneiric-alpha-2 → oneiric-alpha-3
Didier Roche (didrocks) on 2011-07-21
Changed in unity:
milestone: 4.4.0 → 4.6.0
Didier Roche (didrocks) on 2011-08-01
Changed in unity:
milestone: 4.6.0 → 4.8.0
Changed in compiz (Ubuntu Oneiric):
milestone: oneiric-alpha-3 → ubuntu-11.10-beta-1
Changed in unity (Ubuntu Oneiric):
milestone: oneiric-alpha-3 → ubuntu-11.10-beta-1
Martin Pitt (pitti) on 2011-08-31
Changed in compiz (Ubuntu):
milestone: ubuntu-11.10-beta-1 → ubuntu-11.10-beta-2
Changed in unity (Ubuntu):
milestone: ubuntu-11.10-beta-1 → ubuntu-11.10-beta-2
Dave Walker (davewalker) on 2011-09-23
Changed in compiz (Ubuntu):
milestone: ubuntu-11.10-beta-2 → ubuntu-11.10
Changed in unity (Ubuntu):
milestone: ubuntu-11.10-beta-2 → ubuntu-11.10
Changed in unity:
status: In Progress → Fix Released
Changed in unity (Ubuntu Natty):
status: In Progress → Fix Released
Changed in unity (Ubuntu Oneiric):
status: In Progress → Fix Released
Changed in compiz (Ubuntu Oneiric):
status: In Progress → Fix Released
Rolf Leggewie (r0lf) wrote :

natty has seen the end of its life and is no longer receiving any updates. Marking the natty task for this ticket as "Won't Fix".

Changed in compiz (Ubuntu Natty):
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers