Task bar icons don't show

Bug #787437 reported by Daniel Berntsson on 2011-05-24
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Compiz
Unknown
Unknown
compiz (Ubuntu)
Medium
Sam Spilsbury

Bug Description

Binary package hint: compiz

When wxWidgets creates task bar icons they are not shown. It can be replicated by starting the wxPython demo. This seems to be the problem:

http://trac.wxwidgets.org/ticket/13146#comment:4

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: compiz 1:0.9.4+bzr20110415-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
NonfreeKernelModules: wl
Architecture: i386
CompizPlugins: [core,bailer,detection,composite,opengl,decor,mousepoll,vpswitch,regex,animation,snap,expo,move,compiztoolbox,place,grid,imgpng,gnomecompat,wall,ezoom,workarounds,staticswitcher,resize,fade,unitymtgrabhandles,scale,session,unityshell]
CompositorRunning: compiz
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1024x600
 edid-base64: AP///////wAGr9IwAAAAAAESAQOAFg14CrmllllXkSgfUFQAAAABAQEBAQEBAQEBAQEBAQEBUBQAQEFYLCAYiDEA330AAAAYAAAADwAAAAAAAAAAAAAAAAAgAAAA/gBBVU8KICAgICAgICAgAAAA/gBCMTAxQVcwMyBWMCAKADw=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Tue May 24 09:17:59 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: bcmwl, 5.100.82.38+bdcom, 2.6.38-8-generic, i686: installed
GraphicsCard:
 Intel Corporation Mobile 945GME Express Integrated Graphics Controller [8086:27ae] (rev 03) (prog-if 00 [VGA controller])
   Subsystem: Acer Incorporated [ALI] Device [1025:022f]
   Subsystem: Acer Incorporated [ALI] Device [1025:022f]
LiveMediaBuild: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
LiveMediaBuild_: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
MachineType: Acer Aspire one
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: noprompt cdrom-detect/try-usb=true persistent file=/cdrom/preseed/hostname.seed boot=casper initrd=/casper/initrd.lz quiet splash -- maybe-ubiquity
ProcVersionSignature_: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Renderer: Unknown
SourcePackage: compiz
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/14/2009
dmi.bios.vendor: Acer
dmi.bios.version: V1.22
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Aspire one
dmi.board.vendor: Acer
dmi.board.version: V1.22
dmi.chassis.type: 10
dmi.chassis.vendor: Acer
dmi.chassis.version: V1.22
dmi.modalias: dmi:bvnAcer:bvrV1.22:bd10/14/2009:svnAcer:pnAspireone:pvrV1.22:rvnAcer:rnAspireone:rvrV1.22:cvnAcer:ct10:cvrV1.22:
dmi.product.name: Aspire one
dmi.product.version: V1.22
dmi.sys.vendor: Acer
version.compiz: compiz 1:0.9.4+bzr20110415-0ubuntu2
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu2
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

Daniel Berntsson (db-lysator) wrote :

Hi,

Thanks for taking the time to report this bug and help make Ubuntu better. I think you need to provide two things to help people out with creating this:

1.) A link to the file containing the demo which exhibits the problem - and if applicable the commands to run that demo.
2.) A screenshot of the buggy behaviour (i.e. where on the screen the icons don't show)

If you can provide this information then I may be able to confirm the bug.

Changed in compiz (Ubuntu):
status: New → Incomplete
wip (wipinmtl) wrote :

hi, here's more information (and also a screenshot):
http://trac.wxwidgets.org/ticket/13146

This is likely due to a broken window manager which claims to support _NET_REQUEST_FRAME_EXTENTS, but does not actually implement it.

maybe related to:
https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/334358?comments=all

there's no actual solution as for now, but a patch is available for wxwidgets (2.9.1 / 2.9.2) for "detecting WM with broken _NET_REQUEST_FRAME_EXTENTS handling". i think it should be fixed in compix and / or gnome and / or ubuntu 11.04

i can provide a way to test this bug, but you will need to compile wxwidgets (2.9.1 or svn) and compile taskbar sample.

Changed in compiz (Ubuntu):
status: Incomplete → Confirmed

When I run metacity --replace (of course this completely breaks unity) the problem is solved, so it is indeed something in compiz

Changed in compiz (Ubuntu):
assignee: nobody → Sam Spilsbury (smspillaz)
importance: Undecided → Medium
milestone: none → oneiric-alpha-3

Thank you for reporting this bug to Ubuntu. 11.04 reached EOL.
See this document for currently supported Ubuntu releases: https://wiki.ubuntu.com/Releases

Please upgrade to the latest version and re-test. If the bug is still reproducible, increase the verbosity of the steps to recreate it so we can try again.

Do feel free to report any other bugs you may find.

Changed in compiz (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.